Answered

Alexa cannot understand me - over and over and over again!

  • 15 October 2019
  • 15 replies
  • 157 views

Am I allowed to swear in here? Seriously, I’ve gone through all the steps multitudes of times and many of us know how much time it takes do do even a single cycle of resetting sonos controller and alexa etc. It will work for maybe 2 days and then the whole thing starts again! Why can’t Sonos FIX THIS?? Now it seems worse with the last update - as if that was even possible. Now when I try to use the sonos app it tells me one of my speakers is disconnected on an black screen with a ‘room settings’ icon - when I try to press that it simply loops back to the same screen with no results. The only option is to reset the controller. Great - that loops back to you having to log in again and either connect to an existing group or set up new. When you connect to the existing group it recognizes it just fine but then surprise surprise, it sends you back to the black screen saying one of your speakers is diconnected and the whole cycle starts again. If you try to instead start a new group, none of the speakers respond - they all have to be reset through power cycling! That’s very convenient of course when you’ve gone to great lengths to string wires and trying to unplug the power from the bottom of the speaker is even more difficult that the first option. 

SERIOUSLY SONOS - do you have the technological where withall to fix your products or should I just return them to the store? 

icon

Best answer by John B 16 October 2019, 22:00

Sonos' view on hard resets? They achieve nothing. My view too. Whatever the problem is it WILL reappesr after a reset because the cause has not been addressed. And it deletes the diagnostics.

One question. Does your setup have a wired Sonos device or is it fully wifi?

View original

15 replies

My Sonos has worked perfectly for 7 years now.  These sort of problems turn out to be local network related in 99.5% of cases.  When you next have a problem, submit a system diagnostic and post the number back here.  Then you wil have kicked off the (hopefufly short) process of identifying the issue and getting your system working as it should.

SO I did the WHOLE thing over again and now some other bug is happening. OH SONOS you really know how to make something infuriating.

This time, full reset controller after full reset/rename wireless network. Both Sonos 1Gen2  successfully setup (after hard resets of them as well) however when the app went to register my speakers it would not be successful despite multiple ‘Try Again’s.  Then I closed the app and opened it again. Got a black screen telling me “We can’t find any speakers registered to your Sonos Account” with the button to “Register your Speakers” so I do that -- the next screen says Account update complete - Your speakers are now linked to your Sonos Account”  -- then I press done and guess what!!!???!! that’s right, back to the previous black screen telling me there’s no speakers registered to my account!

So then I reset the controller, restart the app, join existing group without an issue and it tells me to sign in to the associated account for the group which I do, again no problem…...and then!!!!! YUP -- black screen telling me there’s no registered speakers again!    Submit report #374185623

Userlevel 4
Badge +9

Have you tried calling Sonos?

None of this should be necessary. None of it is necessary.  Resets are particularly useless.  Good that you have submitted diagnostic. 

Silicone, 

Do you by any chance have a mesh WiFi network, like Google Hubs for example, or any Wifi repeaters, access points or even guest networks running in your home network setup?

Also do you have any network switches that are managed/unmanaged?

I ask these things because it sounds to me like either your controller or your speakers are switching, from time to time, to other access points, or networks, that are operating on different WiFi channels etc.

Can you kindly and just briefly describe your network setup? … thank-you. 👍

 

Nothing fancy on the network front. When i first got these speakers they worked fine on a more complicated setup. Right now I have my R7000 (stock with latest firmware) at the other end of the house with a hardwire connected access point (old Buffalo WZR-HP-G300 running openwrt - bridged connection, no DHCP, simple access point function). Further, there is not even a semi-attempt at unified or mesh type operability - ie, the access point uses it’s own SSID and the speakers nor controller (on android) see any other network connections. None of my other networked wireless devices have any problems with this setup or other setups that try to unify logins via duplicate SSIDs.

 

The app still loops on registration of the speakers - the speakers are indeed on my account as verified on on sonos.com but as the app doesn’t acknowledge that, there seems to be a last command missing from the controller such that I can’t see the speakers in any other app (no amazon music, spotify, and obviously no audio options through the sonos app). Not trying to be dramatic but I’d rather throw them from the window than have to reset everything again. I think what bugs me most is that repeatedly even after full hard reset rituals, despite the speakers ‘existing’, recognized in my account and having previously worked for a couple days at a time, doing a network hard reset does not work to bring these speakers back into functioning connectivity! I’ve never personally seen any other network device fail to actually sort itself out after a simple network infrastructure reboot let alone what we’re asked to do here on a regular basis - a full network reset, unloading of voice services, resetting software controllers, and power off/on the speakers - does nothing! Even when you go one step further and fully power cycle and reset the speakers in concert with all the other activities - you get to this point which still seems like a crap shoot if they will work with Alexa even for a day or two!  I’m guessing if I left Alexa out of the equation it might be different however Google assistant is a joke on these speakers - they aren’t seemingly authorized to do anything google music or youtube music without paid tiers. I’ve got amazon music, which isn’t a music service on it’s own in sonos app so Alexa is necessary for any type of automation - I don’t think I should have to pick up another device everytime I want my Sonos to do something.

Have you tried calling Sonos?

 

It’s a bit of a nightmare thinking of spending ½ hour on the phone with someone who’s going to have me perform full hardware resets, controller and services re-installs, and taking the speakers to the other end of the house all to prove a successful tech solution - which will fail again in two days (or so) time leaving me and apparently so many others back as square one, wondering why Amazon sold these to me in the first place. I’m not sure I would label these as Alexa enabled or supported hardware.

Sonos' view on hard resets? They achieve nothing. My view too. Whatever the problem is it WILL reappesr after a reset because the cause has not been addressed. And it deletes the diagnostics.

One question. Does your setup have a wired Sonos device or is it fully wifi?

Fully Wireless..and while true hard resets do not seem to fix the issues they gave become necessary because the speakers become non-responsive, locked in a loop! When Alexa doesn't understand it indicates more than just voice services - as stated earlier, removing services, unlinking accounts, removing skills, etc does not return control to the Sonos app.....the speakers are 'lost' and simple unplugging does not change the state upon power on... Now this latest example, Sonos app shows them stuck in a loop of not registered despite the fact they are - the app loops back and forth and doesn't finalize or 'announce' them so again, though they are seen by the app and show in my Sonos account online, they are completely unresponsive to any other app including the Sonos app which as stated is looping. Restarting the app and reinstall does not change that.  

I don't know what is causing your issues but your experience is totally abnormal.  No comfort to you, I know. There has to be something or possibly things particular to your setup and network that is causing this.

I am hoping that a Sonos staff member will take a look at the diagnostic and pick this up.

Userlevel 4
Badge +9

I would still urge you to give Sonos a chance to find out what’s causing this behavior. You seem to have exhausted your ways to deal with this. A solution could be letting someone else take a look at your system - preferably someone with knowledge. There are no guarantees here, but calling Sonos would be my first step from here.

I shall just add one further point.  The ‘everything else works fine on my network’ may well be true but doesn’t really prove anything.  Sonos DOES make greater demands on a network because it involves several devices (speakers and controllers) that have to constantly stay in touch.  Even something like having access points and routers on different wireless channels can disrupt communications.  Running in SonosNet mode (one wired Sonos device) rather than purely WiFi is a way of avoiding that and many other issues, but I suspect that won’t be sufficient to resolve your problems.  (Might be worth an experiment though.)

 

Userlevel 7
Badge +26

Hi @silicone, I just took a look at that diagnostic you posted above. It only partially was able to go through, which usually is indicative of local network trouble. From what I could find there, it looks like there are a lot of wireless networks nearby. Are you in a neighborhood with lots of neighbors?

Inconsistent system issues that include dropping players, services being unreachable, and music not playing properly tend to be caused by something that’s also variable, such as networking and wireless trouble. Sometimes connections work, and sometimes they fail, which would be the root of what you’re describing.

Running on SonosNet might be a good test, try wiring in the left side of the pair as that is the one that is in charge. 

Ultimately, it would be best for you to give us a call and work with a technician to sort out these issues. They’ll be able to help identify what’s going on, just make sure you explain the sorts of insonsistent issues you’ve been having, so that they don’t just try to help with the current one, and take some time to do some network reliability tests.

Just thinking is your router duel frequency. I had a problem and have split mine so it looks like I have two networks.  From memory sonos doesn't like. 5GHz just a thought

 

Just thinking is your router duel frequency. I had a problem and have split mine so it looks like I have two networks.  From memory sonos doesn't like. 5GHz just a thought

silicone
In addition to having differently named SSID’s for the two WiFi bands, also switch off ‘airtime fairness’ on the router, if that feature is available on your router model.

Reply