Alexa and Sonos on different IP ranges

  • 10 November 2021
  • 3 replies
  • 40 views

Hi, I am hoping someone has already experienced this problem and can offer some help. I am moving my IOT onto a vlan slowly. I have moved Alexa on to 192.168.2.x which is isolated from my main network 192.168.1.x.

The integration between Alexa and SONOS has stopped working, ok this is probably because it cannot see the SONOS devices, attempts to delete and re-install Alexa and SONOS integrations have worked but Alexa cannot discover the SONOS and in the Beam enabling Alexa works up to the point of logging into the Alexa account with the error “There was a problem adding Alexa, try again”. Useful information ! 

I thought it might be I need to open some ports in the firewall to allow local Alexa to talk to SONOS but then Alexa can see my Hive and Home Assistant networks and they are still  on 192.168.1.x. 

Anyone got any suggestions, other than moving SONOS to the 192.1.68.2.x network as I cannot shift SONOS yet because the music library is also still on 192.168.1.x. 

 

Thanks 


3 replies

It should work. An Echo Dot of mine can control Sonos devices on a different subnet. The Alexa-Sonos control bridge lives in the cloud.

Userlevel 7
Badge +20

Please see my old post here for resolving generic Alexa issues:

The integration between Sonos and Amazon can sometimes throw up annoying, confusing and sometimes completely random issues.  A very large proportion of these issues can be resolved by some very simple tasks.  These have been documented across multiple posts and have remained fairly consistent since the functionality was released.  However, some of my earlier posts are now obsolete due to changes within the navigation and terminology of both the Sonos and Alexa Apps.  As a result, I have compiled an updated set of steps to help users resolve the most common issues.  However, before we start please don’t get phased by the scale of the steps below, they are not all required! I have tried to list these with the most common and easiest solutions first building to a complete reset.  But before we start, if you are experiencing issues with Alexa, then please check for any outages on this page first: Sonos Status

 

Duplicate device names – Although Amazon states that Alexa has the ability to know the different actions for different device types, my experience is Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App and press the ‘Devices’ button in the bottom right of your device.  You’ll need to make a note of any duplicate names, a common mistake is to have a Room and a Device with the same name. I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Bedroom Sonos, etc. Although this would appear to make the voice control of devices more complicated, the use of Groups, removes the need to name these specific Device names in most voice commands.  Here is a link to my naming standards:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players.
1.3/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.

 

Please Retest


Account Linking - Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps one at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ If you have multiple Amazon accounts logged into different Apps on your device, this can confuse the Amazon Authorisation. Please ensure that you log out of all Amazon related Apps and accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for at least 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

 

Please Retest


Duplicate IP Address – Please see my Post here: en.community.sonos.com

 

Please Retest

Thanks guys, when I moved Alexa I thought it would be via the cloud. The problem seems to be logging into Amazon when setting up the Sonos App. I have deleted both apps and re-installed with no change.  Will continue to explore potential solutions. Good to know that its unlikely to be the vlan configuration causing the problem, which is logical since Alexa can access the all the other skills. 

Reply