Setting up Sonos with Eero WiFi system


  • Contributor I
  • 0 replies
I have had trouble getting my Sonos system to work for the past few months, since installing an Eero WiFi system, and I wanted to share what I learned so that I help others avoid the headaches and hassle.



The problem: After installing a network of Eero WiFi devices (three eero Pro devices and one eero Beacon extender), my Sonos system stopped working reliably (would not connect, drop devices, etc.). I tried restarting, reinstalling units, etc., etc., without success.



The solution: Over the past two weeks, I have read a number of posts on this Sonos support site that helped me get the system working again today. Here is what I did and some comments on my system:




  • Enabled "Bridge Mode" on our Xfinity Wireless Gateway device -- got instructions on how to do so on the Comcast website (need to log in from your internet browser and follow a few steps)
  • Connected the eero Pro device that was indicated as the "gateway" (was the only device that my eero app showed as being the "gateway") with the Xfinity Wireless Gateway (Ethernet cord/connection)
  • Plugged our Ethernet switch to the other Ethernet port (the one not used to connect to the Xfinity Wireless Gateway) in the "gateway" eero Pro
  • Our other Eero Pros are connected to that same switch (or a second switch connected into the first switch)
  • Some of our Sonos devices are connected via Ethernet to the second switch
  • Other Sonos devices are connected to the eero WiFi network
  • I am able to control the Sonos system from an iMac connected via Ethernet to one of the eero Pros (not the "gateway" Pro, but another one that is wired into the first switch)
  • And, I am able to control the Sonos system from my iPhone using our eero WiFi network
  • So, it appears that everything is working again (fingers crossed)

So, that's what worked for me. My impression is that the critical steps were:




  • Enabling "Bridge Mode" on the Comcast/Xfinity modem
  • Connecting the "gateway" eero device to the Comcast/Xfinity modem
  • Then, connecting the switch, from which all other devices on our network stem from, to the other port on the "gateway" eero device

My thanks to all the other people who have posted to this support site. Your comments and ideas helped me figure out the solution above. My hope in posting this is that I can help others who have cable modems (like the Xfinity product) and eero WiFi. I'll check back in a couple times to see if others have questions that I can help answer. And, of course, my guess is that many others can edit and improve on what I've written above.



Thanks, again, to everyone who contributes to this site. I could not have gotten my system back up and working without all the help/support from this community.

22 replies

Apart from the 'bridge mode' aspect, the key point is that you wired at least one Sonos device, putting the system into SonosNet mode.



You say some Sonos devices are still connected to the eero WiFi. I hope not, since this could lead to instability. They should be connecting to SonosNet. Check in About My Sonos System. WM:0 means SonosNet (or wired).



You'd also be advised to remove any eero WiFi credentials from the Sonos system. This will prevent devices from reverting to a WiFi connection.

I had several weeks of hell as well when I swapped out my Orbi mesh system. After constantly have to re-find units (we have 7 in 4 rooms) , one time a hard reset and start from scratch.

I started out with support and it was pretty clear they would be more wasting my time than anything, and found a few threads here that pointed to the cause.

Turns out the problem was simple, for some reason each Eero issues its own DHCP, so none of the suggestions are going to fix it. It takes <5 minutes to put the Eero into bridge mode and everything goes away. And you can if wish, use the ethernet ports on the Eero pro, which are helpful

Given how many people have complained about this on Amazon and here, its about time SONOS and Eero got their act together. Eero was a least responsive and competent, Sonos didnt even appear to be reading the email trail (asked 2x for diagnostics which has sent 2x) from person to person. Don’t assume they are networking savvy...

 

I was having same problem with EERO’s system; my iOS controller for SONOS was being intermittent.  Putting the EERO into bridge mode seems to have solved the problem.  Very wierd because the SONOS was “connected” via wifi only and I could determine it was up and stable on the mesh network but the iOS controller did not work.  It seems to NOW work in the BRIDGE mode on EERO’s.  Simple fix via settings and reboot.

I had several weeks of hell as well when I swapped out my Orbi mesh system. After constantly have to re-find units (we have 7 in 4 rooms) , one time a hard reset and start from scratch.

I started out with support and it was pretty clear they would be more wasting my time than anything, and found a few threads here that pointed to the cause.

Turns out the problem was simple, for some reason each Eero issues its own DHCP, so none of the suggestions are going to fix it. It takes <5 minutes to put the Eero into bridge mode and everything goes away. And you can if wish, use the ethernet ports on the Eero pro, which are helpful

Given how many people have complained about this on Amazon and here, its about time SONOS and Eero got their act together. Eero was a least responsive and competent, Sonos didnt even appear to be reading the email trail (asked 2x for diagnostics which has sent 2x) from person to person. Don’t assume they are networking savvy...

 

I’m having the same problem with Eero and Sonos, zones disappearing in Sonos but still show up in the Eero app. I have the Eero Pro, so three Eero devices that are all same, I just use one as a router. Am I still able to bridge my Eero? What is the downside of bridging the Eero system?

Userlevel 2
Badge +1

That all makes perfect sense from a networking point of view: “bridge” mode is almost certainly what is making it work, as that makes all the devices on your network properly visible and discoverable within one single broadcast domain.

Without that, you’ve got many small subnets being routed (or, at the least, proxy-arp’d) across your mesh. I’m really surprised they make that the default, tbh. So much will fail to discover other network devices, and which devices connect to which network will not be deterministic.

Not sure if this is the best place to post this. Hopefully will save some headaches…

I spent 3+ hours rebooting, resetting, reading documentation and forums, and on the phone with Sonos support without success. My Sonos Play One speakers all of a sudden stopped working with my Eero Pro Mesh network. I hadn’t used the speakers for a couple of weeks and the usual reboot methods that I occasionally use were failing.

The issue - In the Eero App (iOs) > Advanced settings > IPv6 > (toggled on). When this was toggled on, the Sonos would not connect to the network. Toggled off (IPv4) everything worked perfectly. I reported this to Sonos support. Hopefully a firmware update will address this.

Response for aph…. I see you’re a fellow Chicagoan :)

I have the same Sonos hell issues. The one thing that is not mentioned in this thread, which I believe is the key issue, is that Sonos hates 5ghz. On previous routers, I had the option of 5 or 2.4 but with Eero, its 5ghz only.

My Eero setup consists of a Eero Pro (router) and 3 Eero Routers (AP’s). The Pro is connected to a Xfinitity supported Netgear modem. I accidentally ordered 2 Eero Pro’s so thought about using 1 in Bridge mode, which appears to have helped others on this thread. Will this work?

 

Being a networking novice, hoping for some guidance on sequence.

Current Config  - ISP -- > Modem → Eero Pro Router → Switch

Once I configure the Eero Pro in Bridge mode, where does it go in the sequence?

Thanks in advance -

I had all of the issues mentioned before - the initial setup of Eero and Sonos was terribly complicated, took many calls to support and then I had to work with Verizon to get the Bridge established. Finally all was working.

My current problem is the new Xbox just came out. It does not like the bridge network and will not connect wirelessly due to the security protocol. I contacted Eero and they said this issue IS due to the bridging (which they also said we lose some of their security due to the bridging).

My question is - has Sonos found a better way to connect to Eero or is bridging still the only way the two can co-exist?

After struggling for months with connection issues, restarts, reinstalls, etc...I believe the switch to Bridge mode solved my problems. There were various ways suggested to move to Bridge but mine was as simple as a few others suggested in this thread - change the setting on my Eero app. 
 

Settings —> Advanced—> DCHP & NAT —> Bridge —> reboot eero —> reboot ATT U-verse router. 
 

It’s only been 2 days but no issues since (THANK GOD). Fingers crossed and thank you all on this thread for your help!!

While I agree with the switch to bridge mode, I’d caution about the use of a Sonos BRIDGE at this point. The BRIDGE is an old product, and is S1 capable only. They are known to have issues with power supplies, which due to voltage variation can cause issues that are somewhat frustrating to track down.

Several years ago, Sonos replaced the BRIDGE with the Sonos BOOST, which not only has a CPU capable of running S2, but better WiFi antennas, a faster version of SonosNet, more interference rejection, etc. I’d certainly suggest anyone still running a BRIDGE to consider upgrading to a BOOST, or simply wiring their ethernet cable to one of the speakers directly, and retiring the BRIDGE.

I also went through hell with this. Constantly restarting my network hoping that Sonos would be found. Sometimes it would only find one room, other times all three. There are two ways to bridge the network. You can use the comcast provided gateway as the bridge, and use EERO as the router, or use EERO as the bridge with the gateway carrying the water. I had no problem bridging the EERO, but I got greedy and tried the opposite, logging online and bridging the modem/router and opening up the EERO to do the work. That was a mess and I lost all internet services, forcing me to call comcast (!!!%$) to get them to unbridge my router/modem. I now have the EERO as the bridge, and all seems well. Some have suggested that you lose some EERO functionality (profiles whatever that is) this way, but that the meshing of the signal will still work just as well. I’ll be happy if I can enjoy music when I want for a change. I’ve been fighting this for over a year. 

Badge +2

In order to use sonosnet, does the speaker/boost need to be connected to the main eero, or could it be any eero?

In order to use sonosnet, does the speaker/boost need to be connected to the main eero, or could it be any eero?

It’s always best to wire the Sonos device to the primary eero hub rather than one of the eero satellites.

Badge +2

Thanks. My router is not in spot that is conducive for hardwiring a speaker. So I guess a Boost may be in my future. 
 

Now I need to decide what eero system to get. I was thinking the 3 pack that’s currently on sale, but I don’t have any hardwired devices, so all those Ethernet ports seem useless to me. 

I also installed new eeros and I had the same problem and tried all sorts of restarts etc. Account, System, Services and Voice were all greyed out.

I tried both wireless but did not work. Then wired to my modem. That did not work. Then finally I just connected directly to the eero pod.

It worked perfectly.....till now. 

Thanks so much - similar to others I spent HOURS working with customer service folks from both EERO and Sonia. Finally found this site- put eero network in bridge and Viola- music thanks so much
 

 

 

Badge

I’ve had this problem and wish I’d found this forum earlier. Sonos support did email me to say ‘make sure that only one router is responsible for the DNS lookup and the others work in bridge mode’ but for me that was of academic not practical help.

The fix was to go into the Eero app on my phone, select Settings and then Network Settings and turn DHCP & NAT to Bridge. I’d probably unknowingly set it up wrong when the Eero first arrived. The Vodafone router now does the DHCP stuff as it’s supposed to and the Eeros don’t go into Gateway mode.

I can’t understand why Sonos Support still don’t connect mentions of Eero and I can’t see my speakers and explain the fix in more basic terms. 

System here is four Eeros, one a Pro, connected by ethernet, four TP Link switches and five Sonos units.

Userlevel 7
Badge +22

There are some Eero notes on this page:

 

 

I struggled a lot with my Sonic speakers getting out of sync once I switched from Comcast + Apple Airport Wifi to AT&T Fiber + eero wifi through the Sonic Internet provider:

https://www.sonic.com/

A call to Sonos was not particularly helpful.  They asked me to put my modem into bridge mode, and I accidentally put the Eero wifi meshnet into bridge mode instead.  Then I called Sonic for help.  They fixed the problem by switching eero to allow the devices to choose which wifi channel to use (the default setting, appropriate for older devices, was to have the eero choose the wifi channel for each device).   Unfortunately there was no way in the eero app for me to choose to do that for myself, but now that the setting has been changed, I’m having no problems.  The Sonos speakers are smart enough to choose to be on the same wifi channel as each other, and my network router is no longer interfering with their ability to do so.

OK, I was wrong in my previous message to think I had the problem solved.   Whenever I reset my Eero network, things usually start out synchronized, but over time they tend to desynchronize.

I was able to figure out that some speakers (such as my right speaker in the kitchen) were choosing to be on the 5GHz part of my Eero wifi network, and other speakers (such as my left speaker in the kitchen) were choosing to be on the 2.4GHz part of my Eero network.  But I wasn’t able to figure out how to get the speakers to stop doing that.

I finally talked to Sonos technical support, and we came up with a new solution.   When I went via my Sonos mobile app to Settings > System > Network, it turned out that both the 2.4GHz and 5GHz networks were listed as options, with an identical network name listed twice.  The tech-support person had me plug on one of my speakers in via Ethernet to my Eero router temporarily, as a precaution to avoid losing connection.   Once I’d done that, I deleted one of the two networks on that Settings > System > Network page.   That appears to have fixed the problem, removing the choice between the two networks so that they will no longer become desynchronized.

It sure would be nice if Sonos could come up with a better solution to this problem when on Eero or other wifi mesh networks.  But for now I am happy again.   I can’t begin to describe how annoying it is to have a delay of about 0.75 seconds between the left and the right speaker in a room, but if you are reading this, you probably know what I’m talking about!

Userlevel 7
Badge +22

It sure would be nice if Sonos could come up with a better solution to this problem when on Eero or other wifi mesh networks.  But for now I am happy again.   I can’t begin to describe how annoying it is to have a delay of about 0.75 seconds between the left and the right speaker in a room, but if you are reading this, you probably know what I’m talking about!

This is Eero’s problem to fix. Sonos just require a working local network, and Eero don’t supply that after devices choose to switch frequencies.

Badge +2

 I live in a large home 6,000 sq ft+with 10 Zones and a Sonos Boost. I’ve had nothing but issues with music dropping, resuming, dropping  etc… The only thing I could play through my entire system without the music dropping was Sirius. My Spotify would drop constantly, same with Tidal. My internet goes through a Telus Actiontec dual band router into a Eero Mesh system.

I’ve tried pretty much everything, disabled smart-steering on the Actiontec modem and setup the Sonos boost up on the 2.4ghz portion of the modem-That was a fail 

Plugged the boost into Eero in bridge mode- That was a fail

Tried changing wireless channels- That was a fail

I’ve rebooted, unplugged and factory reset everything like three times lol

 So, what has finally worked for me is ditching the Sonos boost altogether, keeping my Eero mesh system in bridge mode and connecting the whole Sonos system minus the boost to my Eero wireless network and so far (knocks on wood) no music dropouts at all on Tidal.

Thank you to everyone who has posted their solutions and what has worked for them and I hope my posting may help someone out too! :-)

Reply