Wired setup but speaker connects through sonosnet instead

  • 29 March 2021
  • 4 replies
  • 72 views

Badge

Most of the speakers are connected through ethernet. One device is also connected though ethernet but it blocked by my network because it shows up as an “uplink” instead of giving the device network. This is because the device is connected through SonosNet instead of ethernet. How can I force the speaker to use the ethernet and only use its wifi for other speakers that aren’t connected through ethernet?

To have best experience I should suppose I try to connect as many devices through ethernet and not spamming my internal wifi-network?


4 replies

Either sort out the STP configuration in your core network so the Sonos device doesn’t prefer the wireless connection over wired, or simply disable the radio on that device using the Sonos controller.

Badge

Can you guide me with the STP configuration because it’s all on “default”. I can’t disable the radio on that device because it’s necessary to have another device available.

Is it possible to hardwire most of the speakers and use SonosNet and have for example the new Sonos Beam connected to the wifi instead of SonosNet because I don’t think there’s SonosNet in my backyard but there is Wifi. But changing all the devices to use Wifi is useless when I have a wired connection for most of them...

On the second point, if there are WiFi credentials configured into the system and a device can’t see SonosNet but can see WiFi then it will try and connect to the latter. This is ‘mixed mode’ operation. It can be unstable though if the SonosNet signal comes and goes. YMMV

 

As to the first point, you’d better describe your network arrangements.

Sonos uses ‘classic’ STP (a variant thereof) for the SonosNet mesh to optimise topology and avoid loops. If the core network uses RSTP, then its path costs could be sufficiently large for the wireless path across SonosNet to be favoured instead of a wired path. This appears to be what’s happened here. In effect SonosNet is bridging wirelessly where you don’t want it to. The solution is typically to configure the core network for classic STP. See https://support.sonos.com/s/article/2118

Badge

Hi I have unifi managed switches. RSTP is enabled by default.

Reply