Answered

WiFi Keeps re-enabling and kicking system out of "mixed mode"


Userlevel 1

I am trying to run a mixed setup.  I have a Sonos Play 5 and Sonos Connect in my living room that Id like to remain wireless and connected via wifi.  My WIFI router is in the living room as well so there is a very good connection between the router and the 2 Sonos there.  I have another Sonos Connect and a Sonos Play 5 in the bar on the other end of the house.  The ones in the bar are hardwired because the wifi barely reaches there and I have problems when those units are connected via wifi.  The Connect (bar) is wired to the router and the Play 5 (bar) is wired to the other port on the Connect.  My goal is to have the 2 devices in the living room use WIFI, not SonosNet, and leave the Connect and Play 5 in the bar as wired.  I can get it to work a little while that way by setting up the Sonos system to use Wifi and disabling the wifi on the Connect and Play in the bar.  However, either the Connect or Play will turn back on the Wifi on it’s own after awhile.  The 2 Sonos in the living room then connect to it with a poor connection vs using the strong WiFi connection they could.

When it is working the Connect and Play 5 in the bar are WM:0 and the 2 sonos in the living room are WM:1.  However, after a few minutes the wifi will turn back on, on one of the 2 devices in the bar, and everything goes to WM:0.

What is going on?  Why can’t I keep wifi disabled on the 2 connected devices?

icon

Best answer by ratty 21 July 2021, 22:34

@rajcic

Typically you can’t disable the radio (“disable WiFi”) on a unit which doesn’t have a direct path to the router. It will appear to disable, then re-enable itself.

Temporarily unpick the daisy-chains and wire the relevant units directly. You should then be able to disable the radios and the setting will persist, including across a reboot. You can subsequently re-establish the daisy-chain as required.

View original

4 replies

Do you ever have a requirement to group the Living Room devices with those that are in the Bar, if not, then reset and setup the two Living Room devices on the same Sonos account, but have them using different Sonos Systems/Households on the same subnet, that way you can run the Bar devices on SonosNet and the Living Room devices on your WiFi, separated by HouseholdID. The downside to this, is you ideally need a separate mobile Sonos Controller for each Room/System, unless you can run one setup on an S1 Household and the other on S2.

If not and you do wish to group both rooms (Living Room & Bar), then the next way forward is you need to wire a single Sonos device to the router in the Living Room (which can even be done with a Sonos Boost, if it’s impractical to wire one of the current Living Room products) and just run everything on SonosNet in one Household. Otherwise there’s no easy way to achieve what you are presently looking for, with the current setup you have.

Userlevel 1

I need everything on 1 setup.  I will play music throughout the house for parties.

 

I’ve read multiple other posts where users run a “mixed” setup before, with some of the units using WiFi and some using ethernet and nothing using SonosNet.  Why is that not possible here?

@rajcic

Typically you can’t disable the radio (“disable WiFi”) on a unit which doesn’t have a direct path to the router. It will appear to disable, then re-enable itself.

Temporarily unpick the daisy-chains and wire the relevant units directly. You should then be able to disable the radios and the setting will persist, including across a reboot. You can subsequently re-establish the daisy-chain as required.

Userlevel 1

ah, thanks!  I thought maybe that was a potential issue and was going to try using a switch instead when I got home.  This will save me from having to buy one.  Thanks!

Reply