Unable to add a music library on NAS

  • 21 December 2021
  • 7 replies
  • 132 views

I have a TP-LINK router that I am using a NAS file server.  I have a Seagate external hard drive connected to the TP-LINK router via USB, and the TP-LINK is connected via Ethernet to a SMART/RG router that is connected to the internet and runs my local WiFi network (which includes 6 Play:1 speakers).  I have a Mac (Catalina 10.15.7) and 2 iPhones and an iPad, all using the S2 controller.  I had been using an iTunes folder on the Seagate drive as my NAS music library with no problems for the last couple of years.

I recently upgraded the S2 controller to release 13.4.1.  After deleting some songs from the NAS music library, I got an error when I tried to re-index the music library.  After a couple more failures, I decided to delete the NAS music library and re-add it to see if that would resolve the indexing issue.  To my great misfortune, I have been unable to add the music library back.  Most of my attempts end up with the following error message:

Indexing your music collection could not be completed.
'//192.168.1.253/volume1/iTunes' is no longer available. The device where the music files are stored may not be powered on, or the path may have changed.
Go to Settings > System > Music Library > Music Library Setup to check the path.

I opened a case with tech support (#03530712) and spoke to several help desk people who tried their best to help and suggest workarounds… all to no avail.  The case is still open but the help desk basically gave up and suggested that I try the forum.

My guess is that something changed with S2 Controller 13.4.1.  I checked the release notes and I noticed that the smbv2 and smbv3 network protocols are now supported.  I’m wondering if a change to the network protocol logic might be related to my issue.  I’m sure that I would have been using smbv1 before, as I understand that that is all Sonos supported up till now.

 

 

 

 

 

 


7 replies

hi @jaero if your TP-LINK router has not changed and still uses SMBv1 then you should be fine for that matter - I do not know how you copied the tracks from your Mac to the Seagate but music tracks are since Catalina stored in /Users/<username>/Music/Music folder and no longer under the iTunes folder - maybe Catalina has done some housekeeping on your Seagate and moved tracks that Sonos is no longer able to find - you can get to the folders via the Sonos App Music Library menu at the bottom of the list using the ‘Folders’ option

 

Hi el rubio… Thanks for the reply. Nothing has changed on the TP-LINK router, and it still has SMBv1 enabled.  The iTunes folder on the Seagate is a copy of the iTunes folder on my Mac.  The pathname in the error message in my original post is correct…   and the pathname has not changed since before updating the S2 controller to 13.4.1, i.e. when everything was working fine.

A couple of things I neglected to mention.  The Seagate drive is formatted as NTFS.  I also recently upgraded my Mac to Catalina 10.15.7.  

One other interesting thing is that if I try to add individual folders in the iTunes library, e.g.

//192.168.1.253/volume1/iTunes/iTunes Music/James Taylor   or

//192.168.1.253/volume1/iTunes/iTunes Music/ABBA

...that works.  I am able to add some individual folders into the Music Library.  But, I get an error if I try to add too many individual folders... or the parent folder by itself (which is what I really want to do).

Perhaps there is some sort of buffering issue?

 

hi @jaero I am not in favour of routers used for NAS functions because of performance - anyway, to rule out any router failures, you could attach the Seagate to your Mac and setup a new shared library - bear in mind that the attached NTFS drive will be read-only from your Mac

 
Badge +18

Historically Mac’s could not share an external NTFS drive, Apple replaced Samba with their own version sometime back and it basically ignored NTFS formatted drives. Not sure if this still applies.

My Mac can read/write the NAS NTFS Seagate drive with no issues.  I can access via Go/Connect To Server from the Finder menu bar and entering “smb://192.168.1.253” and connecting that way…. or I can access via Safari by entering “smb://192.168.1.253” in the address bar.  

I initially created the iTunes library on the Seagate by attaching it directly to the Mac and copying the Mac’s iTunes library from the Music folder.  

I still suspect that something has changed in how Sonos is trying to read the Seagate drive as a NAS.

 

My Mac can read/write the NAS NTFS Seagate drive with no issues.  I can access via Go/Connect To Server from the Finder menu bar and entering “smb://192.168.1.253” and connecting that way…. or I can access via Safari by entering “smb://192.168.1.253” in the address bar.  

I initially created the iTunes library on the Seagate by attaching it directly to the Mac and copying the Mac’s iTunes library from the Music folder.  

I still suspect that something has changed in how Sonos is trying to read the Seagate drive as a NAS.

 

Perhaps see if this Sonos support page may assist re. the disk/partition format for the shared library…

https://support.sonos.com/s/article/4876

Problem has been resolved.  In working with one of the Sonos engineers, he discovered issues with Sonos connecting to my TP-Link router using smbv2 protocol.  The router supposedly supported smbv2, but it would periodically drop the connection.

I was able to downgrade the firmware on the router to a version that did not have any support for smbv2.  So, when Sonos now tries to connect to the router, it recognizes that the router does not support smbv2 and tries smbv1 instead…. and voila, everything now works! 

 

Reply