Two Sonos One Speakers behind a DSL Router, Zyxel Firewall and Wireless AP: iOS Sonos App cant connect to Sonos Account

  • 3 February 2019
  • 3 replies

Hi there
I had my Sonos One speakers installed and working until I had to integrate some HW to my network (home and office combined): After installing a Zyxel 2S Firewall (with VPN site-to-site functionalities) which also serves as my DHCP, I can not get my two Sonos One Speaker System to work again.The issue starts when trying to connect my Sonos App on iOS or Android to my account. When connected to the WiFi behind the Firewall, I get an Error message like "Network problem... check Internet connection and date/time settings".

What I have tried already: When I temporary connect to a WiFi outside the Firewall (e.g. my mobile 4G network), I can login on the Sonos App and get to next step. When I then change back to the WiFi AP behind the Firewall to find my speakers, I can also set up both speakers. That all goes until registering the speakers to my Sonos account, for which I need to connect back to the WiFi outside the Firewall to get that step going.
Unfortunately this was not the solution, as I still can not use the speakers with the Sonos App, as it needs to connect with Sonos and the speakers at the same time. I can also not connect it with e.g. Spotify.

I have already switched off the Firewall functionalities on my Zyxel 2S - with no difference to the description above. Therefore I am not sure, what actually causes the connection problems between the Sonos App and my Sonos account.

My setup:
  • DSL: FritzBox 7490 --> IP 192.168.x.1 (UDP Ports 500, 4500 and TCP 10000 passed through for IPsec, DynDNS set-up)
  • Router, Firewall (with default settings), DHCP and VPN (site-to-site set-up) - with DSL on WAN: Zyxel2S --> IP 192.168.y.1
  • Wireless AP: Synology RT2600AC --> IP 192.168.y.2
  • Sonos One 1: connected to WLAN on IP 192.168.y.100
  • Sonos One 2: connected to WLAN on IP 192.168.y.101
  • iPad connected to WLAN on IP 192.168.y.110 --> tried Sonos App
  • Android Phone connected to WLAN on IP 192.168.y.111 --> tried Sonos App
  • Additional computers, printers, NAS etc. are all connected to WLAN and work fine. Internet and all other tested apps work fine on connected computers and mobile devices. Also my Chrome cast works fine on the same WiFi.
This phenomenon does also not allow to send diagnostic data to Sonos, as I can only connect to Sonos the the speakers are not visible for the app.

Am I missing something - or what could be a solution? My Google searches did not unveil a solution yet. Also the Sonos tips on needed ports is not that clear - as the list ( is quite long and unspecific and I assume it is not the goal of open all ports on my network.

Thank you for your support!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

From a device connected to the Zyxel2S, are you able to actually access using a browser?
@ratty: Thank you. Yes, I can access all pages without restrictions. Also the works ok and I can log-in to my account via browser. It seems, as the Sonos apps (Android/iOS) use different ports other than http/https to access the account. But that's just a guess.

PS: I do not have any content filters activated on my Zyxel 2S.
@all: Thanks - the problem seems now resolved (by its own!?!)