Answered

Tips on better integration with wireless mesh network

  • 30 November 2023
  • 5 replies
  • 404 views

Hi all, I have a substantial Sonos system (20 devices) all running S2. My new Ubiquiti mesh network is not working well with my Sonos system. I am running a Sonos Boost connected to my base station. Any thoughts or suggestions?

 

icon

Best answer by controlav 30 November 2023, 16:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +23

You chose Ubiquiti? You need to carefully configure it:

https://github.com/IngmarStein/unifi-sonos-doc

Dump the Boost, once properly configured your wifi should suffice.

Userlevel 7
Badge +22

I’d also dump the Boost.

  1. Wire one or more other Sonos to Ethernet (after setting the needed options in the Ubiquity gear) to let them form a SonosNet mesh.
  2. Move all to WiFi and don’t wire anything to Ethernet.

Option 2 is likely your best bet unless you have severe WiFi issues.

Userlevel 1

Hi,

I have been using Sonos and Unifi network for years now (using only STP instead of default RSTP)  and decided to try the settings as described in https://github.com/IngmarStein/unifi-sonos-doc

However when I get to the last setting: 

  • Port settings on the LAN ports that connect to Sonos gear: disable Enable Spanning Tree Protocol
    • UniFi Devices -> $DEVICE -> Ports -> $AFFECTED_PORT

my Unifi network goes crazy. All my devices keeps going offline and adopting. After one hour with this looping, I backed out of this setting and had to go back using STP again. My Sonos setup consists of mixed wired and wireless speakers running  Sonos Net. My Unifi setup is UDM PRO hosted with several switches and AP (UniFi OS v3.2.7 and Network 8.0.26) . Any ideas ? 

Userlevel 7
Badge +23

Have you tried the manufacturers suggestions?

https://help.ui.com/hc/en-us/articles/18930473041047-Best-Practices-for-Sonos-Devices

Userlevel 1

Thanks a lot. So many gripes about this on the net - missed this one. Just implemented the sonos wireless only option a few hours ago. Seems fine for now and back to RSTP again (great). The last time I tried this my stereo pairs kept failing. Hope it works this time. I just hate re-configuring Sonos speakers….

Thanks again