Question

Spanning Tree & Netgear Switch Settings

  • 12 February 2017
  • 9 replies
  • 1933 views

Please help, does anyone have the correct settings required for using wired sonos components on a Netgear GS724T V3 smart managed switch.
I have recently extended my Sonos system which now includes 4no. Connect Amps, 1no. Connect, 1no. Play3, 1no. Play1, Playbar & Sub.
I have the ability to "hard wire" all the Sonos equipment to the switch via my home network which works ok for 1/2 an hour or so and then it crashes the network.
Having read up on the forum i have found various article referring to "spanning tree protocol" but nothing that relates exactly to my Netgear Switch.
I can revert to the wireless setup with one sonos component connected to the switch acting as the bridge but would prefer to utilise the wiring available in my home network.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +21
Turning off the WiFi may work until you need support, with a non-supported setup you may find the Sonos tech "All soggy and hard to light" to steal a quote from someone long ago and far away.

Best to deal with the problems in a manner that keeps Sonos support happy.
As per my previous post the easiest way to deal with this if you have the capability to hard wire all the sonos components is to switch off the wireless part of each sonos component on the network individually (google the topic there are some straight forward help pages to assist), this cured the problems i was having.
Userlevel 2
Badge
I know that Sonos doesn't do RSTP but from what I've been reading, if I enable RSTP so that other devices on my network that can use it will, RSTP would fall back to STP in the case of Sonos, but what's I'm not sure of is would the fallback to STP be just for the Sonos devices or for the whole switch. The Netgear switch docs don't really go into enough detail (or I haven't found the deal I'm looking for yet). In terms off STP vs. using BPDU flooding, I'd like to use the capabilities of my switch and not just set the "green box" mode that blasts traffic out every port. That's one of the ions I'm asking about aggregating all my Sonos players onto a dedicated VLAN to keep their traffic off of non-Sonos ports. If it's easy, you don't learn anything, right?

In my network, I just installed the GS724 last night (replacing the GS116 that was causing lots of STP storms). STP on my GS724 is enabled and so far my network is quiet.
Userlevel 7
Badge +21
Have a look at this Wikipedia article - Spanning Tree Protocol - specifically the table with the STP and RSTP path cost values, and tell me if you think using RSTP would work properly. :)

It needs to be STP, and with "Classic STP" path cost values. Personally, I've done the same thing, disabling STP and enabling BPDU flooding. My last set of switches couldn't disable STP, and I ended up having issues with wireless Sonos devices as a result. Eliminate a source of frustration and just disable it if Sonos is the only thing on your network that requires its use. If you have other things that use it, then having it enabled so your switch becomes the root bridge wouldn't be a bad idea. But only if absolutely necessary.
Userlevel 2
Badge
Anyone have any configuration hints for the Netgear GS748Tv5 (other than disable STP and enable BDPU flooding)? From reading the Sonos STP post, it looks like Sonos only supports STP and not RSTP, but in a static Sonos configuration (i.e. I don't move the hardware around) I'm not sure RSTP would make that much of a difference if at all. Any issues with enabling RSTP, which should fall back to STP for Sonos?

Has anyone setup their wired Son os ports into a VLAN to segregate the Sonos traffic from everything else on the switch?
I used a smart managed switch (netgear GS748Tv5). Random stops the playing. I am using now a unmanaged switch (TP-Link SG1048) for a few days and now it seems that it works.
Userlevel 3
Badge +2
Easiest way on a Netgear Switch is usually disabling STP and activating BDPU Flooding.
Thanks, i had seen that post and although it helped with diagnosing the problem i am now struggling to find the right settings on my particular switch in order to solve the issue.
Having tried a few different settings unsuccessfully on the switch decided to factory default and i have now switched the wireless side of the connect amps off and left the playbar & sub wired/wireless. I will leave the family to use today and see how it goes.

Fingers crossed
Did this sticky not help?