Sonosnet carrying data traffic ?

  • 19 October 2021
  • 8 replies
  • 69 views

Badge +2

I have 2 Sonos Play 1 , 1 Play 3 and 1 Connect devices at home.

These 4 are all connected with ethernet cables to my main router (Asus AX88U)

I also have Asus Aimesh connected to this router but I believe this is not related to my question.

 

Today I realized a performance issue on my router and digged a bit.

Since I could not stop the problem by rebooting router and mesh devices I disconnected ethernet devices one by one.

Eventually the problem was solved when I disconnected one gigabit switch.

This switch has 4 wired clients on it, one of which is a Sonos Play 1.

 

After disconnecting the switch from my main router, the performance issue was solved.

But even with its uplink disconnected, I was still able to reach the devices on the switch.

I could play music on the Sonos device (which is normal because when it lost wired connection, it probably swithced to Sonosnet)

But I was also able to reach the other devices on the same switch.

 

Then I disconnected the Sonos device from the switch and only after that I lost access to the other devices on this switch.

 

So it is obvious that the Sonos device is acting as an uplink to the switch carrying the traffic over Sonosnet

And this causes a loop on my main router which eventually causes a severe performance issue.

 

I don’t want the sonos devices to carry my LAN traffic.

How can I prevent it ? 

Previously this was an option in the Sonos app settings I remember. But now I could not find that option.

 

 

 


8 replies

Hi @ilkeraktuna,

 

This is a slightly confusing one to me, and there are some details missing that prevents me from fully understanding what happened here, but I’ll give it a go.

 

Today I realized a performance issue on my router and digged a bit.

What was the performance issue?

 

Eventually the problem was solved when I disconnected one gigabit switch.

This switch has 4 wired clients on it, one of which is a Sonos Play 1.

Is the switch a managed or unmanaged switch? Were all of the wired clients Sonos devices?

 

After disconnecting the switch from my main router, the performance issue was solved.

But even with its uplink disconnected, I was still able to reach the devices on the switch.

I could play music on the Sonos device (which is normal because when it lost wired connection, it probably swithced to Sonosnet)

But I was also able to reach the other devices on the same switch.

This is the part that doesn’t make sense to me. If you’ve completely disconnected the players wired uplink to the network (by unplugging the switch from the router) then the players would then drop off the network. Unless, of course, they’re switching over to wireless mode and connecting to your WiFi. I’d be really interested in seeing a diagnostic from your system with your players in this connection state, to better understand what’s happening here.

 

So it is obvious that the Sonos device is acting as an uplink to the switch carrying the traffic over Sonosnet

And this causes a loop on my main router which eventually causes a severe performance issue.

 

I don’t want the sonos devices to carry my LAN traffic.

How can I prevent it ? 

Previously this was an option in the Sonos app settings I remember. But now I could not find that option.

It seems to me that there’s some sort of network switching loop happening here when the devices are all wired to the same switch. If the switch is managed, make sure IGMP snooping is enabled across all ports where you have Sonos devices. 

I would also be making sure to check basic connections too, for example ensuring that the switch isn’t double-wired to the network in some way.

It’s also worth noting, your Play:1 isn’t carrying your LAN traffic, and is oblivious to any communications going through the network that aren’t intended for it or any other Sonos player, and there’s no such setting in the Sonos app now, or in the past, to change this.

Once I have a diagnostic from your system I’ll be able to better understand what’s going on here. So please, recreate the issue and reply with the confirmation number in this thread. :slight_smile:

This sounds like a straightforward case of SonosNet bridging wirelessly because the wired path between the relevant nodes has a higher (probably RSTP) path cost.

In that case the options are to change to classic STP on the backbone (if feasible) or disable the radio on selected wired Sonos devices.

Under these circumstances I’d suggest simply disabling the radio (‘disable WiFi’) on the Play:1 wired to the gigabit switch.

Badge +2

Hi @ilkeraktuna,

 

This is a slightly confusing one to me, and there are some details missing that prevents me from fully understanding what happened here, but I’ll give it a go.

 

Today I realized a performance issue on my router and digged a bit.

What was the performance issue?

 

 

Router could not handle traffic. Simple ping from LAN to LAN had timeouts. 

 

Eventually the problem was solved when I disconnected one gigabit switch.

This switch has 4 wired clients on it, one of which is a Sonos Play 1.

Is the switch a managed or unmanaged switch? Were all of the wired clients Sonos devices?

 

 

Switch is an unmanaged switch. Only 1 sonos device connected. Others are IP camera, game console and TV.

 

After disconnecting the switch from my main router, the performance issue was solved.

But even with its uplink disconnected, I was still able to reach the devices on the switch.

I could play music on the Sonos device (which is normal because when it lost wired connection, it probably swithced to Sonosnet)

But I was also able to reach the other devices on the same switch.

This is the part that doesn’t make sense to me. If you’ve completely disconnected the players wired uplink to the network (by unplugging the switch from the router) then the players would then drop off the network. Unless, of course, they’re switching over to wireless mode and connecting to your WiFi. I’d be really interested in seeing a diagnostic from your system with your players in this connection state, to better understand what’s happening here.

 

 

Why it doesn’t make sense ? As you wrote, the sonos device switches to wireless and use wifi. (SonosNet)  Weird part is that it carries non-Sonos traffic over that connection. Why ?

Unfortunately I did not take a diagnostic at that state. Even if I had tried , I would not be able to get it because LAN access was really bad.

 

So it is obvious that the Sonos device is acting as an uplink to the switch carrying the traffic over Sonosnet

And this causes a loop on my main router which eventually causes a severe performance issue.

 

I don’t want the sonos devices to carry my LAN traffic.

How can I prevent it ? 

Previously this was an option in the Sonos app settings I remember. But now I could not find that option.

It seems to me that there’s some sort of network switching loop happening here when the devices are all wired to the same switch. If the switch is managed, make sure IGMP snooping is enabled across all ports where you have Sonos devices. 

I would also be making sure to check basic connections too, for example ensuring that the switch isn’t double-wired to the network in some way.

It’s also worth noting, your Play:1 isn’t carrying your LAN traffic, and is oblivious to any communications going through the network that aren’t intended for it or any other Sonos player, and there’s no such setting in the Sonos app now, or in the past, to change this.

Once I have a diagnostic from your system I’ll be able to better understand what’s going on here. So please, recreate the issue and reply with the confirmation number in this thread. :slight_smile:

 

Unfortunately the switch is not managed. 

Switch has only one real uplink to the router.

But I really don’t understand how Sonos acts as a second uplink to the switch. Can you explain that ?

Why does the Sonos device carry non-Sonos switch traffic ?

 

 

Badge +2

This sounds like a straightforward case of SonosNet bridging wirelessly because the wired path between the relevant nodes has a higher (probably RSTP) path cost.

In that case the options are to change to classic STP on the backbone (if feasible) or disable the radio on selected wired Sonos devices.

Under these circumstances I’d suggest simply disabling the radio (‘disable WiFi’) on the Play:1 wired to the gigabit switch.

how can I disable wifi on that device ?

and why does it really bridge the traffic ?

 

Unfortunately the switch is not managed. 

Switch has only one real uplink to the router.

But I really don’t understand how Sonos acts as a second uplink to the switch. Can you explain that ?

No, I can’t. But, if you have wired Sonos devices elsewhere in the property that are not connected to that switch, that would explain how the Play:1 is able to maintain connection even after unwiring the switch.

 

Now I know this, it seems to me like your Play:1 is set as the root node in Sonosnet, even when wireless. A correctly functioning system would transfer the root bridge to a different wired player when disconnected, preventing total disconnection.

This would cause the connectivity issues you were experiencing. I would definitely advise getting in touch with our customer care team so they can take a look at this and help correct the issue. 

This sounds like a straightforward case of SonosNet bridging wirelessly because the wired path between the relevant nodes has a higher (probably RSTP) path cost.

In that case the options are to change to classic STP on the backbone (if feasible) or disable the radio on selected wired Sonos devices.

Under these circumstances I’d suggest simply disabling the radio (‘disable WiFi’) on the Play:1 wired to the gigabit switch.

how can I disable wifi on that device ?

Settings/System/[roomname]/Products/Play:1/Disable WiFi

 

and why does it really bridge the traffic ?

All device Ethernet ports are bridged to SonosNet (and vice versa). Loops are prevented by ports being set to forwarding or blocking by STP (Spanning Tree Protocol). The lowest path costs determine which connections are active.

SonosNet uses an approximation of ‘old’ (classic, 802.1D) STP path costs. If the wired network path uses the later RSTP path costs, which are much higher, the wireless path gets favoured over the wired path.

Badge +2

in this case I will disable wifi on all of my Sonos devices.

They are all connected with ethernet to GE ports. If my switch or router is down, I don’t need to have music anyway.

So is there any disadvantage of disabling wifi ?

 

If all your Sonos devices are wired (and you have none of the ancient CR100/CR200 controllers) then feel free to disable all the radios. 

Reply