Answered

Sonos Arc - need help getting 5.1 from laptop connected to TV

  • 13 July 2020
  • 3 replies
  • 179 views

I've got a new Sonos Arc 5.1.2 setup, with the arc connected to an LG CX tv via the eArc hdmi (tv set to passthrough). So far it's been working well - the built in apps do 5.1 and Atmos and my ps4 gets 5.1 as I had expected. (and I'm looking forward to the Sonos Arc update to get more than stereo out of the Nintendo Switch).

My problem is with being unable to get my Windows 10 laptop to recognise that I have a 5.1 setup (let alone Atmos). I'm hoping this is a solvable problem - if the old ps4 can figure it out, surely I should be able to get the pc to as well (even if it requires a bit of tinkering)?  The laptop is running an nvidia 1070 - also attached via hdmi to the tv. Sound driver is Nvidia HD Audio. Latest updates and drivers.

Currently windows sound settings is reporting only stereo speakers. 5.1 appears disabled in the list and cannot be selected. I installed Dolby Access to get Dolby Atmos for Home Theater but that did not work (i suspect I need to resolve the 5.1 issue and then Atmos will hopefully be solved with it).

Searching online has given some generic advise about connecting my pc to my receiver rather than to the tv, but that's not really helpful in the case of Sonos Arc.

Really appreciate any help here from Sonos or the community!
 

icon

Best answer by RagnarokZero 14 July 2020, 11:55

I think I’ve solved it!

5.1 and 7.1 are still both listed as disabled in the Speaker Setup section (a little confused as to why regular 5.1 isn’t an option)

But I finally managed to get everything working with the Dolby Atmos for Home Theater selection.

First I had to run the windows audio troubleshooter, indicating that the test tone sound was bad until it swapped the Nvidia HD Audio driver with Microsoft’s HD Audio Driver. Once I did that, Dolby Atmos for Home Theater started working. 

 

View original

3 replies

Userlevel 7
Badge +21

Sounds like the TV audio settings are set to Stereo for the HDMI input the PC uses. The TV is telling the PC it only accepts stereo, and you need to fix the TV setting.

Thanks for the reply! 

I just double checked the LG CX tv audio settings, nothing seems to be amiss, but I’m listing everything I think might be relevant here in case I’m wrong - 

Sound Out: HDMI ARC.

Connection tab: Simplink (Hdmi-Cec) on

In Sound Additional Settings:

DTV Audio Setting: AUTO

HDMI Input Audio Format: Bitstream

Digital Sound Out: Pass Through

eArc on.

 

I think I’ve solved it!

5.1 and 7.1 are still both listed as disabled in the Speaker Setup section (a little confused as to why regular 5.1 isn’t an option)

But I finally managed to get everything working with the Dolby Atmos for Home Theater selection.

First I had to run the windows audio troubleshooter, indicating that the test tone sound was bad until it swapped the Nvidia HD Audio driver with Microsoft’s HD Audio Driver. Once I did that, Dolby Atmos for Home Theater started working. 

 

Reply