Sonos and AT&T U-verse

  • 8 August 2008
  • 8 replies

Userlevel 2
I have used my Sonos equipment for 10 months without any problem, it has worked perfectly with my Linksys Wireless router (and my previous DSL service).

Yesterday however, I changed my internet/tv provider to AT&T U-verse and my Sonos Desktop Controller can no longer find my ZoneBridge or my ZonePlayers. Nothing seems to be working. AT&T U-verse comes with a wireless router which has replaced my old Linksys router (this is probably where the problem lies).

Does anyone know the answer to this? My ZoneBridge is hardwired to the at&t "2wire" router, everything is physically hooked up correctly, but is not working (maybe an IP address problem).

I appreciate any help that I can get, thanks.

for some reason, now the Sonos equipment has contact with the router ... everything seems to be working now EXCEPT for the Sonos DESKTOP Sontroller (which still is "searching for the Zonebridges/-players

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies


Reboot everything on the network. With respect to the SONOS system, start the reboot process with the ZoneBridge connected to the router.
Userlevel 2
I have a slightly different situation - got the U-verse wireless router and now the iphone connection gets dropped. Previously everything was rock solid (Netgear router). Now I can find everything after running the standard configuration routine with the iphone, but once I turn the phone off, it loses the sonos system and I have to reset the controller and start over. Rebooting doesn't help.

Anyone with Uverse figure out the fix? I'm certain there is a router setting I need to adjust, I just cannot figure out which. Thanks!

The easiest solution is to disconnect your network from the AT&T modem and turn OFF its wireless, then connect one of the AT&T network ports to the WAN port of your Netgear and continue as you were before the arrival of AT&T.

While this may seem a little clunky, it trades a little clutter and a very small additional latency for solid operation.
Userlevel 2
I have two ZP90s, two controllers, and a zone bridge. Both zone players are connected via wireless. The system worked fine until I had U-verse installed yesterday. I could not get the new router from AT&T or the Sonos desktop program to recognize the zone players or controllers. The only thing recognized was the zone bridge.

I changed wireless channels on both the Sonos and the wireless router and I played around with firewall settings, but none of this worked.

I finally performed a factory reset on one of my controllers and that seemed to fix the problem. I realized that the old IP addresses from the original set-up were still in the zone players and controllers. Performing the factory reset removed those IP addresses.

I have seen threads indicating that people are disabling the wireless functionality of the AT&T router (2Wire). I did not need to do this. I am able to use the AT&T wireless router with the Sonos system.

Hope this helps.
Note to all --

We do not recommend performing the Factory Reset procedure unless asked to do so by SONOS support. Factory reset does not cure the fundamental reason for this sort of problem and it deletes certain diagnostic data that will make truly resolving the issue more difficult. Further, you could lose your Favorite Internet Radio stations and SONOS playlists.

Simply removing power from ZonePlayers for about 30 seconds or simultaneously pressing Mute and Music on the SONOS handheld controller will resolve this particular issue.


These FIOS routers are nasty. Depending on your network complexity, you may find that you will need to reboot the router and many items on your network every few weeks.
After having my Sonos and UVerse TV system lock up virtually every other day for months, having to unplug the network switch, unplugging the Sonos ethernet to my network almost every other day, and calling both Uverse and Sonos for support for weeks, to no avail... ATT finally told me they have issues with Sonos. Their solution, which they setup and I hope works was to disconnect any Sonos equipment with ethernet connections to switches or the router itself. To install a netgear or other wifi extender with an ethernet port, and plug any of the Sonos units into that ethernet port. This way the Sonos is effectively on the Wifi network and not wired to the network.
I have a choice of going with ATT or staying with spectrum. Suggestions?
Userlevel 4
Badge +6
The problem with connecting the SONOS products directly to AT&T Gateway / Router is that is does not properly support the STP requirements that are required. I have found that most routers will have this issue.

The solution is to add switch that support the SONOS STP required. Connect the SONOS components to the switch and then the switch to the router.

I no longer have AT&T U-VERSE since we moved to a new home but my system was rock solid once this change was made. I originally utilized Dell PowerConnect managed switches but have since switched to tp-link. The switch was made do to failures of the Dell Power Connect switches and the need for a larger switch.

I have post on how my tp-link managed switches are currently configured with my SONOS system and everything is working correctly with my Comcast XFINITY Gateway.