Sonos Amp shows an an option under Browse/TV even when no HDMI connected?

  • 1 May 2019
  • 1 reply
  • 121 views

Userlevel 2
I have a commercial set up with 3 connects, 8 amps, and 5 sony tvs connected to 5 of the amps. 3 major issues; when browsing something to play and choosing the TV submenu I've noticed that all 8 of my amps show up as options to select even though, as stated above, only 5 of the amps have HDMI connected. I'd like to suggest that amps only show up as a viable option under browse if they actually have HDMI connected and have been set up to work with a TV. Otherwise it's really confusing. Other major issue is the naming convention which is "TV: [name of your sonos zone]" limited to 16 characters. In my case I have 2 TVs over a bar, left and right, left is hooked up to the sonos amp for the room it's physically in, which is fine, but the the right tv is hooked up to the amp running the bathroom, so if a user wants to listen to the right tv in the bar area they need to go Browse/TV: 1st floor Bath. With only 16 characters I can't rename this zone something more obvious like "TV: 1st floor Bath/Right TV". Last major issue - if I want to listen to a tv I must group the zones that have the TVs connected. In the example above, if I want to play the right TV audio in the bar I need to group the bar zone with the bathroom zone (the zone the right tv is plugged into) otherwise it doesn't show as an option under Browse/TV. Obvious issue here - I want right TV audio in the bar but let the bathroom continue to play an audio stream, I cannot do this. It would make more sense if every TV audio was just available to every zone.

Sonos support, I'd love some feedback on these 3 issues. Power users, feel free to comment on the above.

1 reply

Yes. I have been a Sonos dealer for over 10 years and this needs to be addressed. I have a client with a guest house with multiple PlayBars in the bedrooms. When they want to stop listening to music the process is to go to Browse then select TV. Out on the patio, I have a Sunbrite waterproof TV and passive sound bar power by the Sonos Amp. The amp was setup using the Stereo mode and there is no optical or HDMI connected yet there is a TV option under the Browse menu. The process for switching from music to TV audio is to select the Line In selection under Browse NOT TV. When they select TV, a message says that there is a problem with the HDMI. This is not an acceptable situation for the UI. Simply removing the TV option when there is no HDMI or Optical connected would help. Tech support suggested I put up a sign showing how to use the system outside...Really?! I'm hoping Sonos reads comments because their tech support doesn't seem to see the benefit in listening to dealers.

Reply