PLAY5 + TRAKTOR S2 MK3 = Delay (Line-in)

  • 8 May 2019
  • 6 replies
  • 237 views

I encountered the same problem, and as I understood it, SONOS is indifferent to the requests of its customers.
I connect TRAKTOR S2 MK3 through Line-in and so it is absolutely impossible to play. For me, it’s really not clear why this problem cannot be solved for so many years, because it is fixed by one new firmware. Why do we need smart chips if you plugged the speaker through the cable? Turn them off and let the sound go directly!
Dear and beloved company SONOS, forget about it or is there at least some chance in the future? After all, there would not be this problem, many would choose PLAY 5 as a monitor, buy a second PLAY 5 speaker for themselves.

6 replies

I'm not sure I understand why you think you can simply "turn off" the delay. Sonos' entire selling point is that they do whole home audio, which means that the sound must be sync'd across up to 32 speakers at the same time. In order to do that, it requires some amount of buffering.

Sonos isn't a simple bluetooth speaker, or a normal computer speaker. It's part of a system designed to spread music in sync throughout your home.

I would not expect that, unless there is some change to physics, that removing the need to buffer the input would occur at any point.
I'm not sure I understand why you think you can simply "turn off" the delay. Sonos' entire selling point is that they do whole home audio, which means that the sound must be sync'd across up to 32 speakers at the same time. In order to do that, it requires some amount of buffering.

Sonos isn't a simple bluetooth speaker, or a normal computer speaker. It's part of a system designed to spread music in sync throughout your home.

I would not expect that, unless there is some change to physics, that removing the need to buffer the input would occur at any point.


I understand perfectly well that this delay does not just exist, but I would like to be able to part with it when the speaker is connected directly via cable and no smart features are needed. Just play the signal that goes over the wire, without delay.


I understand perfectly well that this delay does not just exist, but I would like to be able to part with it when the speaker is connected directly via cable and no smart features are needed. Just play the signal that goes over the wire, without delay.


Sonos is not going to do that. It was designed for multi-room music, and to let the user turn off that feature would create a logistical/support nightmare. You will need to purchase a speaker that is designed for your purpose.
One does not simply "play over the wire" with Sonos. (Lord of the Rings pun intended.)

The analogue line-in signal needs to be digitally processed, then played back through the zone player's actual hardwired speaker. This conversion process cannot be tempered with. It will always result in a considerable delay being added to the output signal. Which makes Sonos generally cumbersome with any kind of DJing/PA equipment requiring real-time cueing or beat-matching.

There is no physical way to push the native analog signal through the zone player's chipboard without any digital conversion process ( = added delays) taking place. Zone players were never designed for such purpose in the first place. So it indeed cannot be simply fixed "by a new firmware".

TL;DR: you're using the wrong tool for the job. :8
Userlevel 7
Badge +20
@Z1SS: Just to check, how much delay are you experiencing? Is it about 75ms, or about 2s? I assume it's the former, shorter delay, but if it's the latter, change the Audio Compression setting to 'Uncompressed' in the Sonos app.
@Z1SS: Just to check, how much delay are you experiencing? Is it about 75ms, or about 2s? I assume it's the former, shorter delay, but if it's the latter, change the Audio Compression setting to 'Uncompressed' in the Sonos app.
I tried all the recommendations from this forum and nothing helped. 75 ms delay

Reply