Answered

Moved House - Cannot Reconnect - BT Smart Hub & Google Mesh

  • 29 January 2023
  • 6 replies
  • 314 views

I have just moved house having had my sonos system work well before.  Previously I had Virgin Media as my ISP and was using a Google Mesh to share the wifi around the house.

I’ve moved and taken the mesh with me and now use BT as my ISP.  The Google Mesh uses exactly the same network name and password, but I cannot get my Sonos to connect.

If I connect one directly to either the BT router or the Google Mesh router via Ethernet cable, I can see that and use it on my account, but none of the other speakers connect at all.

One suggestion I’ve seen is that having both mesh and smart hub as DHCP causes an issue, but I can’t make the hub a modem only device.  I need to use the google mesh through the house as the signal won’t reach otherwise.

BT have changed the wifi signal from their router to 2.4GHz which has helped, but it is not having any effect.

Any ideas and suggestions would be great!!  It’s all getting rather frustrating.

 

(edited to correct spelling)

icon

Best answer by Corry P 30 January 2023, 15:45

View original

6 replies

Userlevel 7
Badge +18

Hi @whopah 

Welcome to the Sonos Community!

There is nothing particularly easy about networking, so your frustration is understandable, and common.

One suggestion I’ve seen is that having both mesh and smart hub as DHCP causes an issue, but I can’t make the hub a modem only device.

This is very likely to be the issue. You only want to have one DHCP Server on a network - they essentially define the network, so having two makes things behave very strangely as soon as devices want to talk to each other instead of only to the internet. It is an endless source of annoyance for me that mesh systems do not come equipped to detect another router and configure themselves into Bridge mode accordingly.

As I mention in my Troubleshooting Sonos on WiFi article (which I recommend you have a read of), Google Mesh can be (or was - maybe things have changed by now?) difficult to put into Bridge mode. Although BT’s routers don’t have a “Modem Mode” in the way that Virgin Media’s routers do, you can achieve the same effect by disabling the SmartHub’s DHCP Server and any WiFi broadcasts. With DHCP off, it is important that only the main Google Mesh node (which is, technically, another router) connects to the BT router in any way - no other devices should connect via Ethernet or Wi-Fi, otherwise they will be exposed to the Internet and all the Nasties on it without the protection of a local IP address (though the hardware firewall would still be in place, unlike with a Virgin router in Modem Mode).

After reconfiguring the BT router, please switch it and the main Google node off (even if updating the settings required a soft reboot - allow the soft reboot to complete, then do this hard reboot after). Wait 30 seconds, then turn on the BT router. Once it indicates it has finished booting up (take note of the lights lit before rebooting), turn on the Google node. This should ensure that all client devices get an IP address issued by the Google Mesh rather than by the BT router. I recommend you also reserve IP addresses for all the devices that frequently connect to your network, including Sonos devices.

If you ethernet-wire a Sonos device to the network, please only connect it to the main Google Mesh node, or to the node via a network switch (not to the BT router or to a secondary node). With the BT router’s Wi-Fi disabled, it’s okay to have it and the Google node next to each other, but a wired Sonos unit should be at least 1m away from anything broadcasting WiFi.

I hope this helps.

 

Thank you for that full and detailed response.  I shall try that later and let you know how I get on!

Unfortunately this hasn't done the trick. Turning dhcp off on bt smart hub completely disabled the Internet connection and the Google mesh would no longer connect to the Internet.

No Internet at all was worse than just having no sonos! 

One other suggestion is to ditch the smart hub and replace it with a 3rd party modem. Does that sound like it could work? 

Userlevel 7
Badge +18

Hi @whopah 

Apologies for the delay - I was on holiday.

One other suggestion is to ditch the smart hub and replace it with a 3rd party modem. Does that sound like it could work? 

In theory, yes. Though, in theory, so should have my last suggestion - it’s possible you would next have to configure the Google mesh to manually take an IP address instead of it being offered one by the DHCP server on the BT device, as would normally happen. If this is the case, you would also need to do so with another router/modem too, but you really shouldn’t need to purchase another device.

This is why most meshes allow you to disable DHCP on them - it’s easier to do so on a device downstream from the initial connection. It may be worth contacting Google technical support.

I hope this helps.

I have finally solved this with help from the main Sonos Tech suppot.

Essentially, I had to disable the Google Mesh system entirely and install all the Sonos speakers onto the BT Network, using an ethernet cable initally and then enable wifi and connect wirelessly onto the BT wifi.

Then turn on the Google network and connect one speaker physically to one of the mesh nodes.  That can then connect the speaker onto the new network and then port the others across onto this now trusted networks.

One of the speakers has to remain physically connected as there is no way to turn the smart hub into bridge/modem only mode.

All sorted now thankfully!!

Userlevel 7
Badge +18

Hi @whopah 

Thanks for updating the thread, and I’m glad to hear you got it all sorted out!

Reply