Question

Move + Sonosnet + WiFi = problems

  • 18 June 2020
  • 9 replies
  • 197 views

Hi, I’m a big Sonos fan and have invested quite a bit over the past few years. I just purchased by 14th Sonos speaker, a Move, to join my existing setup consisting of various: Play:1, Sonos One, Play:3, Beam and Connect:AMP (gen 2) devices. All of my existing devices were running on Sonosnet, firstly with a Sonos BOOST, but more recently with the Beam being wired and the root of the Sonosnet. That change (removing the BOOST) was just to simplify as I really didn’t need it.

 

I tried moving everything onto WiFi a few weeks ago, but it was terrible. Speakers kept dropping out, changes to songs (like skipping forward) or volume changes were laggy, the app UI kept restarting, then stopped showing me all my speakers (even ones that were playing) and took minutes to update them back into the app. It was terrible. I put this down to having a 4-node “mesh” WiFi system. I have a wired backhaul on those APs, so not strictly “mesh”, but they do support steering, 802.11v, etc. to optimise the WiFi coverage in my home.  But simply plugging the ethernet into the Beam got everything to reconfigure onto Sonosnet and order was restored -- it’s remarkably reliable in that configuration for me.

 

Anyway, the Move turned up today and during setup I realised to my horror that it wanted to be on the WiFi network. So, I’m now in mixed mode. Everything else is still on Sonosnet, but the Move is on WiFi. And, sure enough, everything is now behaving badly again.  The Move works fine, plays fine, and seems to sync up with the other speakers fine. But then some speakers in the group will drop out, when they normally wouldn’t -- not the Move itself, but others. And then the UI on the Sonos app resets, reloads all the speakers again, some missing, even ones that are currently playing, etc. Just like when tried putting everything on WiFi.

 

I’ll do more testing later today, but does anyone have any tips? I can’t lock the Move to a particular AP in my setup, and even if I could it would go against the whole point of having a mesh WiFi system. Perhaps it’s better if I start music on the speakers on the Sonosnet first, then add the Move into that group, rather than start on the Move and then add other speakers? Not sure yet. Any other suggestions?

 

It’ll be very disappointing to have a remarkably stable Sonos system destabilised by adding this additional speaker, so if I can’t find a way to solve this and make it all work as it should, I’ll have to return it (which I really don’t want to do!)

 

Thanks everyone!

 

Michael


9 replies

Have a look in About My System and see if any players -- other than the Move of course -- have migrated to WM:1/WM:2, i.e. shifted back to the WiFi.

If so, consider using only a 5GHz SSID for the Move, not 2.4GHz. This should prevent anything else from flipping off SonosNet.

No, everything else is still on Sonosnet, showing WM:0.

It sounds from your original post that problems were arising when players were grouped, and that the Move may have been the ‘group coordinator’ (the first room), In that case you could try starting with one of the other rooms -- ideally a wired one or one with a good wireless signal -- and then adding the Move. Results ought to be more predictable.

I’d still suggest that you move the Move (pardon the pun) onto 5GHz if you can, to avoid any unplanned mixed mode flipping in the other units. 

It was just a thought that things might be worse if the Move was the start of a grouping, I’ll need to test further to see how things go. 
 

I don’t split my Wi-Fi into separate 2.4 and 5Ghz SSIDs and don’t want to do that. Right now the Move is happily connected on 5Ghz I’ll keep an eye on the other units for any unplanned flippage to Wi-Fi. 

Badge +1

I use a number of Boosts around the house to ensure a good Sonosnet network for the various speakers we have. Like you I was disappointed to find that the Move has to be connected via Wi-fi.  I have managed to do so, attaching it to a UniFi mesh network - where it seems to be working well at the moment. However my Move is connected via 2.5Ghz rather than 5Ghz. I was interested to read the comment about the Move being connected at 5Ghz

 I’d still suggest that you move the Move (pardon the pun) onto 5GHz if you can, to avoid any unplanned mixed mode flipping in the other units.

How do you do that?. I don’t have separate SSID for the 2 bandwidths and I’m not aware how one can choose. Any help greatly appreciated

In my network, my setup automatically “steers” clients to the 5GHz frequency if they support it. It’s a network thing, and I know Unifi APs support the same technology. Look up “band steering” and you should be able to select “Steer to 5G” to get more of your 5GHz-capable devices on the 5GHz frequency.

 

In general, I’m finding my overall Sonos deployment is less stable than before, now I’ve added a Move on WiFi. That’s disappointing. But, it’s working well enough I’ll keep it. After a spot of testing at the weekend, I’ve discovered:

  • I need to select devices that are on Sonosnet, start that group, and then add the Move to that group, to keep things more stable. The Move can’t be the “base” speaker that I add others to.
  • Get the streaming going for a few minutes before moving the Move. It seems it takes a bit of time for everything to settle down (I get a few dropouts for some speakers initially)
  • If I Move the Move once it’s working, it continues to work well.

If I move the Move while it’s streaming, my WiFi network tends to keep it attached to the same AP, which helps with stability. So for my use case, this is fine: the Move will typically live in the Kitchen, alongside some Play:3s and a One, and then will mostly move to the garden on sunny days.

 

I am disappointed that adding a Move has made my Sonos setup more fragile, and that I need to think about how everything is working before doing any moving, but hopefully things will improve with subsequent releases and updates.

IHow do you do that?. I don’t have separate SSID for the 2 bandwidths and I’m not aware how one can choose. Any help greatly appreciated

I think you would have to have separate SSIDs.  Many routers give you that option.  But if things are working fine as they are I would leave well alone.

Badge

I had exactly the same problem as you describe, my sonos was very stable using a boost but when I added a move I started getting issues with grouping and dropouts, my broadband router didnt allow me to split the frequences so I brought a new router split the frequencies, removed the boost now everything is on WifFi its all very stable.

Have you checked the network matrix for interference? Browse to http://Speaker IP:1400/support/review to check, I was told this last week it really helped me refine my setup

 

I have the troubles here,, the MOVE make me crazy .. all stable,, and when i add the MOVE in a group,, all terrible .. 

Reply