Google Wifi, Google Fiber and Sonos

  • 6 February 2017
  • 11 replies

There are a couple of other threads in the forums about people having problems using their Sonos system after updating their WiFi to the new Google WiFi mesh network. I wanted to share my experience as well, especially if you also are on Google Fiber.

I am on Google Fiber in Kansas City. My entire home network was working just fine... I have a Netgear Nighthawk R7000 wireless router configured as a an access point. I only switched to Google's WiFi ($300) because I am an early adopter.

When I switched, setup of the Google WiFi three access points was easy. Things were working great and I was getting decent speeds. The problem is, I couldn't use my Sonos controller on my iPhone or iPad any more. So I went through a lot of trial and error and never got it figured out. I factory reset my Sonos bridge and turned off all of my Sonos speakers to try a fresh install. No matter what I tried, the iOS device connected to my Google WiFi could never see the Sonos bridge, even though it was hard wired into my network. And it was hard wired earlier than the Netgear Router... it was hard wired through a switch directly connected to the Google Fiber network box. (Again, this setup worked fine with the Netgear Nighthawk Wireless Router.)

It Gets Worse
Google Fiber rolled out the ability for all their Google Fiber TV boxes to be Chromecast devices. Prior to the Google WiFi install, I could target any of the three TV boxes in my house and cast content to them just fine. After Google WiFi, I couldn't seem them from my apps as available Chromecast devices. They had disappeared.

I completely reset my Google Fiber network (on the web, logged in as admin). I power cycled my entire house. I spent 2 hours on various troubleshooting articles and forums. Unplugging... plugging in. I tried everything I could think of and I am a technical person.

So here's the deal... I wanted to write this in case anyone else is having similar problems. I am leaving my Nighthawk router in place... anyone want a Google WiFi set of 3 access points that is 2 weeks old for $150? :)

Good luck.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

To operate as a mesh your Google WiFi must be in router (not bridge) mode. Devices connected 'upstream' of the Google WiFi -- such as your Sonos BRIDGE -- would have been invisible to wireless devices. They'd be on a different IP subnet.

Wire everything 'downstream' of the first Google WiFi unit.
My Sonos services stopped working as soon as I got google fiber (Austin Texas) back in Jan 2017. I also tried starting all over and resetting everything. I can no longer register my system. I even bought a new bridge--that didn't work. I tried my bridge at a friends house and it worked just fine. So it's my network that's the problem. I've tried everything and nothing works; and I'm pretty good with networks. I host my own websites at home and that was an easy setup to do the ip forwarding for http and https to my web server. But this problem perplexes me. My sonos devices ip addresses are hard wired and only a few ip addresses higher than my other devices so I don't see how they'd be on a different subnet. I don't see any configuration for bridge/router. Is it a DNS problem where the sonos system tries to get to the sonos servers but it can't resolve the address?
Go to http://x.x.x.x:1400/tools.htm where x.x.x.x is the IP of one of your players. See if names can be resolved and selected internet hosts pinged from that device.
Can you elaborate on "Wire everything 'downstream' of the first Google WiFi unit."?
Can you elaborate on "Wire everything 'downstream' of the first Google WiFi unit."?
To the LAN port on the first, or satellite, units.
CrazyIvanKC, I'm about six miles away from the Google Fiber wall in my city so no Gigabyte love here. I'm a early adaptor too so I'd be happy to buy your Google Mesh router if you end up selling it off. Drop me a note!
ratty, I was able to connect to one of my players at http://x.x.x.x:1400/tools.htm. The topmost entry had a button for "ping".

I tried pinging "" and got message: "running /bin/ping -c 3" and "ping: Host name lookup failure. I was able to ping "" from a command prompt. I feel like I'm making progress. What should I do next?
"ping: Host name lookup failure.
That does sound like a DNS problem.

What does it say at http://x.x.x.x:1400/status/etc/resolv.conf ?

And what does the last line of http://x.x.x.x:1400/status/opt/log/udhcpc.log say ? It should contain 'udhcpc:renew' followed by the DHCP response parameters.
There's the problem. It's pointing to one of my we servers where I run a dns so my local network can resolve computer names. What should I do?

Doesn't that local DNS resolve external domain names with a public server then? How are other devices on the network resolving internet destinations?

Sonos is getting its DNS from your DHCP server (hence the http://x.x.x.x:1400/status/opt/log/udhcpc.log query). You need to fix that so Sonos gets a valid DNS. A solution which would obviously work is i.e. Google's DNS.