Question

Do I have STP issues with a Sonos boost and Connect both hardwired?

  • 30 October 2016
  • 13 replies
  • 439 views

Hi,

We have a Sonos setup that is split across two buildings. One building houses audio and networking equipment and building 2 is where the sonos speakers are playing. We have issues where the Sonos Connect sometimes isn't found and doesn't show up on the network. We use the Sonos connect for line-in functionality.

Based on the research I've done, it looks like I might need to disable the wireless on the Connect and/or replace my switch with one that supports STP.

I've attached a diagram for reference, just wanted to get some input before I purchase hardware.



Thanks!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

There shouldn't be an STP issue with that switch. That said, given your config I'd be inclined to disable wireless on the CONNECT anyway. It's not officially condoned of course.

When you say the CONNECT doesn't show up on the network, do you mean in a Sonos controller, or are you losing it in a device scan such as with Fing?
I have used unmanaged TPLink switches without STP issues so I doubt it is that.

Have you tried using a different wireless channel for your Sonos system? Maybe there is some contention with the APs.

Have you tried a new patch cable between the Connect and the TPLink switch? A bad Ethernet cable can create some tough to diagnose problems.

Not a fan of shutting off Sonos radios but you could try it on the Connect just to see if it changes anything.

Also make sure your DHCP setup is clean with reserved addresses for the Sonos gear and as many other networked items as possible.
I'm losing it in a device scan as well as it disappearing from the Sonos controller. When I try to ping the IP it just times out.

I'll try out the options you guys mentioned (e.g, new cable, disable wireless, change wireless channel etc)

Thanks!
I played around with it some more today and I found that if I disconnect the Boost, the Connect shows up in the controller and is stable. As soon as the Boost is connected to the network (hardwire), the Connect drops from the network (not pingable and can't see it in the controller). It seems like there is some type of contention between the Boost and the Connect.

I'm tempted to reset all the devices to factory state, forget the current system in the controller, and re-add all the devices starting with the Connect.
Actually this does sound like an STP thing based on what you are seeing. If you unplug the Boost do you lose all of the players in building 2 or do they still work wirelessly across to the Connect in building 1?

Or can you go the other way and unplug the Connect from the switch and see if it will reach the Boost wirelessly?

Also what device are you using to look at the network and where is it located?
Yes, if I unplug the Boost all the players in building 2 are lost. I think the Connect and the Boost are sufficiently far enough that there is no way the Connect can jump on SonosNet

Likewise, if I unplug the Connect from the switch it doesn't reach the Boost.

I'm using a laptop hardwired into the switch in building 1.
So there is no wireless path between building 1 and building 2 so the contention is not due to multiple routes. I wonder if the Boost is having a problem with Unifi AP? How close together are they? Is there any channel overlap?

Is there any way to leave the Boost off and temporarily plug one of the Play1s into the Ethernet feed from the switch? This would give you the SonosNet mesh in building 2 without the Boost to see if the problem is the Boost itself or if it happens any time that SonosNet in building 2 is linked to the switch.
I just moved the Boost and UnifiAP to be next to each other this past weekend. Previously they were about 10-15 feet apart. I'll look into the channel overlap as well.

I think I have enough length in the Ethernet cable to bypass the boost and go straight to a Play 1. Will give that a try!
So just to clarify, did things work better before you moved the Boost closer to the Unify AP or did the system never work?
The system was previously generally working with some occasional drop out in sound. The occasional drop (interruption) in sound is what lead me to believe there might've been STP issues.

After I moved the Boost (had to unplug and re-plug power) I haven't been able to get the Connect and Boost to co-exist on the network at the same time. Moving the Boost did slightly put it closer to the Connect. It didn't occur to me that moving the Boost might be triggering the problem (e.g, interference with Unifi AP, Connect jumping onto SonosNet - I haven't physically observed this yet)

Unfortunately this set up is not at my house but at my church so I won't be able to trouble shoot again until the weekend. I drove over there yesterday to play with it based on the initial feedback and that's how I learned a little more.
Sounds like it is worth checking the Wi-Fi stuff in detail:

Make sure the APs and Sonos are on different channels

Make sure both are limited to channels 1, 6, or 11 so there is no overlap

Make sure the APs are set to a channel width of 20 MHz NOT 40 MHz and NOT automatic 20/40

Try to keep the APs and Sonos devices as far from each other as possible

There has to be a simple cause... hope you find it.
Well, I was able to fix the issue but I'm not 100% what was the true cause of the problem.

I completely disabled/powered down the Unifi AP and it didn't improve or change the situation. I did go ahead and make the changes to the settings as mentioned.

I installed a managed switch with STP support and configured it based on some settings I read on the sonos community board. I wired both the Boost and Connect to it and things started working but still had occasionally drops. I then unplugged power to the Boost and left it unplugged for about 5 mins. During that period I also disabled wifi on the Connect. I plugged power back to the Boost and everything came up and has been solid with no drops.

I'm not sure if it was the powercycle of the Boost that fixed things or putting in the managed switch or both, but that's what it took to get things working again. I'll keep the managed switch in the event our setup gets any more complicated in the future. Thanks for all the tips and input!
I would guess that disabling the radio on the CONNECT is what helped. What exactly is the wired connection between the two buildings? Ethernet? Roughly how far is it?