Connecting arc via ethernet cable

  • 6 September 2021
  • 4 replies

I have had a few problems relating to my wifi and thus I invested in having an ethernetcable installed next to my arc to be able to connect via this cable, since the arc, sub and sorround speakers are furthest away from my router.

However when connecting via cable directly to arc, nothing seems to be changing. If I try to deactivate wifi in the setup menu, the system however states, that I have to install an ethernetcable (which I already did).

How can I see whether the speaker is using cable connection or wifi? And do I have to deactivate wifi in the speaker setup menu?


Best answer by ratty 6 September 2021, 18:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

In Settings/System/About, the Arc should show WM:0 if the Ethernet is working.

Do not disable the ‘WiFi’. It has nothing to do with WiFi. It disables all the radios on the unit, stopping it from communicating with its surrounds and Sub. 

Userlevel 7

If your speakers are in a “wired” setup, if you go to Settings > System > About My System, the last line under the speaker information will display as “WM: 0”.

It is also best to keep WiFi enabled for all speakers even when in a wired setup.

Thank you both of you.

My settings shows wm:1 on all speakers except for sub and sorrunds which show wm:2 

Sub and sorrounds are setup as home theatre together with arc.

Does this indicate that arc is still running on wifi? And do I have to change any settings before plugging in the ethernetcable?

Your Arc is still on WiFi. The cable isn’t working. Try re-socketing it at both ends. It that doesn’t work the cable installation could well be faulty. The installer might have messed up the pinout.

No settings need to change on Sonos. It should just flip over to wired operation.