Spectrum problem

  • 14 February 2023
  • 43 replies
  • 6419 views


Show first post

43 replies

@Airgetlam, can you Bridge the SPECTRUM?

I think it depends on which one you get. The version I had, 4 years ago, yes. I’m not sure that version is still available, but I haven’t checked, I’m happy not to have to deal with Spectrum any longer. That being said, I’m really hoping fiber gets to my location in the next several years, right now CenturyLink is the only wired possibility, and they failed four attempts to install over three months, I have too many trees to go with a satellite option, so I’m stuck with a 5G offering from a cellular company. Living in the sticks does have some connectivity restrictions. 

Userlevel 7

Which Router is recommended for Sonos products?

Motorola cable modems work well with Spectrum and Sonos. I have been using the Motorola MG8702 cable modem with success.

Which Router is recommended for Sonos products?

Motorola cable modems work well with Spectrum and Sonos. I have been using the Motorola MG8702 cable modem with success.

I already ordered the amazon Eero.  Hope that one is compatible?

Badge

Yes, further research shows that my particular Spectrum router - SAGEMCOM SAX1V1S - is locked down by Spectrum so you cannot change the band steering settings, which seems to be the cause of my Sonos issues.  So I will likely be buying a router and give this one back to Spectrum… but at least that should save me $5 a month!

In my case, the Sonos devices have no issue connecting to the router, presumably on the 2.4Ghz band.  The problem is really a disconnect between the Sonos “network” and the phone app, and seems to occur when my phone connects on the 5Ghz band, then I can’t “connect” to any of the Sonos devices.  As a temporary workaround, it seems like when this occurs, I can temporarily shut off the phone wifi, and turn it back on.  Usually everything then connects… at least for a while. PITA, but at least I can select music again until I get a new router.

 

Hope this helps someone else with this issue.

Thanks, let us know what router you do get and share if what special configuration changes you need to do. I’m shopping around but still hesitant to pull the trigger. :-) 

Badge

Some routers do not allow 5GHz clients to communicate with 2.4Ghz clients. If this is your situation, when the phone signs-in on 5Ghz it cannot communicate with SONOS, but if the phone signs-in on 2.4GHz it is available to the SONOS system.

So how do you force your phone to sign in on the 2.4GHz band? 

You would need to give different SSID’s (WiFi name) and passwords to 2.4 and 5GHz segments. My understanding is that this is not possible with some of the SPECTRUM routers, nor is it possible to change the setting that blocks communication between 2.4 and 5GHz segments.

The phone will automatically pick the ‘best’ WiFI. Potentially you could carry the phone to an area not covered by 5GHz as the phone starts up, but this would be a very fragile arrangement because if the phone ever renegotiates its connection, it will again pick ‘best’ at that moment.

Badge

I’m still having issues where the system loses the network and I have to unplug all my speakers and search for the system. I’m looking at this router: WiFi Router 1200Mbps, WAVLINK Smart Router Dual Band 5Ghz+2.4Ghz. Will this be a good option?? Tired of the constant disconnects with the Spectrum router! 

Badge

Been having similar issues ever since we got a new Spectrum router.  All three Sonos devices appear to be connected to the router, but fall in and out on the app.  Seems very random, with constant “connection” issues… at least as it appears on the app.

Tried this today and so far it seems to have fixed the problem!

In the My Spectrum app, clicked on Router and Advanced Settings.  There is a setting there called UPnP (Universal Plug and Play), which “enables devices on your network to find each other and communicate”.  This setting was disabled… enabled it, and after the router reset now everything works!

Hopefully it continues, but so far its working consistently.

@Steve821 Makes me wonder why Sonos did not recommend this.

Please let us know if that is a consistent fix. 

Thanks!

Hello,

There are known Wi-Fi issues with Spectrum routers. See Incompatible hardware with an available solution

The general resolution is to use Sonos in a wired setup."

"Wired" is not a good solution! Results in poor, limited speaker positions.

That’s why I use a Sonos BOOST. It can sit close to the router, without sacrificing a speaker.

Userlevel 7
Badge +22

I’ve found it fairly easy to wire several Sonos here, in particular the Arc and Beams since I already had Ethernet to the TVs.

A Sonos Boost is also a good option to get off WiFi IF you don not have any WiFi only Sonos Era speakers.

We travel a lot. This Spectrum router incompatibility was just another disappointment. Guess what, Roam doesn't work with hotel wifi. Last year it took 2 calls and 3 hours of Support time to make our SL One speakers work in an Airbnb. Sonos product is just too fragile. Big regret I bought it. It won't play Amazon music, can't "find" the music yet the same music plays via Bluetooth to the Roam. On and on. 

Hi,

   As of 5/15/2024 the problem persists. I went with a inexpensive AX1500 and Sonos Beam,Sub Mini,2sl wireless . All working fine as of now.

 

Badge +1

Most Spectrum routers do this with no issue. IF you are in an area where they are supplying Eero routers instead of Arris, Netgear, etc. you have to do a “trick” to get 2.4 active. See in our video below.

 

https://www.youtube.com/watch?v=dybX7rjoQdY&t=4s

Sadly this did not resolve the issue.  I’m thinking the change in router setting just did a restart of the router which made it “work”… for a while.  By the next morning, the same problems were occurring.

The odd thing is that each Sonos device remains connected to the router just fine.  I can press play and each one will resume playing the last station or playlist.  The problem seems to be more with the app not being able to connect to the Sonos network.

Really wish someone would figure this out!

Folks, the easiest fix for any router issues is to plug one of your speakers into the router with an Ethernet cable. Your Sonos system will automatically create its own network and, just like that, all router related issues are solved. Of course, you need to have your router near enough to one of your speakers, or run some cable through your house. But for me, it was a much easier and less expensive fix than having to buy a new router. And yes, you only have to connect one speaker, not all of them. 

BTW, my issues were caused by a new router from Spectrum.

Badge

Sadly this did not resolve the issue.  I’m thinking the change in router setting just did a restart of the router which made it “work”… for a while.  By the next morning, the same problems were occurring.

The odd thing is that each Sonos device remains connected to the router just fine.  I can press play and each one will resume playing the last station or playlist.  The problem seems to be more with the app not being able to connect to the Sonos network.

Really wish someone would figure this out!

ugh. Thanks for the update. Everyone says to purchase your own router… 

Reply