Can't connect AGAIN!

  • 20 July 2023
  • 44 replies

Userlevel 2

Last week, for about the 20th time in 2 years, my Sonos Play1 wouldn’t work.  App did nothing.  I tried to update the app, nothing.  I saw there was a new app, so I downloaded that. Tried to re-pair my speaker or whatever, nothing.  Then suddenly it works.  No problem.  Everything fine.  I think finally, a new app, this will be better.

Today, nothing.  NOTHING.  Tried to re-set it, won’t work.  Won’t recognize it.  I’ve spent hours on this.  SO frustrated.  The speaker sounds great when it’s work (which is only maybe 50-60% of the times I’ve tried to use it).  Bluetooth would be so much easier!

44 replies

This is primarily a user-to-user community, though Sonos staff do oversee it and participate at times. You’ve had your rant. You’re not here to seek help, and in any case we’re clearly too ill-informed to assist with your troubles. 

If the objective really was to find a solution, you would've asked for one instead of hurling insults.  Me?  I'll go help someone who actually wants help.  Nothing to see here.

The “solution” might be that you need to learn something new.

At one point I had SONOS issues much more severe than you are reporting. After I learned a few new (to me) things, I was able to fix my environment and it has been smooth sailing since. That was in 2005. If I had been having constant, unresolvable issues along the way, I would not be here.

If you will not share any details about your home network and are unwilling to learn, we cannot help. You mentioned that you have updated your network along the way. I suggest that you again hire an expert. Hopefully the person that you hire has been keeping up with technology. 

And perhaps oddly, I’ve been using my Sonos speakers for well over 10 years, without issue. 

Not helping Bruce...

yup … just what I was saying … and if you were listening, you would have seen my comment that I hired  the skills to ensure my network was robust and capable of handling the sonos system … 

did I reach out to sonos to seek help in resolving my issues? absolutely

Were you in my home evaluating either … I think not … so kindly withhold your opinion of what I’m doing wrong until you have all of the relevant information

spare me the platitudes

I expect you will take further shots at me to fuel your ego and make yourselves feel important at my expense but I won’t partake in any more of this waste of time 

It’s the “Trump approach” … if you yell louder, longer you think you’ve won, when actually all you’ve done is proven your insecurity in the world not seeing it your way … the last man standing in these debates is seldom right … the objective is to find a solution

I’m not about to lie to anyone here this man is right. I just sat here and read this whole forum and weeewwwwhhhh. As a network engineer for a International Fortune 500 company I can confidently say you're right. I mean my network is STACKED. 5 Gig dedicated fiber connection coming into a pretty heft firewall going into an extreme switch with a network and multiple extreme 510i APs throughout my house. There isn't a single corner of my house that doesn't get AT LEAST 700 MBPS both up and down and from the AP in the living room where my sonos has line of sight my S24 Ultra on a speed test pulls 1.1 MBPS. I mean corporate office in the thousands capable network in my house for no reason other to say I have it honestly.

Every single device (about 30) is on a static IP and set aside in its own range separate from my DHCP. My sonos will randomly drop. and I only have the one. A singular play 1 that struggles to stay on the internet. Go and check my firewall logs and its not even requesting an IP address on Ethernet even. I dont have a way to MAKE it call for one. Then when you factory reset the thing to connect it to your phone and do the setup through the Sonos app it wont even connect. This is on my wife’s 15 pro max, My work Pixel 8 Pro and my personal S24 Ultra. Call Sonos support and let them tell its dead. However let me take my old router and plug it in on my backup spectrum connection and it magically works. SO dead XD.

This is a SONOS issue.


Every single device (about 30) is on a static IP and set aside in its own range separate from my DHCP. 


Interesting.  Does this include Sonos devices?

Userlevel 7
Badge +18

Just to clarify, @phishmeister, you just have a single Play:1 if I read your post correctly? That’s quite an old device, with more limited network capability than more modern Sonos devices. Is this a recent acquisition for you or have you had it (and your connection problems) for a while? 

Yesterday music heaven Today …..nothing ……has there been a recent upgrade/downgrade do I have to restart the whole world? Do I have to unplug my whole house AGAIN WTF what is happening must you guys fk around all the time now IT wont connect all it will do is make the beeping microphone noise then says it’s not on my network I CAN 100% guarantee it is. Why why why why are you a real company or do you make expensive speakers that last as long as you don’t DO A SYSTEM UPGRADE FFFFSSSSS how do I get around this do I have to move house AGAIN or something similar. 

If I can interpret your post properly, I suspect a fairly easy solution to your network issue is setting up reserved IP addresses in your router for your Sonos (and frankly, I’d do it for everything on your network). 

You can do a short term fix a bit more easily by unplugging all your Sonos devices from power, then reboot your router. Wait two minutes before plugging back in your Sonos. But a router that has ‘failed’ in this manner once will be likely to do so again. Reserving IP addresses helps guard against this network behavior. 

One i am not a techie and the play 3 is old. I have had the same problem through out its life. I really dont care whos fault it is. What is a dhcp readable address and can it be done simply. Please give the steps to see it works for me. Appreciated.

Setting reserved IP addresses in a router’s DHCP table depends on the router. Your best bet is to look in the manual for the router, since they’re not even always the same within a single manufacturer. And, as in my personal case, currently, using a wretched T-Mobile provided device,  the router may not always allow you to use reserved IP addresses.

However, you don’t have to do it, if the thought overwhelms you. You can do essentially the same thing, albeit potentially more temporarily, merely by unplugging all your Sonos devices from power, then rebooting your router. Give the router a couple of minutes to load everything before plugging back in your Sonos devices. 

It’s possible that the router, having gotten into that state once, could do so again, but it may not, too. It does get exposed more frequently by Sonos, due to the fact that they reboot every time you install new software, and ask the router for a new IP address. But that simple process resets the DHCP table, and is relatively easy. 

Userlevel 7
Badge +22

Please give the steps to see it works for me. Appreciated.

As said the steps are router dependent but if you open your router’s web page and look for DHCP Settings it may have an internal help page or a link to the on-line help page that will walk you through it.

Pretty much what you do is put in the Sonos MAC address and the IP address you want it to use. Then power down everything and then bring it back up using the new addresses.

I share the same frustrations with this guy. The speakers will only connect to the network 40% of the tome. It’s been like this for years. When is go into the app, I regularly get the message “Unable to connect to Sonos. Let’s fix it.”. However the app troubleshooting never works. It’s completely sporadic. However my WiFi works perfectly with strong bandwidth & no breaks in connectivity. As I type this, the speakers won’t connect. Is this because of my router reassigning new IP addresses?  If so, how do I fix it at the Sonos end? I’m close to the point where I’m ready to ditch my 4 speakers and buy a different brand.

Some further context. The Play is connected to the network (it plays when I press the Play button on the speaker itself) but the app can’t find it!

Userlevel 7
Badge +22

If you’ve tried the suggestions above and it still isn’t working well...

Send in a diagnostic when having the problems and call Sonos Support to have them look at the internal data that we users can’t see.

Some further context. The Play is connected to the network (it plays when I press the Play button on the speaker itself) but the app can’t find it!

The controller Apps are impatient. As the controller starts it sends out a type of “who’s there”, but if a speaker does not reply before the timeout, you’ll get a “not found”. Some network characteristic is intermittently blocking the query and/or delaying the response.

I have been frustrated with connectivity issues as have many Sonos users. I did talk to Sonos and they did the usual thing saying it’s not on their end. I did come across something that I had not seen before so will share it:

Go into your router. Under “Advanced Settings”, click on wireless. Then click on “Professional”. Then go down to Airtime Fairness and click on “Disable”.

It actually worked. I can’t guarantee that this is the fix for everyone, though it saved me from getting rid of my Sonos system out of frustration. 

Note: I have an ASUS RT router. You may have a different appearance of tabs once in the router menus. Just look up how to navigate to “Airtime Fairness” for your router. 

It’s absolutely ridiculous that we even have to talk about these technical solutions, or suggestions to reboot your network. You buy an expensive Sonos you must be able to rely on the system operations. I am so disappointed and regret expanding my system with more units. Since the app update my problems drive me also to sell it to someone who is willing to waste time finding solutions with the poor performance level of Sonos.

There comes a point where its time to accept the fact that Sonus  Play 1 is no longer in the design and  test plans. I reached it.  All to hard and inconsistent results.