Temporarily putting Roam on another wifi network

  • 4 September 2022
  • 9 replies

Userlevel 2
Badge +6

I have a Sonos S2 system with a few Ones and a Roam in it.  We’re going on holiday soon and would like to take the Roam with us and put it on the holiday home’s wifi network.

I’ve read other posts saying I can go to the general network settings and add multiple wifi networks which sounds exactly what I want.

However, I’m just a little confused.  If I take the Roam away from my own network, how do I connect to it so I can put the new wifi network in?  

Sorry I’ve seen a few questions on it - a lot about using multiple Sonos systems which isn’t what I’m after - but I’m obviously missing one small detail.  I’m sure this must have been answered elsewhere.


Best answer by John B 4 September 2022, 16:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 2
Badge +6

Oh maybe it’s dawned on my what a stupid question this is.  I’ve never really intended to use the Roam as a speaker I can easily take around the (one) home so I’ve never used it in bluetooth mode before.  I’d got it in my head that it just acted like a dumb bluetooth speaker and would just play what’s on my phone.  But I’m guessing it just still appears in the Sonos app and I can control it as normal.  Is the right?  In which case, please do excuse the idiotic question.

You just take your controller device and connect to the local Wi-Fi. With the Roam powered on, try "find missing product". You should be able to add the new WiFi details 


Jeez it isn't an idiotic question at all. My reply crossed with your second post.

Userlevel 2
Badge +6

Thanks so much for the reply and not making me feel too dense for asking the question.  It sounds like it should be simple enough with any luck.  Really appreciate the help!

I'd be interested to hear how you get on. Currently in a holiday house in France where the only way I could get the normally UK-based Roam to connect to the new wi-fi was to factory reset the Roam and replace the S2 controller with a new copy.  The 'Let's Fix It' option jmostly just got stuck looking for the Roam.  Even when the Roam was found the 'continue" put me back in the loop (as best I can remember as, as with most IT hitches, you end up tapping mostly to no avail at so many ineffectual options).  Of course, the reset and reload resulted in the Roam being set up as a new system and needing a couple of music services being put back on.

PS Anyone noted the big posting milestone ratty is approaching?

Userlevel 7
Badge +15

Hi @BrianJ , I had exactly the same experience as you and could only see the Roam by resetting it.  It was the first time I'd really used the Roam so wasn't too familiar with it.  Upon return home I tried to then add it to home WiFi but was stuck in the same loop and had to reset it again.

When on holiday and trying to add it, the App told me it had found the system but when I selected it, it listed the devices that were S1 and at home, not the Roam.  Each time I tried different options but invariably ended in a loop of it not being found.

I did post screen captures here on my return but don't recall any Sonos response.

EDIT: URL added -


Userlevel 2
Badge +6

Just got back from holiday, and it all worked, but it wasa awkward to set up.  Bear in mind, I am an iPhone VoiceOver user, so my experiences are  likely different to most.

Also, my memory is a little foggy so apologies if some details are incorrect.

When I got to the hholiday home, I set my phone up on the new wifi network and plugged in the Roams.  (Yes I got a second one).  Beforehand, I had Bluetooth paired both Roams to my phone.

The app warned me there was a problem finding any products.  I went to Settings but options like Network were all dimmed.  I found the warning and tapped the show more link.  Whatever happened next didn't work with VoiceOver as I got stuck and couldn't hear anything, so quit the app.

This happened anothre time.  I think on the third go I happened across a link to find missing products by swiping around.  I think this took me into the place to sort it out but I'm not entirely sure how I got there.

While I was doing this, my sighted partner was using her Android and also couldn't find the option.

Anyway, I got a list of all Sonos products, although I don't think any were named, so I was glad my Roams were different colours so I could tell them apart.  I tapped Select on one of my Roams and entered in the new wifi details.  After a while, I got an error saying it could not connected.  I tapped retry and got the same.

However, when I went back to the system part of the app, the speaker was there.  I went into Settings and Network was available, so went in there and opted to Add or Update networks.  I selected the other Roam and it connected quickly without prompt.

The only other issue I had was with Voice Control.   The older Roam was on Alexa and Sonos Voice Control and worke, but the other was using Google and I couldn't get it to respond properly.  Frankly, I think Google Voice on the Sonos is not a great option, so I replaced it with Alexa and Sonos Voice Control.  This worked, except Alexa couldn't properly control playback and had no idea what was playing.  It also didn't know what my new Roam was called.  But between that and Sonos Voice Control I got everything I needed.

When I got back home, I plugged them in and they just rejoined the old network as if nothing had happened.  I think Alexa is now working as it should too.

I'm not entirely sure how it works - I don't think it uses Bluetooth so guess when you plug it in and it can't connect to wifi it must go into some sort of discovery mode.

All in all, I was pretty happy with the experience, but it could have been a bit slicker.  But once working, it was great.

Userlevel 2
Badge +6

Actually, I was wrong about the Alexa integration - I found it was broken across all my devices.  It couldn’t control music and kept telling me I was listening to something I hadn’t heard for a while.  However, removing the Sonos Skill from the Sonos app and re-adding it seems to have fixed the problem. 

My Nest Mini (or whatever it’s called) also seems to have lost it, so I guess I’ll have to do the same there.

I can’t say for sure it’s to do with my holiday or whether it was the most recent Sonos update.  At any rate, not a big deal and was easily fixed, but just mentioning it here anyway.

Sonos has nothing to do with your Nest. It was more likely an issue with Amazon’s servers, which they’ve fixed. Likely not the Sonos update at all.