Answered

Sonos Roam showing as „not connected“ - but does not seem to be off

  • 17 December 2023
  • 5 replies
  • 330 views

Userlevel 3

Hi!

I have a recurring issue with our Sonos Roam.

It is populated with lots of episodes of a children’s series.

The idea is, that our daughter just can press play when she wants to listen to it.

The Roam is connected to power all the time.

Battery saver and WiFi Power save is on, but this does not make a difference.

What happens is as follows:

Every few days the Roam shows up as „not connected“ in the iPhone app. As such, I cannot control it from the app anymore.

Pressing play just plays a click sound and the left LED flashes white twice. It does not start playing and does not wake up (i.e. still not connected in the app).

When pressing the button on the back, it plays a two note chime, still nothing happens.

The only thing that helps is holding the button on the back until the turning off chime plays - waiting a few seconds and then turn the Roam on again by pressing the button again shortly.

I made a short video, that shows the behavior:


Any idea or help is much appreciated!

 

icon

Best answer by Jamie A 18 December 2023, 15:56

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +16

Hi @scope_v24_gts, welcome to the Sonos Community!

I’ve had a look in our resources and can’t find anything that specifically relates to the issue you’re having. I would recommend you reach out to our support team for further troubleshooting, as they can look into your system through diagnostics to see what the issue is.

I hope this helps!

Userlevel 3

Hi!

Thanks for your help!

Yes, I’ll he to contact support.

Unfortunately it seems there’s only the option to chat or to make a phone call, I don’t have time for both for the usual service hours.

E-Mail support would have been nice…


Greetings!

Userlevel 3

Hi!

Just a small update:

I had a chat with the support. I was told that the behavior  I described matched a case they are currently investigating.

There is no ETA for a fix, but it is actively being worked upon.

It might have to do with having multiple access points.

I myself use three Unifi AP AC Pro in our house.

I was given the following config changes I might try to resolve the issue on my end:

1. Log into the UniFi controller
 2. Click the Settings tab on the left sidebar
 3. Click WiFi under the Settings page
 4. Click on the network SSID. Note: if there are multiple SSIDs that the players and controllers connect to, the same will need to be done for each SSID.
 5. Scroll down to Advanced Configuration and set it to Manual
 6. Verify and confirm that WiFi Type is set to Standard
 7. Click on the Apply Changes button at the bottom of the page.
 8. Click on Settings > Networks and select the network that Sonos is being set on.
 9. Scroll down to Advanced Configuration and set it to Manual
 10. Verify and confirm that Network Type is set to Standard and IGMP Snooping is enabled.
 11. Disable the following options by unchecking the Enable option:

     a. Multicast and Broadcast Control (blocks all multicast and broadcast for non-listed devices).
     b. Multicast Enhancement (converts multicast to unicast when possible).
     c. Client Device Isolation (prevents wireless client on the same AP from communicating with each other).
     d. Proxy ARP (converts broadcast to unicast when possible).

 12. Once completed, allow up to a minute for the settings to apply and for the online connection to be restored, then proceed with the process again.

 

Nevertheless they acknowledged that it is a known problem that has to be fixed for the Roam.

I have this same issue. Is there any idea when it will be resolved?

Thanks. 

I have this same issue. Is there any idea when it will be resolved?

Thanks. 

The post above yours, is suggesting it’s an SSDP multicast broadcast device discovery issue between the speaker and controller App. So on that basis reboot your router, switch off any other hubs, WiFi repeaters/wireless access points and check which WiFi band the Roam is using.

Switch off any VPN/Firewall or other security software on your controller device and connect it to the same access point (router) using the same WiFi band and then you should see your Roam reappear in the App, assuming that there are no settings on your router that disable multicast broadcasts.

Once the Roam is back in view, you can put things back in place and try to discover what might be interrupting the multicast packets and intermittently stopping the Roam being discovered across your local network.

Hope that assists.