Sonos Roam not working..


My Sonos Roam will not work.

When plugged in with USB-C, the orange light comes on and stays on but cannot operate the Roam.

When unplugged, no lights, cannot turn on at all. 

Can anybody help me??!


Best answer by Airgetlam 9 November 2022, 21:07

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Not sure what you mean by “cannot operate the Roam”. Were you able to follow the setup process first, and now it’s not working, or are you trying to use it without setting it up? Does it show up in your Sonos controller when it’s plugged in, and then failing when it’s not plugged in?

Have you called Sonos Support yet? 


I am experiencing exactly the same problem. It was previously set up and was working and now it seems dead. I’ve tried a reset but cannot do it because it’s essentially dead. The solid orange light remains on indefinitely when plugged into the USB C charging cable 

What did Sonos support say when you called in?

After it’s been on the charger for a while, remove the charger and hold the Power button for at least 15 seconds. This is a different sort of reset. Now continue to full charge.

I’ve had the same situation and done all the above. I’m at a loss as to how to move forward. I bought two at the time. One is working and this one is dead - not charging. I’ve tried to charge it from the wireless charger and the USB-C but it won’t hold a charge. It’s very frustrating.

What did Sonos support say when you called them?

Same here, my Roan is dead 

Same question: what did Sonos Support say when you called them?

I had the exact same problem.

Support asked me to do a force reboot, and after that didn’t work a factory reset. After that didn’t work either, they immediately agreed to replace the faulty Roam. It was quick and painless, took no more than 15 minutes of chatting with an agent.

This was the second Roam to die on me. Getting the first one replaced involved sending them videos of me pressing buttons etc. Nothing of the sort this time.

Fingers crossed that the third Roam will be the luck one.

Thank you all because I have exactly the same problem.

Just adding my voice to show how many people are facing or have faced this issue. 

@Airgetlam don’t ask me “what did Sonos Support say when you called them?”, I will reply when I will have done it 😉