Answered

Sonos Move Update

  • 16 March 2022
  • 6 replies
  • 202 views

I have two Play:1 and one Sonos Move. The move is requiring an update, but I’m getting an Error Code 30 every time I try. I’ve tried unplugging the router (and all other WAPs), then powering down the Sonos Move, then rebooting the router, and turning the Move back on - and that still has not worked. 

Any other tips?

icon

Best answer by Ken_Griffiths 17 March 2022, 15:32

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Perhaps leaving the ‘other’ WiFi access points switched off temporarily and ensure the mobile controller and Move are connected to the same WiFi band on the main router. Also ensure the mobile controller device meets the requirements shown in this link:

https://support.sonos.com/s/article/4875

Thanks, Ken! I did leave the other access points off, but I’m still not having any success. And my app meets the requirements in that support article. 

Userlevel 7

@doubless Have you tried rebooting your phone and placing the Move closer to the main router?

@GuitarSuperstar I have - and I uninstalled the app and reinstalled to make sure that was up to date as well. I’m at a total loss as to how to fix this!

@doubless,
Error code 30 is a network error and it seems the speaker is not getting through to the Sonos update server. I would perhaps try another DNS on your router - try 8.8.8.8 or 8.8.4.4 Google public DNS servers and see if that resolves the connection.

@Ken_Griffiths - Thanks so much for your help here! I just tried changing the DNS to the ones you suggested, and I’m still getting Error 30. Any other ideas?