roam+move skip when connected to TV/beam

  • 5 November 2022
  • 2 replies



this is an issue I have had for some time now when switching to S2 but finally getting around to asking why this is happening:


I have a beam connected to my tv and when watching tv, works without issue (5.0 setup with 2 ones). However, when I group either our move or roan to the TV setup, they both will skip / have poor connection to TV audio (however the beam and ones still work smoothly)


this is unique only to tv audio.  When I stream music or anything else, there’s no issue. Pre s2, it was not a problem at all. 

I’ve tried resetting everything, software is up to date, etc and nothing seems to work. 

any help is appreciated. 


Best answer by Airgetlam 5 November 2022, 20:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

I think the S2 connection is mostly a red herring, the only indication it might be telling you is that something may have changed in your local network.

The TV input is a higher bandwidth signal than most ‘just streaming music’ sources, so it’s more sensitive to wifi interference than others. The Beam, since it’s wired directly to the TV via ARC, obviously isn’t affected. And the Beam communicates to the surrounds on its own ‘hidden’ 5Ghz network. Only the non-home theater speakers such as your Move and Roam connect to your standard Wi-Fi signal, as does the Beam itself. 

The challenge, of course, is that this wifi interference may be coming from inside your home, either from Wi-Fi or any other electrical devices, or it could be coming from outside sources. I had a new neighbor a while back, who set up their router to use the same channel as I was using, most devices worked OK, but the Sonos devices were more sensitive (probably due to less caching in the process). My whole system was happier when I changed Wi-Fi channels (god forbid I have to talk to the neighbor!). 

I’m 95% confident that this is what you’re dealing with in terms of dropouts. 


One further way to often get around this type of audio ‘dropout’ issue, is to go into the ‘Room’ Settings of the Beam in the Sonos App and change the ‘Group Audio Delay’ to a higher value (larger buffer size) for grouped rooms. It’s fine to do this, particularly if the speakers, Roam/Move, are held in a different ‘physical’ room in the Home, but you may see a delay/echo if all the Sonos products are in the same room.

To deal with the mentioned audio delay/echo, you can increase the buffer on the Beam using the ‘TV Dialog Sync’ slider bar control, which can also be found in the Beam’s ‘Room’ Settings.

However, If you do buffer the Beams audio, then you may see lip-sync issues with the video playing on the TV.