Roam doesn't always connect

  • 20 November 2022
  • 6 replies

Hello all

I am getting no where with support and wanted to reach out to you. 

The Sonus Roam turns on and connects to my network. I can always use Alexa and it works well/plays music from spotify.

The issue is that it often doesn’t show as an option to connect to within spotify or the Sonus app.  This issue may resolve c10mins into turning on but as you can imagine it is v v irritating.  Before letting the battery discharge and leaving in a cupboard/giving away, I wanted to know if anyone has a fix for this.

I currently have the issue on Samsum S21 ultra.

Thanks in advance all



Best answer by Corry P 25 November 2022, 16:37

View original

6 replies

It sounds like an SSDP device discovery issue over the network - what router/WiFi system are you using. Is there more than one WiFi access point (extenders/repeaters/EOP adapters etc?) Any network switches managed or unmanaged across the network? - and what WiFi band, channel and channel-widths are you using for the Roam?

Hello Ken

Thanks so much for coming back to me on this.  It is a BT Smart Hub 2.  No access points, v v simple setup in a small property.  I have 2.4 and 5 ghz turned on.  Re your final points on the Roam band, Channel etc. No idea.  First world problems I know, but in 2022 I wouldn;t expect this issue on a Sonus product (maybe some dodgy Amazon knockoff but not this).


Userlevel 1
Badge +2


Reset your roam to put it back on your home network and reauthorize spotify on the sonos app.


BT routers are not the best unfortunately and it may pay to check if there are any firmware updates for it.

My son-in-law has one of their routers too and he often has a few issues with it. Anyhow do you have different SSID’s for the 2.4Ghz band and the 5Ghz band setup, or are you running both with the same SSID? 

If it’s the latter, then here’s a suggestion to perhaps consider/try, if you’re okay with doing these things… go into the router configuration pages and separate the two bands by giving them two separate names - most just add ‘-5G’ to the end of the 5Ghz band, like this example: ‘MyWiFiNetworkName-5G’.

I seem to recall you just need to uncheck a box on those routers to separate the bands and rename them. When they are separated, put both the controller mobile device and the Roam onto the 2.4Ghz band and set the band to use ‘fixed’ channel 1, 6 or 11 (non-overlapping) - if the router allows, also set the channel-width to 20Mhz only and see if those things will resolves your issue.

Note that any devices on your network that you want to use on the 5Ghz band will need to be setup again with the new SSID.

Hope that’s not too complicated for you to consider trying.. but I think it may resolve the issues you’re currently experiencing.



Thanks for taking the time to respond.

I will try what you have suggested. Speaker connects instantly to network and I am accepting that I will just use alexa rather than choosing songs on my devices such as ipad or android phone.  

Thanks again - probably going to get rid of the speaker.  Shame 

Userlevel 7
Badge +18

Hi @DrubUK 

Welcome to the Sonos Community!

The fact that Alexa works and Spotify plays very strongly suggests there is no problem with the Roam, or its ability to remain connected to the network. It is not experiencing any issues.

The problem lies with the communication between the apps (Sonos & Spotify) and the speakers - this is either due to router configuration, a router fault, network topology, or firewall/VPN software on the phone.

As you don’t have any extenders, the topology is likely simple so I recommend you switch off your router for at least 30 seconds, and repeat this several times a year whether you encounter issues or not. It may also help to reserve IP addresses for your Sonos devices in the router settings to prevent other devices from accidentally getting the same IP address as one of them, which could definitely mess things up in this way.

With routers, you get what you pay for, and forgive me if I am wrong but you did not pay for your Smart Hub 2 at all - you pay for the internet connection. As a result, most home routers in the UK - where this is common practice - are below par due to the costs of handing out literally millions of devices for what is basically free - they obviously cover their costs, but will still try to keep costs down. An option is simply to replace it - I would not recommend paying less than about £$€50.

If a reboot of the router does not help, please check your phone’s firewall/VPN software, if applicable.

Please do not reset your Roam as suggested above! It will not help.

I hope this helps.