Listening through SONOS Roam speakers to CDs played on Apple Superdrive through iMac


  • Contributor I
  • 2 replies

Hi

I have an Apple Superdrive connected to my iMac and frequently play CDs which I listen to through the iMac inbuilt speakers.  I recently purchased SONOS Roam speakers and I can play music stored on the hard drive through the Apple Music app and have it play through the Roams (and it sounds great!), but I can't get anything when I play a CD and expect to hear the music through the Roams.

Any ideas?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

The music i wish to play is either stored on the HD of my iMac, or on CD that I wish to play thorough an Apple Superdrive  that is connected to my iMac.  I can play the music on the HD using the Apple app ‘Music’ (which is an improved version of iTunes) and hear it through the Roams, which is great.  BUT, if I choose to listen to a CD the only way I can listen out it is through the iMac inbuilt speakers, whci8h is what I am wanting to avoid.

As @Airgetlam mentioned above, connect to the Roams over AirPlay.

Userlevel 4
Badge +6

Hmm.  Perhaps @kymc has just overlooked a basic feature of MacOS?  You need a relatively recent release to set the whole system’s sound output to AirPlay, but if you have that, your System Preferences / Sound panel should look like this:

So I can play any (i.e. all) sounds thru my system’s speakers (Mini=yuck) or via AirPlay2 to the Sonos Move, or the Kitchen or Bedroom which are stereo-paired Sonos OneSL’s.  (N.B.  I suppose it is theoretically possible that Apple could have intentionally prevented such playback, and I don’t have an external SuperDrive handy to test, but it seems highly unlikely.  Besides, if this fails for some reason, it’s easy enough to drag your CD tracks into the Apple Music app, creating a local library, and play from there.)

Not clear how you’re connecting to the Roams. For stored music, I’d hope you’re using the Sonos controller to access the hard drive and play. However, since the Roams are not designed as computer speakers, you’d likely need to be using either Bluetooth or AirPlay 2 to send the signal that the SuperDrive is generating. 
 

 I’m pretty sure that Bluetooth won’t send a stereo signal to two separate devices, so I think AirPlay 2 is the only viable solution. And I’d be prepared for some potential issues, as I’m not sure how much latency would be involved. Sonos doesn’t make or really promote any of their speakers as computer speakers, it is out of their expertise, and there are many, many other companies out there that do concentrate on that market. 

The music i wish to play is either stored on the HD of my iMac, or on CD that I wish to play thorough an Apple Superdrive  that is connected to my iMac.  I can play the music on the HD using the Apple app ‘Music’ (which is an improved version of iTunes) and hear it through the Roams, which is great.  BUT, if I choose to listen to a CD the only way I can listen out it is through the iMac inbuilt speakers, whci8h is what I am wanting to avoid.

Hello Tracker

Thyank you for your reply.

My System Preferences / Sound panel looks like...

You can see that the Sonos products are there.

The problem remains, when I play a CD and try to select one of the Sonos outputs, the CD stops playing!

I’m wondering whether Boom Audio might have anything to do with it? (BoomAudio is an equaliser that I use to (try and) make the Mac’s inbuilt speakers sound better!

Userlevel 4
Badge +6

Sorry, I don’t know whether BoomAudio in the middle is troublesome or not -- I have a vanilla setup.  The drag&drop of the CD tracks in the Finder onto the Music app’s icon seems like the simplest work-around.

But if you want to pursue it further, you didn’t actually say *how* you were playing the CD?  Does it happen automatically when you insert, or are you running some application?  The diagnostic method I would try is: (1) select iMac speakers, not Boom; (2) reboot (NOT re-opening prior windows automatically, == no apps running); (3) select the AirPlay speaker(s) as system sound output; (4) then play using whatever app or method.  

You didn’t say how old your system is, but know that there were MacOS bugs using AirPlay2 as the system sound output in the past: Under MacOS 10.14 for example, QuickView in the Finder (i.e. when you click on a document and press the space bar) outputs nothing at all to AirPlay speakers in my test system, even though it thinks it is playing!  It *was* buggy in the past.  It *is* better nowadays -- I think MacOS 12 was the repair point -- but it still isn’t 100%, especially in a mixed environment with AirPlay2 and AirPlay (1) devices both present on the network.  This isn’t Sonos specific: even in an environment of only Apple HomePods and Apple AirPort Express’s, I still find myself sometimes reverting output to the Mac’s computer speakers and then returning to the AirPlay speakers to clear up Mac sound output problems.

Good luck.  I’d use the work-around of letting the Music app play the CD.