TV Autoplay behavior config

  • 1 February 2023
  • 4 replies

  • Contributor I
  • 1 reply


First my issue:
TV Autoplay has a default behavior of setting the Arc volume to 10 if it is less than 10 when TV Autoplay triggers. I would like to have an option to either a) not have that default behavior happen or b) have that minimum 10 volume behavior also apply to grouped speakers.

Or both, that’d be cool.

Anywho, I have a full ARC setup with surrounds and subs in my living room. Works great. I mostly use it by chromecasting content to my TV. Usually I have all the sonos speakers in the common areas of my house grouped to the home theater. A lot of times I have the volume of all of the speakers set to 7 or 8 for background music (again, the source is my TV). When I come home or pick up where I left off and chromecast more content, TV Autoplay kicks in and sets my home theater to volume 10 while all the still grouped common room speakers are still on volume 6 or 7. Then I have to go open the app and fiddle with the volume to get them all equal again. Kind of a pain in the butt.

I’d really like to be able to disable this minimum 10 volume behavior for the arc/home theater so that my volume for all grouped speakers is exactly where I left it when I come back. This used to be the behavior before the minimum 10 thing started happening 6 months ago or so. I think a checkbox called ‘Minimum Volume on Autoplay’ in the home theater configuration menu right under ‘TV Autoplay’ and ‘Ungroup on Autoplay’ would be awesome - it would fix this problem for my use case and anyone else who’s been confused by this behavior.

Thank you for considering.
-Ryan H.


Best answer by Corry P 1 February 2023, 10:36

View original

4 replies

Userlevel 7
Badge +18

Hi @ARH 

Welcome to the Sonos Community!

Thank you - I've marked this thread as a feature request and it will be seen by the relevant teams for consideration. Keep the ideas coming!

However, I am not entirely sure that what is happening has anything to do with Sonos - I’ve never heard mention of it before, and I just verified on my own system that it doesn’t happen (my usual TV volume is 12, so I had to check) there.

Instead, I suspect that it is your TV deciding that the power-on volume should be 10. Some TVs will mute attached audio devices during startup to prevent any power-on thumps, clicks or pops, and then ramp up the volume once power-on has completed. This usually goes to the last volume level set, but it may be different for your TV. I do occasionally see this happen (Sonos shows a green light for a moment).

Note that if your Arc is already set to TV input (as in, it was the last thing it played), TV Autoplay has no effect, so I’m not sure your suggestion would always have the effect you think it might.

Thanks again for posting and for your feedback.

Edit: I realised I had not in fact ensured that Autoplay was being activated in my testing. Once I played music with the TV off at volume 6, I then turned on the TV to find the volume at 10. I’ve greyed the text above because I was wrong. Your feature request stands.

Can I send another source (such as a bluetooth receiver) through the TV / optical input to the Sonos amp, so that source will “TV Autoplay” whenever it is on? 

Userlevel 7
Badge +18

Hi @TLButton 

As long as the feed from your other source is of a format that the Amp knows how to play, that should work, yes. Please note, however, that inputting to the HDMI port on Amp will result in no buffering prior to playback - this means that if you group other rooms in with the Amp, they will not be in sync with Amp and may experience audio interruptions, depending on your network conditions. If synchronised multiroom playback of the new source is a requirement, I recommend you connect to the Amp’s RCA (standard analogue Hi-Fi) Line-In connection and use the Line-In Autoplay setting instead.

I hope this helps.

Userlevel 7
Badge +18

Hi @TLButton 

I should add that to connect Amp to an optical connection, you’ll need the Sonos optical audio adaptor.