Answered

Syncing Sonos Arc with Airplay

  • 18 October 2021
  • 7 replies
  • 717 views

Setup:

65” TCL

Latest 4K AppleTV

Sonos Arc connected via ARC port

Issue:

Sometimes I’ll be watching a program and I’ll want the audio to extend over AirPlay to various HomePods in my home. When I do this from the AppleTV, the audio is not in sync between the ARC and the HomePod(s). When I attempt to run the AirPlay audio sync tool on the AppleTV, it throws the lip synchronization off significantly.

Has anyone else possibly run into this? Thank you

icon

Best answer by AjTrek1 18 October 2021, 23:39

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7

You might be experiencing wireless interference. Try the troubleshooting tips in this article:

https://support.sonos.com/s/article/3286?language=en_US

Thank you @GuitarSuperstar. Sadly we do not have the option to change the channel with Eero. Appreciate your reply still. 

Userlevel 7

Are you able to wire any of your Sonos speakers (not a Sub or surround speaker) directly to your main router with an ethernet cable? This will create SonosNet, a separate mesh network for just your Sonos speakers that could improve your wireless performance including AirPlay.

When you’re using airplay,  are the homepods and Arc connected via airplay?  Or is it case where only the homepods are connected via airplay and the Arc is still getting audio through it’s wired connection to the TV?

Userlevel 7

I don’t have a need to send audio to HomePods and Arc simultaneously. However, the setup below causes no out of sync issues. This assumes your primary connections to TV are are follows:

  1. Arc to HDMI ARC or eARC Port on TV
  2. AppleTV to available HDMI Port

NEXT

  1. Go to AppleTV Settings > AirPlay and HomeKit > Airplay ON > Allow Access > Anuone on the Same Network > Conference Roon Display OFF > AirPlay Display Underscan AUTO > HomeKit  Room > Select Room with Arc > Home Hub > My Home CONNECTED
  2. Go to AppleTV Settings > Vide and Audio > Audio Output > Default Audio Output RECEIVER SPEAKERS > Temporary Audio Output > Select Receiver Speakers and Home Pod Rooms
  3. To stop sending audio to HomePods deselect Temporary Audio Output speakers

Note: AppleTV remote will control volume for Arc. HomePod volume will have to be adjusted via HomePod direct. 

 

When you’re using airplay,  are the homepods and Arc connected via airplay?  Or is it case where only the homepods are connected via airplay and the Arc is still getting audio through it’s wired connection to the TV?

Only the HomePods are connected via AirPlay and the Arc is getting audio from the wired connection.

 

When you’re using airplay,  are the homepods and Arc connected via airplay?  Or is it case where only the homepods are connected via airplay and the Arc is still getting audio through it’s wired connection to the TV?

Only the HomePods are connected via AirPlay and the Arc is getting audio from the wired connection.

 

Well, you could get lucky but the audio paths to the Arc and to the HomePods are totally different. Different processing requirements; different latency variation; different buffering strategies. One shouldn’t expect sync at all.