sonos s2 dolby digital plus 5.1

Dear All, I recently bought a Sonos Beam Gen 2 and its connected to my Hisense TV via HDMI ARC. On the Sonos S2 App, its showing the Audio-in as Dolby Digital Plus 5.1 and the same on ‘Now Playing’ screen as well. Once done watching I used to switch off only the TV and Sonos will be left ON all the time (as there is no ON/OFF button on the device). And afterwards if I switch on my TV then the Audio-in on S2 app is showing as just Dolby Digital 5.1 instead of Dolby Digital Plus 5.1. The issue is solved once I restart my Sonos device or by unplugging/plugging the hdmi cable. Please suggest or guide me through any other solution if available.


Best answer by GuitarSuperstar 6 May 2022, 07:34

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

What exactly are you watching? From what app/device? What specific model is your TV? Are you using the Sonos-supplied HDMI cable?

I am watching Netflix and Amazon Prime Contents through those apps respectively which is in-built on my TV and also some sports channels which supports Dolby Digital Plus/Atmos audio. The TV Model I am using is Hisense 50A6100UW and also I am using the Sonos-supplied HDMI cable.

Userlevel 7

Can you post photos of your current audio settings on your TV?

For Netflix, log in to your account on a web browser and under your Profile, make sure the Playback Settings is set to HIGH to ensure you are always getting the best quality audio. And if you want Dolby Atmos audio from Netflix, be sure you have a premium subscription.

On ARC mode, the audio options available for me is PCM, Dolby Digital & RAW. I am getting Dolby Digital Plus 5.1 on my Sonos Device (as shown in the S2 app) if I choose the TV audio option as “RAW” and also it sounds more louder than than Dolby Digital or PCM. But once I turn off and turn on my TV, the audio signal showing on the S2 app is Dolby Digital for all contents even though the audio quality remains the same as Dolby Digital Plus. It seems to me like a sync issue with the S2 app and as soon as I restart the Sonos device, it’s showing the exact one. Other than just unplugging, Is there any way to turn off the Sonos device once i turn off my TV. 

Userlevel 7

Not sure why it’s doing that. You might want to unplug the TV from power for a couple of minutes and see if that makes a difference.

There is no other way to power off the Beam completely other than unplugging it.

Thanks for the support. Will try that for sure. Also was wondering whether it has something to with CEC settings. Currently CEC is turned ON on my TV so that I can control Sonos with my TV remote.