Answered

Sonos Beam vs Apple TV 4k vs Samsung 2021 TV - glitchy sound

  • 16 November 2023
  • 4 replies
  • 189 views

Hi, I have an issue with my Sonos soundbar setup.

I have a 2021 Samsung AU8000 TV, Sonos Beam Gen 2 (Sonos HDMI cable) and Apple TV 4K 2022 (connected via HDMI 2.1 cable).

I have just upgraded from Apple TV 4K 2017 and I started having a strange sound issue with eARC, Pass-through and Dolby Atmos enabled. The sound is distorted - high pitched and out-of-sync.

If I disable any of the mentioned options, it goes back to normal. Also, this applies only to content from ATV, all internal Samsung apps sound fine.

I’ve upgraded my ATV HDMI cable (no change), updated Sonos to 15.10, re-adopted my Sonos System and tried myriad different options on the TV or ATV.

So in conclusion, the only change was upgrading Apple TV from 2017 to 2022 model and the issue appeared.

icon

Best answer by GuitarSuperstar 16 November 2023, 20:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the Beam, TV, and Apple TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Anynet+ is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect the Apple TV to the TV.

Try this:

Disconnect everything from the TV and unplug the Beam, TV, and Apple TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Anynet+ is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect the Apple TV to the TV.

Thanks, that seems to have worked.

Well, not entirely this, but after doing these steps, I had to cycle through the “Input Signal Plus” option on the TV and the sound was fixed.

After all, it still went back to glitching.

”Input signal plus” setting seems to trigger it one or the other way. Tried setting it on/off for all HDMI ports, but can’t get it working right.

Is there anything else I can try?

hey @GuitarSuperstar, I do not want to open another thread, but I still have the issue, do you have any suggestions on what else I could try?