Answered

Problem with sonos beam gen 2 and tv q70t samsung

  • 24 November 2022
  • 10 replies
  • 434 views

Badge

Hi, what's up? I have a TV Samsung q70t and a soundbar Sonos Beam Gen 2. I have a problem playing content Dolby atmos (Netflix, Amazon, HBO), the sound cuts out every 10 to 15 minutes, less than a second. Does anyone know how to fix this problem?

icon

Best answer by GuitarSuperstar 24 November 2022, 02:33

View original

10 replies

Userlevel 7

Set the Digital Output Audio setting on your TV to Passthrough instead of Auto. If this doesn’t work, try disabling eARC in the TV settings.

Badge

I just found it to disable earc from the TV, doesn't this lower the audio quality?

Userlevel 7

I just found it to disable earc from the TV, doesn't this lower the audio quality?

It shouldn’t lower the quality if you are just using the TV’s native streaming apps.

I'm having the same issue.  The suggestioned fix doesn't work for me.  I have tried all the suggested fixes to no avail.  It cuts out briefly every 30 minutes or so. Not horrible but still annoying.  It does it for all sources -PS5, Firestick and Rogers Ignite TV.

Any help would be appreciated.

I just realized there was an update to 15.10 around the same time this issue started so I'm thinking it has something to do with the update

Since it’s with Samsung TVs only, it’s a better bet that it wasn’t an issue with a Sonos update, but instead with a Samsung update to the way they handle CEC. 

Badge
It's been a while and they still haven't solved the problem.
Userlevel 7
It's been a while and they still haven't solved the problem.

Did you set the Digital Output Audio setting on your TV to Passthrough and disable the eARC setting?

Userlevel 7
Badge +17

Who’s “they”?

Badge

Who’s “they”?

Sonos support

Reply