DTS-HD 5.1 4K discs suddenly no sound

  • 26 February 2024
  • 20 replies


Hi everyone.

So my current set up is:


Sony UBP X-700 4K blu ray player

Sonos Arc + 2x Play 1’s and Sub.

I’ve had the above set-up for over 6 months now and have never had any issues playing any of my 4K discs. I’ve never had to fiddle with any settings on the TV or Blu Ray player, just pop them in and they will play fine.

However, in the past week all of my DTS-HD 5.1 discs have suddenly stopped playing any sound. My discs that are Atmos, DTS:X or DTS-HD 7.1 all still work perfectly - but every single 5.1 disc is silent. 
Checking the threads on here i can find various suggestions for different settings on the TV and BR player, but having spent hours going through trying different ones and while most didn’t work, i have now managed to get it working by changing the Digital Sound Output setting on the TV to PCM. After changing this, my Sonos app now shows ‘Stereo PCM’ instead of ‘DTS-HD 5.1’ as it has always done.

My questions are:

  1. Has anyone else (hopefully with the same setup as me) come across this sudden change in the past couple of weeks?
  2. Is PCM going to be a worse sound now on all of my 5.1 discs? (Which annoyingly include all Christopher Nolan titles)
  3. Does anyone know a work around to get my discs playing in 5.1 sound again (just like they always have done) without having to change to PCM before watching  certain 4K discs?

Apologies if there is a thread somewhere for this but I can’t seem to find any relating to my exact setup.

For additional info, watching 5.1 movies on Netflix, etc.. all show as 5.1 on my Sonos app still, so nothing has changed there. My instincts would tell me this has happened with a recent update to either the Sony BR Player or the Sonos Arc.

It’s all very frustrating so any help much appreciated 👍🏽

20 replies

Userlevel 7

There is no way the Sonos app reported “DTS-HD 5.1” when you played a DTS-encoded disc. The LG C2 doesn’t support DTS pass through and Sonos doesn’t support DTS-HD Master Audio.


Make sure the TV is set to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On


When playing a DTS-encoded disc, set the Blu-ray player to these settings:

Digital Audio Output: PCM

BD Secondary Audio: OFF

Audio DRC: OFF


These settings should result in “Multichannel PCM 5.1” or “Multichannel PCM 7.1” audio.


Apologies - Multichannel PCM 5.1 sounds correct. I was trying to remember from memory what it used to say.

Just tried those settings and disc still has no sound. Any other suggestions?


Cheers 👍🏽

Userlevel 7

Try unplugging the TV, Arc, and Sony player from power for a couple of minutes. And disconnect/reconnect the HDMI cable from the Sony player to the TV.


Just did all that - still nothing working on Pass Through.

The only one of the Digital Sound Output options that works is PCM - and that shows as ‘Stereo PCM’ on the Sonos app.

Userlevel 7

Try connecting the Blu-ray player to a different HDMI port.


Changed from HDMI 4 to 1. Sadly still no sound. 

What’s baffling me is why this has suddenly happened. Everything has been working fine since i first set up the Arc 🤔


Ok so a follow up to this, i now suspect this is due to an LG software update. Found a few other people online with the same issue that has suddenly started within the past two weeks. This would explain why none of your suggestions are working.

At a guess, i would say it’s the Pass Through function that has been affected, as if this worked, it should solve the problem. 

But for now i will have to just have to accept that i have around twenty 4K blu ray discs that i can only watch in Stereo PCM.

I have raised it with LG and will share any feedback i get from them on here.



So LG weren’t much help - just told me to check my Arc is setup correctly and i’ve run all updates, etc, etc…

I haven’t changed any settings on the tv, Arc or Sony BR player since watching Interstellar 4 weeks ago which worked absolutely perfectly, showing Multichannel PCM 5.1 on my Sonos app. Something has definitely changed in the past few weeks!

Not really finding much help online anywhere so i guess that’s that. I’ve paid a couple of grand to get an LG OLED with full Sonos surround…..to get stereo sound! Awesome!

Thanks for the help. Whilst I appreciate this is not looking like an issue with my Sonos devices, if anyone is suffering the same problem and can offer any assistance, it would be much appreciated if you could post 👍🏽


Sounds very similar to the issue myself and others are experiencing. Only difference is I have an LG C1.

my thread here: 

I’ve had no luck speaking to LG, they just said there last update was just minor fixes and didn’t cause this issue. But before a couple of months ago this passed through and I was getting 5.1 or 7.1 fine with no issue.

Userlevel 1

I’m having the same issue. Set up:

LG 65 G1

Panasonic 820 4k blu ray

Sonos Arc

ul to a few mo the back, DTS was showing as multichannel as expected. All Blu Ray DTS is now outputting Stereo PCM.

This does appear to be an LG issue, no current workarounds I have found. Happy to be corrected.





Definitely an LG issue and unfortunately not fixed in the recent update. I updated my LG C1 yesterday and the issue remains. 


So here’s the weird thing - I’ve noticed that when i press the Display button on my Sony X700, it shows that the disc IS playing 5.1 DTS-HD sound.

But then when i check the Sonos app, it is stating ‘Stereo PCM’.

I watched The Dark Knight the other night and the sound was quite frankly awesome. Definitely not stereo sound imo.

So i think this could be a problem with the Sonos app incorrectly reporting ‘Stereo PCM’ when it’s not.

Might be worth checking what your BR player is actually saying…



What was that showing on the Sonos app? I’ve played multiple 4K Blu rays and you can definitely tell the difference from previously when it was showing 5.1. When it’s shows stereo pcm on Sonos app the sound is a lot quieter and nothing of note coming through the surround speakers. When I try the same disc on my PS5 I can tell a noticeable difference and pcm 5.1 is showing. 



So after all this it turns out it was my Fire Cube causing the problem! Unplugged my Cube and the sound came back on all my DTS-HD 5.1 discs and is now showing Multichannel PCM 5.1 on the Sonos app.

Despite me putting the Cube to sleep, it turns out pressing play on my Sony Blu Ray player was switching the Cube back on too - which was causing the sound to stop. So weird and stupid!
Anyone having this same issue, try unplugging your Fire Cube (or stick) and see if this fixes it.

Hey King Bobby, 

I'm currently having a similar problem but I'm using a PS5 instead of a stand alone player. Movies I have watched before that are DTS no longer have sound once the movie starts playing. Playstation menu works fine, dvd menu has sound but as soon as the movie starts nothing. It has just started within the last couple weeks I would say. 

So for the past week I had been watching many blu ray discs that all had just a DTS-HD track on them. I intitially thought… ahh that won’t work as Sonos doesn’t support it. However I discovered it converts it to pcm 5.1. Which tbh all sounded great and all good.

Then suddenly today I’ve sat down to watch something and sound isn’t playing at all from discs. I even tried the ones I used yesterday as a comparison. They played yesterday. Now… silence.

i have lg c2, arc and era 300 rears. Sony x700 too.

i haven’t changed any settings… it’s just stopped playing the sound. So odd. 
I do have a fire stick. Tried unplugging it. Still no sound unless I do stereo 2.0. Which isn’t what I want. I want to go back to the pcm 5.1.

any tips would be great.


Sorry no… it was the fire stick. Not a clue why it is interfering and only just now.

anyway. Have the pcm 5.1 back and sounds great again 


Glad to hear 👍🏽

I’ve been scouring the internet for some sort of help on this, hoping to find how to set up the Fire Cube so it doesn’t do this, but not having much luck.

The setup option menus on the Cube are very limited and not much help. 

For now i’ll just have to keep unplugging the Cube whenever i’m sitting down to watch a movie.

All very annoying! 😤



Hey King Bobby, 

I'm currently having a similar problem but I'm using a PS5 instead of a stand alone player. Movies I have watched before that are DTS no longer have sound once the movie starts playing. Playstation menu works fine, dvd menu has sound but as soon as the movie starts nothing. It has just started within the last couple weeks I would say. 

I can’t help much here sorry, I’m an Xbox man and i don’t have it set up in the same room as my Sonos/Oled/Blu Ray Player.


Yeah it’s very strange how it just suddenly happened. My fire stick has always been plugged in and I watched a blu ray on Thursday with no issues. Then last night suddenly it does not work. Unplugged fire stick and it does. So odd