Beam(2) with Samsung UE75 and HDMI / output switches from speaker to HDMI and back


Beam (Gen2) ist connect to Samsung TV UE75 HDMI Arc Port (HDMI2).

Beam works nicely as streaming device for music.

Here’s the issue: on the TV setup, the audio output device switches every few seconds from HDMI (Beam) to the internal TV speakers, back to HDMI, back to internal…

For the few seconds, when the output device is HDMI, Beam works and sounds great.

Any ideas?

TV and Beam are on the latest software releases. Both have been rebootet. The HDMI cable in use is the one which came with the Beam system.

Thanks a lot in advance and best regards!



Best answer by Ken_Griffiths 19 June 2022, 13:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

When you switch TV-input to the HDMI ARC port, do you see the Sonos screensaver? I think some Samsung TV models ‘may’ have an issue with the Sonos screensaver and in some instances I’ve seen it mentioned that some users have contacted Sonos Support to see if it needed to be switched off, but if you don’t see it anyway, then just try powering everything off (not standby) for about three minutes and powering all back on again and see if that resolves the issue.

Otherwise you should be able to contact Support Staff via this LINK and see what they may say about your particular TV model.

Another possibility, is that CEC control maybe enabled on some other TV connected device, like Apple TV for example …and that might be trying to steal focus away from the Beam - so maybe see if switching off CEC on anything else that’s connected, might resolve the issue.

Ken, thanks a lot for your quick reply - and for the solution to the issue!

I didn‘t have the screensaver situation and powering off everything didn‘t help either - BUT

the HDMI connect Denon Amp caused the problem.

After disconnecting the Amp (which no longer is needed with the soundbar in place) everything works and sounds great!

thanks again for your help and the quick solution!

have a great Sunday!