Answered

Using Samsung Smart-Touch Remote with Playbar

  • 1 February 2016
  • 41 replies
  • 38159 views

I have a curved Smart-Touch remote for my Samsung TV and have gone through the Sonos setup process, but the Playbar does not recognize the volume button signals (I'm assuming this is due to RF signals??). The strange part is that when the TV is set to TV/arial source (not HDMI) the playbar volume works!? When I switch to my other sources the volume does not work.
If I configure the Playbar to work with the IR remote, everything works, but I'd much rather use the Smart-Touch remote.
Any clues as to how to best fix this? (I did not get a IR repeater with my TV, although it has the external connector for HDMI etc)

I have the Playbar connected via the optical port.

All help appreciated!
icon

Best answer by JWNten 27 July 2016, 02:59

All, after spending quite some time on this, I found how to implement buzz's workaround in a satisfactory way (without losing any other controls). Hope this can help some people out. This applies to recent samsung TV's with smart remotes:
- go to settings, remote setup (on my TV, this means clicking the home button, going left then up until I'm on the remote icon, then pressing the center ok button)
- add a device, an AV receiver, select Bose
- for source, select optical
- once the device is created, if you're using a set-top box like I am, you can actually (in the remote setup menu) click the bose device, and combine it with the set-top box (so that the TV thinks both devices are in a serial connection). That way, it will allow you to control the set-top box as before, but will assign volume controls to Bose compatible IR.
- once this is all done, play the TV from the combined set-top box / bose source
- now in the Sonos app chose to change the remote and follow instructions. If it works you should see a white led in front of the Playbar everytime you change the sound up or down. Mute should work as well.

Worked for me, I now have full control!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

This has worked for every source except the Fire TV, which I can't get the Samsung TV to find as a source to add as Fire TV/Sonos. Any suggestions?
This worked perfectly fust type in sono for device during remote setup
I have a samsung KS8000 and had problems with connecting my sonos play bar. I don't have a cable box and get my tv instead from over the air broadcasts. At first I couldn't pair the remote with the sonos playbar, but eventually figured it out. Here's what I did.

- Go to the universal remote feature in the samsung home menu
- Add a device
- Search for a brand (since Sonos is not on the list)
- Type in Sonos and press enter
- Agree to the prompts as they come up, even though it doesn't seem like the remote is turning the playbar off/on
- Enjoy using your samsung smart remote now to control your playbar!
All, after spending quite some time on this, I found how to implement buzz's workaround in a satisfactory way (without losing any other controls). Hope this can help some people out. This applies to recent samsung TV's with smart remotes:
- go to settings, remote setup (on my TV, this means clicking the home button, going left then up until I'm on the remote icon, then pressing the center ok button)
- add a device, an AV receiver, select Bose
- for source, select optical
- once the device is created, if you're using a set-top box like I am, you can actually (in the remote setup menu) click the bose device, and combine it with the set-top box (so that the TV thinks both devices are in a serial connection). That way, it will allow you to control the set-top box as before, but will assign volume controls to Bose compatible IR.
- once this is all done, play the TV from the combined set-top box / bose source
- now in the Sonos app chose to change the remote and follow instructions. If it works you should see a white led in front of the Playbar everytime you change the sound up or down. Mute should work as well.

Worked for me, I now have full control!


Whew hoo! Thanks! Morr importantly, my wife is not pissed that we can’t use the TV remote after adding on the Sonos!
While the Bose method didn't work, this worked perfectly for my Sonos Playbar and Samsung 2016 KS7000

I have a samsung KS8000 and had problems with connecting my sonos play bar. I don't have a cable box and get my tv instead from over the air broadcasts. At first I couldn't pair the remote with the sonos playbar, but eventually figured it out. Here's what I did.

- Go to the universal remote feature in the samsung home menu
- Add a device
- Search for a brand (since Sonos is not on the list)
- Type in Sonos and press enter
- Agree to the prompts as they come up, even though it doesn't seem like the remote is turning the playbar off/on
- Enjoy using your samsung smart remote now to control your playbar!
You could go a bit cheaper than a new TV and invest in a third party remote, like Logitech's Harmony remotes, which you could program to handle all the different devices. I've got two in my house, and they work wonderfully well, across multiple manufacturer's products.
Yep I had a Sony Bravia 52" 800 series TV hooked up to the Sonos Playbar with Sony Blueray player, Apple TV 4, Fire TV 4K. Everything worked perfect the Sony TV remote, Sony Blueray Remote and Apple TV remote would control volume no matter what the input was. I bought a new Samsung 4K TV with the smart remote and everything has gone to crap with regards to volume control. After reading the Sonos help community forums multiple times I've tricked the TV into thinking there are several home theatre systems and Blueray players hooked up to the TV and sometimes the smart remote does control the volume but sometimes it just doesn't and I have to pull up the Sonos app. Ive literally tried 20+ different options to get this to work and it just plain sucks. May just ditch the new Samsung TV and go get a Sony 4K TV.
Thanks NP crowe. Tech guys from SONOS could not even offer me the above!

Cheating the system as mentioned worked!
I have a samsung KS8000 and had problems with connecting my sonos play bar. I don't have a cable box and get my tv instead from over the air broadcasts. At first I couldn't pair the remote with the sonos playbar, but eventually figured it out. Here's what I did.

- Go to the universal remote feature in the samsung home menu
- Add a device
- Search for a brand (since Sonos is not on the list)
- Type in Sonos and press enter
- Agree to the prompts as they come up, even though it doesn't seem like the remote is turning the playbar off/on
- Enjoy using your samsung smart remote now to control your playbar!
All, after spending quite some time on this, I found how to implement buzz's workaround in a satisfactory way (without losing any other controls). Hope this can help some people out. This applies to recent samsung TV's with smart remotes:
- go to settings, remote setup (on my TV, this means clicking the home button, going left then up until I'm on the remote icon, then pressing the center ok button)
- add a device, an AV receiver, select Bose
- for source, select optical
- once the device is created, if you're using a set-top box like I am, you can actually (in the remote setup menu) click the bose device, and combine it with the set-top box (so that the TV thinks both devices are in a serial connection). That way, it will allow you to control the set-top box as before, but will assign volume controls to Bose compatible IR.
- once this is all done, play the TV from the combined set-top box / bose source
- now in the Sonos app chose to change the remote and follow instructions. If it works you should see a white led in front of the Playbar everytime you change the sound up or down. Mute should work as well.

Worked for me, I now have full control!


Thank you very much. Worked with a Samsung UE55KS7000

Peter

Hi Peter,
I'm using the same TV model as you have have installed the CI+ module digital Full HD TV. After reading all posts many times & trying to get it fixed, no success until now.
The only device connected to my TV is the Sonos Playbar via the optic port.

I was able to define the Bose device by adding a home -cinema set via Optic port. It's not clear for me how I can manage the volume control on the Sonos Playbar when I select TV as input. Still I need to make use of the second IR remote controller to change the volume. So what are the exact steps after defining the Bose device, hopefully you can help me. I'm doing something wrong but can't find the reason. You can also reply in Dutch.
Dear All,

Im very happy that FINALLY i figured out how to get it all up and running and everything from normal coax tv channels, chrome cast, hdhi cable tv box and PC input working with remote!

TV/Coax: Setup universal remote

1 NEW DEVICE / HOME THEATRE / SEARCH FOR SONOS / CHOOSE OPTICAL AS TV PORT CONNECTED

CHROMECAST
1 UNIVERSAL REMOTE / NEW DEVICE / BLUE RAY PLAYER / HOW CONNECTED: TV / BRAND: BOSE / SELECT PORT: CHOOSE PORT/HDMI / OK FOR SOUND/POWER OFF / DONE
2 UNIVERSAL REMOTE / CHOOSE NEWLY SETUP "BOSE" OPTION / USE WITH HOME CINEMA / BOSE
Thanks this worked well but I have one problem!

when combining the bose and vigin media input I lost the recordings tab that used to be above the red virgin graphic, this has upset my telly addict wife and think I am going to have to unpair and hope it returns! any ideas would be much appreciated.
What about netflix app and nvidia shield BR player . how do i add the sonos playbar and sub and the 2 play 1
All, after spending quite some time on this, I found how to implement buzz's workaround in a satisfactory way (without losing any other controls). Hope this can help some people out. This applies to recent samsung TV's with smart remotes:
- go to settings, remote setup (on my TV, this means clicking the home button, going left then up until I'm on the remote icon, then pressing the center ok button)
- add a device, an AV receiver, select Bose
- for source, select optical
- once the device is created, if you're using a set-top box like I am, you can actually (in the remote setup menu) click the bose device, and combine it with the set-top box (so that the TV thinks both devices are in a serial connection). That way, it will allow you to control the set-top box as before, but will assign volume controls to Bose compatible IR.
- once this is all done, play the TV from the combined set-top box / bose source
- now in the Sonos app chose to change the remote and follow instructions. If it works you should see a white led in front of the Playbar everytime you change the sound up or down. Mute should work as well.

Worked for me, I now have full control!


Thank you very much. Worked with a Samsung UE55KS7000

Peter
Badge
I have a curved Smart-Touch remote for my Samsung TV and have gone through the Sonos setup process, but the Playbar does not recognize the volume button signals (I'm assuming this is due to RF signals??). The strange part is that when the TV is set to TV/arial source (not HDMI) the playbar volume works!? When I switch to my other sources the volume does not work.
If I configure the Playbar to work with the IR remote, everything works, but I'd much rather use the Smart-Touch remote.
Any clues as to how to best fix this? (I did not get a IR repeater with my TV, although it has the external connector for HDMI etc)

I have the Playbar connected via the optical port.

Thanks for this. Completely sorted me out was losing me mind!! So easy

All help appreciated!
thanks i will try that.
We both got it working with only playbar - you need to set up the home theater (playbar) on Samsung tv, the add each input you have named as one of the random brands Samsung TV lists, then select each input to work with home theater, then use Sonos app to learn it all over.
the smart remote for Samsung ks range works via bluetooth, only on/off works in IR.
I'm having same problem as you guys.
my sky remote and standard Samsung remote both work play bar together but i do prefer the smart remote.
very frustrating.....
This is true it does sound really great
Eloquently put! That's what I did and have it working.
I agree for what the sound bar costs and the TV, I probably should have just gone for a normal 5.1 setup, but I'll make the most out of it and ensure it sounds fantastic. Just thankfully I didn't get 2 play 1s for a 5.1 setup
Got the Samsung remote controlling playbar volume on all inputs (tv apps, Samsung blu ray, tv antenna, chromecast). Set up the playbar as home audio first, then set up each device as a different random brand then selected "use with home theater" to 'connect' them with the playbar.

My long instructions above are correct just you have to go thru and set up all the inputs per instructions, connect them to 'home audio' once set up, THEN do the sonos app part once they're all set up and connnected

Samsung support and sonos support both confirmed there is no way to remove the volume change icon that appears every time you adjust external speaker volume on any input with current software (Samsung's fault).

I probly wouldn't have spent so much on playbar if I had know how time consuming/ridiculous this would be.
Thanks 007M - didnt get time to try it tonight but i'll follow up in this with results - appreciate the help
Here's what I did, Under the universal remote delete everything you have and start afresh. Create a 'bose' home theatre. Then createe the different inputs you have and attach the Bose to those inputs.
I know it's gotta be frustrating. But I got it working, I'll be home in 2 hours and check how I have it set up, because I can control smart Tv apps as well as my other 2 inputs
Also it seems there is no way to control playbar volume with the TV remote when using a smart TV built in app once you set up control of volume for any other input...