Answered

Sonos beam lip sync issue


Setup the new beam today, no problem getting it working. Problem is with lip sync - I have a Samsung UHD 8000 series with Sky (in the UK). Beam is connected via ARC. Tried adjusting delay via the app and TV and can’t get it to sync, so really frustrating. Any ideas? Didn’t have this problem with the Playbar (connected via optical). Thanks Toby
icon

Best answer by Ryan S 18 July 2018, 20:34

I'd like to suggest again that you take the time to give us a call so we can look into this closer.



In the meantime, would you mind submitting a diagnostic from your Sonos system and replying back with your confirmation number while you're getting these sync issues? I'll send them up to the team to look into just in case something is being flagged there. We've seen similar issues with certain TVs not handling Dolby Digital audio quickly enough and sending it slightly delayed. If this is the case, setting to Stereo or PCM would resolve the issue, as would using an HDMI switch instead of the TV. However, this would make the CEC commands not work from Beam.



Please note what TV model you're using here, and also, how the Beam is connected to it.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

71 replies

I hope this is helpful (see bold below), because the solution to my issue of the audio being behind the video is counter-intuitive:

I was having 2 issues using my new Beam (Vizio P65-F1, XboxOne S, AppleTV 4K, Shield TV, DirecTV Genie Mini):
1) Beam does not show up in CEC list when other devices are connected (this is still a problem, so I went with the Optical adapter.
2) DirecTV audio was trailing the video via HDMI (when it worked), and via Optical, so I bypassed my TV and went straight from the DirecTV Genie Mini to the Beam, and everything was in sync. So, messing with different settings, I realized "Game Low Latency" was turned on. I turned it off, and the sync problems were gone. See why I say counter-intuitive?

Anyway, I hope this helps others... now if I could get the CEC to function properly... I think it is the Vizio and not the Beam, though. All other devices have CEC disabled, and on the Vizio, I have CEC set to ARC Only.
Userlevel 7
Badge +26
We'd love to look into this with you. One thing to check is that in the settings for the TV that you have Dolby Digitial selected as the audio format to go to the Beam. HDMI will usually automate that, but it's a good check to make sure you set. Also, try setting the audio source to Stereo instead and see if the lip sync improves.

We've found that some TVs have trouble processing and sending that signal on time, which can cause this, but we haven't seen the same issue so far with the Beam. We'd love to get some more details on what TV you're working with and how everything is connected. I'd suggest that you give us a call on our support line and a technician will assist with getting all the details we need to investigate and help you find a solution as well if possible.
Today I have bought a Samsung QE55Q70RATXXU and a Beam, connected to the tv is a Sky Q 2TB, Xbox One X PS4 Pro and a Apple TV 4K, I connected the beam via optical as all 4 HDMI ports are in use and in all honestly I don’t want Alexa and we have a Echo in the kitchen and the proximity of both would probably cause chaos anyway, the Xbox PS4 Apple TV physical box and all the TVs apps such as Netflix Amazon the Apple TV app Youtube BBC etc all work perfectly with absolutely no adjustment needed however Sky Q just will not sync, I have tried adjusting the delay through the Sonos app Sky Q and the TVs internal settings, the Sonos and Sky Q settings just make it frankly worse the closest I can get to it working is through the TV delay as it goes up in 10ms instead of 20ms but this then knocks everything else out of sync, I have spend three hours trying to sort this and it’s getting frustrating, I have no clue of this is a Samsung or a Sky issue.
Same issues here, but turning off dolby digital in my hdpvr solves it as far as I can see.
Badge
I have a Philips 4K TV on latest Android (8 I think) and had the same issues. Mine has a setting (options -> all options -> sound) which is called “digital audio delay” and it’s set to “on” by default. After setting it to “off” everything is in sync again, no matter what compression is used.
Thanks,
I've been trying a few options and may have come up with the solution.
My Sony XBR900E has a Sound Option called Clear Audio+ which is ON by default. I set it to OFF
On the Apple 4k TV I switched the Surround Sound setting from Best Available to Dolby Digital 5.1
These changes seem to have worked.
Although this says answered, it is not resolved for most users. I have an LG OLED55C8PUA 55-Inch 4K. It works with other sound bars. Both ARC and the optical have delay. I have ensure that I am using dolby. Hopefully a fix to speed the audio output can be made.
Although this says answered, it is not resolved for most users. I have an LG OLED55C8PUA 55-Inch 4K. It works with other sound bars. Both ARC and the optical have delay. I have ensure that I am using dolby. Hopefully a fix to speed the audio output can be made.

Agreed - my problem has not been solved either. The most frustrating thing is that I replaced a standard Samsung soundbar with the Beam, at 4x the price and I now have a system with superb sound but it's unwatchable because it's out of sync!
Fascinating. That must mean that there's some sort of delay on processing the picture. Or maybe there's a time machine built into the TV 🙂 Delighted it works for you!
Similar to other people I am getting significant lip sync issues. In my case the sync drifts in and out. I have the Sonos Beam, Sub and two Play 1’s at the rear, tv is a Panasonic FZ802b OLED connected to the Beam using ARC, Sky Q 2TB is the source. Previous Samsung sound bar had no issues with lip sync. The fact that the lip sync drifts in and out makes it impossible to resolve. Have tried the delay settings on both the Sky Q box and in the Sonos app but no combination cures the issue. Deeply frustrating after spending this amount of cash on a premium system.The Sonos Beam can only play the audio stream when it has been processed by the TV and passed out through the HDMI-ARC or Optical Port .. some TV's seem to do better via the Optical port and others are faster via the HDMI port... so perhaps try the Optical port in your case.

It’s sometime also helpful to turn off extra audio features on the TV like extra Bass Boost Settings or wide surround sound etc. So if you have such things, then turn off those enhancements. Ultimately most brands/models of TV have no lip sync issues with the Beam and it really is often down to the TV manufacturer to process and output the audio out its connected port in good time.

Check online for any TV firmware/software updates too, as often the latest update may fix such issues.

Hope thes few suggestions help you to resolve your lip-sync issues. I really do appreciate how frustrating these things can be.?
Userlevel 3
Badge
I'd also be interested in a list of which TVs are not affected, but there is such a rapid turnover of models that any list is almost immediately obsolete. I often find that even TVs which receive 5-star reviews are immediately discontinued - why?

Anyway, because of lip sync issues I returned my Samsung UE40NU7120, and bought an LG 49SK8500PLA. It is plagued by the exact same issues. I have contacted LG support but based on feedback elsewhere on this forum, I don't expect any useful help and I expect to be returning this and trying yet another TV manufacturer. Maybe Sony?

Using a lip-sync test video on YouTube and running the TV's internal speakers and the SONOS in parallel, I did some testing by recording the output and analysing it. Interestingly I found that, when I connected the SONOS directly to my Freesat box, the sound was coming out of the SONOS about 50 milliseconds before it came out of the TV's internal speakers. In other words, the TV even delays output to its own speakers. When I connect the SONOS to the TV (via optical), the sound is coming out of the SONOS about 60 milliseconds after is comes out of the TV's speakers. So the TV is delaying the audio output to the optical audio port by ~110ms, which is well above acceptable tolerances.

https://www.prosoundtraining.com/site/wp-content/uploads/2014/02/Lip-Sync-Errors.pdf
In all honesty, I'd be bugging the manufacturer of the TV. That's where the delay is caused. This is why those who use HDMI switches with optical outputs don't have the issue. You could potentially look into an HDMI switch that can handle an ARC signal from the TV.

It's not really a Sonos issue, they can only play audio as quickly as it is passed to them.
Thanks again for the answer, I appreciate your suggestions.

However, I disagree.

I've already clearly stated that I could purchase a new TV to make it work - given that I know which TVs actually would work without audio delay issues with the beam. Since TVs manufactured ranging from 2016 to 2019 from most of the popular brands have audio delays issues with the beam, it would be very helpful and valuable for Sonos customers to understand which TVs are known to work well with Sonos products.

I believe Sonos are more likely to both have the relevant data and incentive to provide that list rather than all the TV manufacturers. Do you really think me simply asking for a list of TV devices that are known to work well with Sonos products me bugging Sonos?

Again, buying a TV switch will not solve the problem for the internal TV apps and I would much rather buy a new TV than spend another $200+ for a new TV box and another $100+ for a really good switch that can handle ARC.
My suggestion of an HDMI switch which supports HDMI-ARC would indeed support the internal TV apps, by sending the audio from the TV back along the HDMI-ARC connection to the switch, which would then send it out the optical connection to the Beam.

However, it's merely a suggestion. You can choose to do whatever you want.
Would that setting mean that all functionality of CEC was turned off except ARC? Have you tried flipping that setting the other way?
@Airgetlam, it means CEC only on the ARC enabled input (HDMI-1). I've tried both ARC Only as well as Enabled, with the same results.
I am having the exact same problem. Audio is lagging behind the picture, and I can’t get it to sync at all. I have an LG oled 55 b7. Very disappointed as it seems as though this has been an issue with Sonos and Sky Q for quite a while. Wish I’d have known before spending £400!!
Interesting. That's certainly counter to the way I would understand that. Which model do you have, I'd love to look at the manual?
Badge
I'm having similar lip sync issues with my Beam and certain streaming channels from an Apple 4K TV.
Userlevel 7
Badge +26
I'm having similar lip sync issues with my Beam and certain streaming channels from an Apple 4K TV.
Is that while passing through a TV or are you sending the audio straight to the Beam using AirPlay 2?
Badge
I'm having similar lip sync issues with my Beam and certain streaming channels from an Apple 4K TV.
Is that while passing through a TV or are you sending the audio straight to the Beam using AirPlay 2?

Sending through the TV.
Ok so I changed format from bitstream to PCM and it’s a bit better. Would that make sense?
Userlevel 7
Badge +26
I'd like to suggest again that you take the time to give us a call so we can look into this closer.

In the meantime, would you mind submitting a diagnostic from your Sonos system and replying back with your confirmation number while you're getting these sync issues? I'll send them up to the team to look into just in case something is being flagged there. We've seen similar issues with certain TVs not handling Dolby Digital audio quickly enough and sending it slightly delayed. If this is the case, setting to Stereo or PCM would resolve the issue, as would using an HDMI switch instead of the TV. However, this would make the CEC commands not work from Beam.

Please note what TV model you're using here, and also, how the Beam is connected to it.
Badge
I'd like to suggest again that you take the time to give us a call so we can look into this closer.

In the meantime, would you mind submitting a diagnostic from your Sonos system and replying back with your confirmation number while you're getting these sync issues? I'll send them up to the team to look into just in case something is being flagged there. We've seen similar issues with certain TVs not handling Dolby Digital audio quickly enough and sending it slightly delayed. If this is the case, setting to Stereo or PCM would resolve the issue, as would using an HDMI switch instead of the TV. However, this would make the CEC commands not work from Beam.

Please note what TV model you're using here, and also, how the Beam is connected to it.


Thanks for your reply, Ryan.

My setup is a Sony X900e and an Apple 4K TV.
--On the TV, I turned off Clear Audio under Sound Settings
--On the Apple TV, I changed the Surround Setting to Stereo

So far this seems to be working; however, I'm not sure how these changes affect the sound quality.
Right the issue is fixed completely if I set sky q box to pcm or normal and not Dolby digital, using hdmi arc. Sonos customer service told me that there is no difference in the quality of the sound from DD and PCM, can anyone confirm if this is true. If PCM is worse quality than DD then I will be returning my Beam as £400 for inferior sound is a joke. Hopefully someone can put my mind at rest as I really love the beam!!!
Userlevel 4
Badge +6
Right the issue is fixed completely if I set sky q box to pcm or normal and not Dolby digital, using hdmi arc. Sonos customer service told me that there is no difference in the quality of the sound from DD and PCM, can anyone confirm if this is true. If PCM is worse quality than DD then I will be returning my Beam as £400 for inferior sound is a joke. Hopefully someone can put my mind at rest as I really love the beam!!! What a joke. PCM on Sonos is stereo. Dolby Digital is surround sound. Dolby Digital is far superior to PCM Stereo.