Yet more problems with this train wreck of GA on Sonos

Userlevel 5
Badge +8

Still trying to get my GA routines working again on my Sonos Ones, but I’m just encountering one error after another that makes it difficult to even pinpoint the specific problems. That’s very frustrating!


First of all the GA routines invoked on my Sonos speakers are now failing about 30% of the time in the last few weeks. It tends to come and go in bursts - if there’s one failure, there are lots more for a while, then things settle down. (Just to be clear, there are no failures on my Google Home speakers, no failures on the Echo Dot located right next to the Sonos speakers, and no failures if I switch to Alexa as the voice assistant on Sonos).


Whenever there is a failure, GA on Sonos locks up for more than a minute with the “active” LED on, then says something went wrong. Sometimes it’s worse - for example if I ask it to play my news briefing, the response is sometimes delayed for several minutes, during which time the active LED is not on, and GA on Sonos will not respond to any command. While GA is unresponsive, the manual controls still work, and the Sonos app can still control the speaker, and the Echo Dot can still play to the Sonos speaker (but volume is reduced because GA is still sort-of-active).


When there is a failure during a Google routine, the routine simply stops at that point, but GA does not respond for more than a minute, and then to say that there was an error. Google’s Activity record is erratic, sometimes showing that some of the routine steps were executed, but no indication of which one failed.


As best I can conclude from all this:


  1. Google Assistant on Sonos has some serious problems passing commands to Google and and coordinating back and forth.
  2. The problems between Sonos and Google are erratic over time, sometimes better, sometimes worse.
  3. GA on Sonos has a design flaw in waiting too long to report errors. Real Google Home speakers report command failures in a few seconds, while GA on Sonos can lock up and become unresponsive for minutes when an error is encountered.

I’ve given up on expecting Sonos to fix anything, but I hope this is helpful to other GA users on Sonos in recognizing the problem they are having.


Best answer by Doug Ames 8 January 2020, 16:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 5
Badge +8

I think there’s a specific problem to be discovered here that suddenly causes Google Assistant to have a high failure rate on commands. So far diagnostics don’t seem to be able to discover what the problem is. I think Sonos should either do some work to discover the problem, or at least improve their diagnostic tools so that users can discover the problem.

Once again, the involvement of routines is a red herring. Routines are more likely to demonstrate the problem because they involve several commands in a row, but when commands are running reliably then so do routines. When I start to see this problem, simple command like “set volume” or even “what time is it” are equally likely to trigger a faulty response as anything else.

Sonos has not described the process of how commands are passed to Google and executed, or what the lights on the speaker mean. We are only inferring that a flashing light means it is doing something, and a solid bright white light means it is waiting for something. When it fails to execute a single command and reports a glitch, usually that command does not show up in the Google Assistant activity log. Did Google get it or not? We don’t know the process. All we can say is that the local Sonos speaker got the command and did something, then it appears to enter a wait state for one full minute, then it reports a glitch, and Google has no record of it. The behavior is different if it didn’t understand a command, and indeed we know it isn’t misunderstanding fixed commands within a routine that started successfully, so this is a problem of execution, not understanding.

And aside from everything else, the wait period of one minute is way too long. When a Google Home speaker has a failure to execute a command, possibly due to a smart home device or service being down, it comes back with a “glitch” response within 10 seconds.

I know routines and a few other things are not officially supported on Sonos (yet) and the GA ‘enabled’ Sonos device is mainly geared for just music playback and control. In that regard, I have no playback or music control issues here with my Sonos devices.

I use the Nest Hub and Home Mini’s aswell as many other smarthome devices. I also use Amazon Alexa devices and as far as Sonos is concerned it does “what it says on the tin” for playing audio around our home. 

I do currently prefer the Alexa integration with Sonos, because that VA supports grouping and group audio control, but there again Amazon came onboard Sonos a while before Google, so I guess there is some catching up to do.

As it stands at the moment though GA on Sonos seems to work okay here for what we want it to do.

Note there is a difference between a full blown Google Device and  a Google “enabled” Device as I assume Google are not giving away all the features that their own devices will do otherwise that would be detrimental to their product sales and similarly Sonos probably look to protect their own market-interests too.

I am exactly the same problem, failure rates of 10% in the past for GA, now more like 80% failure rate for power commands. I have severe urges to throw the speakers out of the window or disabling the GA and putting Google Home minis on top of them, a product that actually works. 

Userlevel 5
Badge +8

It’s b-a-c-k! A couple of weeks of reliable operation, and now the problem has started again. Constant command failures (one minute pause, then “something went wrong” or “there was a glitch”), Routines run a few steps, then fail erratically at different points with the same kind of error. Once again, nothing seems to fix it - rebooting Sonos, rebooting router, changing Sonos LAN IP address, switching to ethernet = no effect on the problem. I’m not about to do a whole house power-down again to try to fix this (if that was even what fixed it before), so I’m back to complaining that GA on Sonos is a train wreck. :rage:

Userlevel 7
Badge +20

Hi, Doug. I’m happy to hear that this is resolved, at least for the time being. Sometimes a good old fashioned full reboot is just the ticket. If you do find that the problem reemerges, please don’t hesitate to let us know. 

Userlevel 5
Badge +8

Well, this is intereesting…

We had a 10-minute power failure yesterday, causing everything on the network to go down and then power up again in random sequence, and it cured the problem. After weeks of very unreliable response and long freezes, Google Assistant on Sonos is suddenly restored to normal function.

During testing over the last week the Sonos speakers and the router were powered off and on again many times, and Sonos looked at diagnostics I sent, but no cause or solution were found. My best guess is that it’s something to do with the startup sequence of the equipment, either the Sonos speakers, or possibly even including the Google Home speakers as well.

Userlevel 5
Badge +8

I already did all of that - removing, re-installing, setting up voice assistant again, trying with Alexa again etc.


But I did make some more progress in testing today. I already established that the problem is that commands to GA are suddenly failing at about a 30% rate just in the past few weeks, and Google routines are worse only because they involve several commands in a row that talk to Sonos (setting volume, saying something etc), and therefore have a much higher chance of failure. The problem is made worse by the way GA on Sonos locks up and goes unresponsive for a full minute before it reports a failure. And if the failure involved playing media (like my 2-minute news briefing), it actually locks up and becomes unresponsive for the entire duration of the media stream as well. Apparently Google still thinks it’s playing the stream, even though the Sonos speaker is silent. When GA on the Sonos speaker is unresponsive, the app still works and controls the speaker without problems, but it can’t affect the volume reduction placed in effect by GA until GA unfreezes.


I tried putting the speaker on ethernet. No effect, same failure rate, so definitely not a WiFi issue. Then I tried switching to a different router (Cisco instead of Netgear). That did help - GA commands suddenly became reliable again, it a bit slower to respond for some reason. Routines run just fine again. Unfortunately that’s not a solution because I’m not going to swap my premium Netgear router for an old one just because of Sonos.


It’s looking like Sonos no longer likes my Netgear router because of something that changed in the last couple of weeks. I haven’t updated my Netgear router firmware. Did Sonos change something with a firmware update that sideswiped Netgear routers? Only when using Google Assistant? That’s weird.

I think it’s a case some things work by default as part of the integration/collaboration but are not currently officially supported. It’s the same with the Amazon Alexa routines, they are not officially supported and neither are the intercom/calling features etc.

On the other-hand the music playback/control features should be working okay. I’m not seeing any issues in those areas personally speaking so, if you are having trouble in that area you may perhaps be best speaking to customer support about it.

One thing that is worth exploring is to remove the Sonos device/skill from the assistant App and wait for all Sonos devices to be removed from the home and set them up again and place them back in their required rooms.

Then re-add the voice assistant back to your speakers.

That process usually fixes most things. I have over 20 devices here and mine are working just fine at the moment for music playback and control. 

Userlevel 5
Badge +8

That is incorrect. Google routines have worked on my Sonos speakers since GA support was first released, but have gone through a few periods of unreliability, most recently and worst in the past few weeks. It is not the Google routines themselves that are failing now - the problem is that ALL commands to Google Assistant on Sonos are failing regularly, including simple music commands. Since my routines have several commands in a row, they are almost always failing to complete successfully. Two weeks ago they were working reliably.

If Sonos wanted to state that only a limited subset of GA functionality is available on their speakers (that is, even more limited than the short list of currently known limitations), they should say so officially.

We don’t need more excuses here, we need Sonos to start taking their GA support seriously if they are going to offer it.

Google Assustant on Sonos is mainly aimed at music playback and those things associated. Google 'routines' are not currently supported, as explained here:

if you select ‘routines’ in the GH App and choose the edit option at top of the dialog box, you will see that ‘routines' only play on google devices. Sonos devices do not even appear in the device list.

The Sonos products are not full blown Google assistant devices they are ‘Google Assistant Enabled devices, so you won’t find them having the full features, although I understand that Google & Sonos have somewhat hinted that some additional features may get supported at some point in the future, but what that means exactly, remains to be seen.