Question

How to remove old Speaker from Account and Google Assistant

  • 3 December 2019
  • 6 replies
  • 448 views

Hello,

 

Have some old speakers on my account still, as a result they come up in Google Assistant when linking my account. Any ideas how to remove them (other than the answer I have been able to see online which is they have to be registered with another account). 

Or anyone have any ideas how to remove them at least from Google Assistant as a device (they get pulled from the Integration with Sonos, which I assume if from my Sonos account online).


6 replies

What I ended up doing was creating a new "home" in Google home called a" unused" and moved the device to that location. Now it's just my smart device graveyard. Similar, actually, to what I ended up doing for devices I temporarily don't need (for some holiday smart plugs I have an "unused" room, but that didn't cut it for the Sonos device to not be found).

+1 from me. It would be nice to be able to (automatically, or manually)  remove, archive, or hide, devices held in a users online account profile after say a period three months of continuous connection-inactivity, as some devices are not always sold on, but maybe recycled, or faulty/discarded etc.

I have an old Sonos Dock for example still showing in my profile that has long-since bitten the dust and was recycled when it was obsoleted. No chance that will ever be registered again. 

A factory reset and re-registration of a Product could perhaps restore a device to a users account, in any event, so that all is then still not lost, even after the three month period has passed.

I also have the same problem, old Play:5 still showing up in Google Home. Seemingly no way to remove it.

Also having the same issue; surprised there's no way to remove the device and meanwhile voice commands don't work in the room with the old device ghosted in there...

I’m in the exact same situation. I’ve moved the old ones to a room name I don’t use so there’s less confusion. 

I have the same issue.  I updated my amps but still see the old ones in Google Home.

Reply