Answered

Google Assistant wont play Spotify music.

  • 30 September 2020
  • 12 replies
  • 2673 views

Verbally asking Google on my sonos arc to play music results in this response: "Sorry, it looks like you haven't set up Spotify Premium on your Sonos app. To play from Spotify Premium, link the same account on both Sonos and Google Assistant."

I've tried looking at other posts but I haven't seen any working solutions. I've done exactly as Google said as well as reinstalling apps and reconnecting Spotify to Google assistant and to Sonos. But I still get the same message every time.

icon

Best answer by Mattmill27 30 April 2022, 18:03

View original

12 replies

Userlevel 6
Badge +16

hi @Choppy, Thank you for reaching out and welcome to the community. Sorry to hear about the issue that you've with the Spotify and google Assistant on Sonos. Regarding this issue. I’ll ask some questions to further check.

  • When did the issue start?
  • Are there any changes made with the settings on Spotify, Google Assistant, or on the Sonos App before the issue occurred?
  • Have you tried to do the removing and readding of your Spotify account on another or a different controller device where you have the Sonos App?
  • is it only happening on Spotify? how about other Music services?

I’ll ask you to submit a diagnostic report to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue.  

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

I have exactly the same issue. No problem when using a Sonos One. Only when a I use a Google home mini with a Sonos Play:1 as it’s default speaker.

I have submitted the diagnostics report. The confirmation number is 2074106163.

I fixed this. It’s the iOS app that is at fault. No number of of attempts at removing and re-adding spotify from the iOS app have worked, However once I removed and re-added spotify via the mac app it’s all working perfectly with my google home mini with the Play:1 as it’s speaker.

 

@Simon B Sonos should fix this one!

Userlevel 6
Badge +16

Hi @phunkyfish, thanks for the update, Sorry for what happened and thanks for sharing your experience about this issue. We’ll surely have this checked with our team for this issue So other users will be guided accordingly.

If you have other questions with your Sonos products and services, feel free to reach out.\

The Sonos community is always here to help.

This still does not work when using the apps on iPad.  Frustrating that this has not been resolved.

Userlevel 7
Badge +18

Hi @Joswald94123 

I recommend you, and anyone else having this issue, get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

I had this same issue and here’s what fixed it: 

Go into the Google Assistant app and press on your profile to open the settings. From there, press Devices and go into the menu for whichever your Sonos system is. Under “Default music speaker,” make sure the one selected is the Sonos that you’re trying to play from. I, for whatever reason, had two identical “Kitchen” speakers, one inactive (causing the issue) and the right one (pressing on which solved the issue).

Hope this helps.  

Hi!

I ran into the same issue. I double and triple checked that Spotify is added to my Google account and that the Sonos speaker I was trying to use was set up as the default music device. 

The issue, however, as someone mentioned here above was not on the Google Assistant iOS app side but on the Sonos iOS app side. Despite the guided setup, the app fails to complete one last step: Authorize Spotify in Sonos on this device. I went to Settings > Music & Content > Spotify and authorized again on this iOS device through connecting to Spotify. 

After this step my speaker was able to play Spotify via voice command to Google Assistant. 

 

Some of the solutions above did not work for me - the way I solved was signing into the Spotify website on my desktop, go to account settings, then apps, and then “remove access” to Sonos. Then I reenabled via the standard process and everything was solved!

Some of the solutions above did not work for me - the way I solved was signing into the Spotify website on my desktop, go to account settings, then apps, and then “remove access” to Sonos. Then I reenabled via the standard process and everything was solved!

This fixed it for me as well.  thanks!

Some of the solutions above did not work for me - the way I solved was signing into the Spotify website on my desktop, go to account settings, then apps, and then “remove access” to Sonos. Then I reenabled via the standard process and everything was solved!

This worked for me! Thanks!

Reply