Google Assistant Sleep Sounds Bug

Google Assistant sleep sounds now work on my Sonos.  However, whenever the sleep sounds are about to end (1 hour I believe is the default), Google Assistant shouts out “SORRY, I DO NOT UNDERSTAND” or something to that affect.  Obviously not good, I’m asleep by this time only to get woke back up!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 5
Badge +8

Oh well, it’s nice to hear that something new is working, even if buggy. At one time I used to use “rain sound” on Google Home, but GA on Sonos said it wasn’t supported. I also have an Echo Dot in the same room set to send media output to Sonos, but it refuses to do so for sleep sounds because that skill is not to now allow it for some reason.

Userlevel 5
Badge +8

I let it run for more than an hour, and I didn’t hear a shout out at the end. Might have been a unique event with your system.

Userlevel 2
Badge +3

Well!!! I am glad that I am bored at work and able to surf around… I would have missed this completely. Exciting!!! Is this something that has to be set in Routines? My Goodnight routine plays sleep sounds but normally it plays from the Nest hub. I will try this when I get home and see if I get the same thing. 

Try saying “Hey Google, let me hear the sound of rain for one minute”  When one minute is up, GA will say “Sorry, I do not understand”.  Note that the sleep sound rain does keep playing.  Now for some reason when the rain sleep sound ends automatically in one hour, GA does the same thing.  For what it is worth, and I hope I made sense. 

Now what is really frustrated is that my NON Sonos smart speaker works fine and doesn’t do this.

I play sleep sounds using the Google Home Bedtime routine.  I now believe the problem is with Sonos not liking the routine, although I have no idea why.  Can someone test that for me??  When I directly give the command to play rain sleep sounds, it works fine… the rain sleep sound ends in one hour without the google assistant shouting at me.  When the rain sleep sounds is playing using the google home routine bedtime, after an hour the google assistant yells “SORRY, I DO NOT UNDERSTAND”

I found a work around.  In the google bedtime routine, if I select the radio button beside sleep sounds, I get GA yelling at me in an hour.  If I use a manual typed in command (action), in this case “Play rain sleep sounds”, it works fine.  It sure is disappointing that Sonos implementation of voice assistants is mediocre at best.


Exact same problem here. I ask GA to play sea sounds for 20mminutes as this helps me to get to sleep. Then after the 20’minutes I get the assistant screaming SORRY I DO NOT UNDERSTAND.  this wakes me up, oh and yes the sea sounds keep playing. What the *bleep*?   Can someone from Sonos investigate?

Userlevel 4
Badge +12

Hi Everyone, sorry for the late response and thank you for reaching out.

For any issues we’re having with the Google Assistant; here are some helpful tips for using Google Assistant.

Help and tips for Google Assistant on Sonos

If you’re still having issues, the last recommendation in the support article is to call our Phone Support.

If you have other concerns, feel free to reach out.


Yeah obviously the answer is not in there… how come enare getting ploed with these silly references to FAQs that fix diddly squad?! Come on waiting for a REAL ANSWER here

Userlevel 4
Badge +12

Hi @Sara_G, thank you for the update.

If none of the Support link suggestions didn’t work then there’s not much we could do; other than calling our Phone Support to troubleshoot the issue live with you.

They’ll have more options and they have the capacity to escalate the issue if need be.

If you have other concerns, feel free to reach out.


Unfortunately I have a very bad experience with calling Sonos support on a similar Google assistant issue. Support rep was very friendly but kept referring me to Google. And Google then refers to Sonos. Not the best customer journey in my opinion. But you know what!? I’ll give it a go tomorrow and report back in. Have a nice evening