And the voice announce problem just got worse...

  • 21 February 2024
  • 8 replies
  • 96 views

Userlevel 5
Badge +8

Several months ago Google Assistant started responding “I didn’t understand” to commands in Google automation routines that were supposed to announce something on the initiating Sonos speaker. This bug is still present and I don’t think it was ever acknowledged or addressed by Sonos or Google. Only Sonos speakers are affected - all other Google Assistant speakers continue to perform this action just fine. Fortunately there was a workaround in the case of routines that are only ever used on the Sonos speaker: modify the routine to always make the announcement specifically on the Sonos speaker rather than “on the initiating speaker”.

Today things got worse. Google Assistant on Sonos has started responding “I didn’t understand” even when the announcement in the routine is specifically sent to the Sonos speaker.

I guess this is the next step in Google trying to put the screws to Sonos and Sonos trying to abandon Google Assistant?


8 replies

Userlevel 5
Badge +8

And today it’s spontaneously back to working with announcements made to the Sonos speaker specifically.

You already know what they said. No known problem. Someone will look into it. Have your tried all the usual useless reset/update/re-link steps...

 

Just stop with the abuse.  The poster is trying to help you, and has no ability to fix your problems if the solution does indeed lie with Sonos.

 

Moderator Note: Modified in accordance with the Community Code of Conduct.

Userlevel 5
Badge +8

What did Sonos Support say, when you called in to discuss your diagnostic submission?

You already know what they said. No known problem. Someone will look into it. Have your tried all the usual useless reset/update/re-link steps...

What did Sonos Support say, when you called in to discuss your diagnostic submission?

Userlevel 5
Badge +8

… and it’s back. Google Assistant on Sonos is again responding “Sorry, I didn’t understand” after any attempt by an automation routine to make an announcement on the Sonos speaker.

Userlevel 5
Badge +8

Some time in the past few days the most recent problem has been fixed. Announcements made to “speaker that started the routine” still fail for Sonos, but now announcements made to the Sonos speaker specifically are working again.

Userlevel 5
Badge +8

What have you tried to do about this? 

See 

 

Userlevel 7
Badge +17

What have you tried to do about this? 

Reply