Won't Update Music Library

  • 24 November 2021
  • 14 replies

Userlevel 4
Badge +9

Trying to update my Music Library. Getting the message:


However, that path is absolutely available.


Additionally, I am literally listening to music in that Library right now. Sonos can find it, Windows can find it, it just won’t update.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

Since Sonos uses SMB and NTML in order to “read” an NAS, showing that Windows can see it doesn’t really tell us much, since it uses an entirely different protocol.

I’d recommend checking your NAS to see if there was a firmware update that turned off SMB v1 and/or NTML v1.

Userlevel 4
Badge +9

Why would it be able to play from the NAS but unable to read from the NAS?

Since I didn’t write the code, nor do I have access to it to see how the pathways work ,if they possibly work on two separate paths, I don’t really know. It was merely a potential solution, feel free to ignore if it offends your sensibilities. 

Userlevel 4
Badge +9

“Offends sensibilities” is a little harsh: “If that’s a cause, how does it explain the facts on the ground” is one of the most basic troubleshooting questions, to avoid spending time (and potentially making things worse) chasing potential ghosts.


I have re-mapped the drive, successfully (Manage => Music Library Settings => Add Folder), yet it still gives me the same message when I try to update the same drive. So any time I add new music I need to remove the folder and add it again. Very frustrating.


Userlevel 4
Badge +9

Now it’s even worse.

I can show screenshots if necessary, but I have tried to use both the Android and the Windows app to re-update my Library.

In Windows, I click Manage=>Music Library Settings=>Add

I select :

  • “Networked Device (NAS)”
  • Browse
  • Network
  • The Drive (“RJB-MEDIADRIVE”)
  • The next triangle-open is “sda1”
  • The folder with my music (“Seattle Music Library”)
  • OK

The path shows correctly - “\\RJB-MEDIADRIVE\sda1\Seattle Music Library” so I click “Add”

I get the “’Seattle Music Library’ is now being set up on your system” message

The Settings window puts up its spirograph with “Updating Music Library… Please wait.”

Then I get the window:


I mean, it is LITERALLY right there. I JUST selected it IN THE SONOS APP.


Yes I have rebooted. EVERYTHING.

I am so tired of rebooting and reinstalling all of my Sonos products, but I just want this to work like it used to.

Someone please help.




I experience the same problems….the system has worked for years without any problems when accessing my QNAP Music Library. Now it’s not working at all. I’m able to add the path to the music library and it’s accepting the access to the NAS and it start indexing. However, the path never shows up in the settings afterwards. I’ve tried to cable one of my speakers (instead of using the boost) - but it does not help.


My conclusion is that the new SMB-module is erroneous. I’ve tried to close down the SMB1 protocol on the NAS, or close down SMB2 and SMB3 but nothing helps.


So now I’m just waiting for an update of SONOS……


An addition….when adding the setup information to the library, nothing really happens, but the music stops playing on all speakers. So perhaps the bug in the SMB/music library involves more than just the music library….?

Curious as to what Sonos said when you contacted them? This still sounds like an update to the OS on your NAS that made a change that blocks the Sonos devices (not your computer) from reaching the data on your NAS. And particularly if you’re running S1 on your Sonos, the requirement remains SMB v1 and NTML 1. It’s fairly common for updates to the NAS to turn off these option, requiring you to have to go in and change them back. But ultimately, providing a diagnostic to Sonos, and calling in to discuss that would likely uncover the ‘real’ issue with the hard data. And more quickly than ‘waiting for an ’update’ ever would, since they have no real clue what the issue is you’re trying to deal with. 

Userlevel 4
Badge +9

There are no firmware updates for my drive.

I’m running S2.

Calling in may be the option, but getting away and letting someone offline tinker with my home network is kinda fraught during a weekday, but if that’s what it is has to be. (It doesn’[t help that their 24/7 assistance is a chatbot that doesn’t understand much.)


Userlevel 4
Badge +9

It’s a Seagate drive attached to a TP-Link router. So if there are SMB settings anywhere (other than on my PC/client), I can’t find them.


Suddenly my sonos music library works again - I just retried to scan again and again….the cover art is however gone or works very slowly, which is strange… I still suspects the Sonos update to be the issue…and others complain about problems. It is probably the smb-improvement in the latest update that is buggy.

Userlevel 4
Badge +9

Hour with online tech help - had me mess with firewall on my PC (which wouldn’t explain why it won’t install from other operating systems’ devices, but still) then finally said had to speak to someone live. So another 90 minutes of them repeating everything we just did, and still nowhere.

Next step, apparently, is they wanted me to reboot router… And, of course, they can only give live support during business hours which is exactly when having my network up and running is mission critical…

MY next step may be to spray the whole thing with Raid and see if that gets the bugs out.

Userlevel 4
Badge +9

Had to rename the drive and now it’s connected. Don’t know if it will update on its nightly sweep - the proof of that pudding will be tonight.

BUT. (And if this needs a new thread, will do so)

All of my playlists are gone. Which I guess makes sense. But is there anywhere I’ll find even text files with the playlist contents?


(I have found that if I double click on my devices, there are subfolders in “Saved Queues”, each one named for individual playlists, but they appear to be empty.)

Userlevel 4
Badge +9

It did NOT update on its nightly sweep.