Storytel does not work properly with Sonos S1. Logs provided.

Hi there! 

I have been using Storytel for over 1,5 years in my Sonos S1 system. It has always worked perfectly. 

Since about 1,5 weeks, I cannot search nor browse Storytel content. 

I have tried to restart all my devices and also removed and readded my Storytel account. I can add it properly like before, but no content is available any more. 

All my other services like Spotify, SR (Swedish radio) and many others work perfectly fine. 

Logs here:


There is nothing wrong with my Storytel account. When I use their app, it works 100% fine. 

Thanks for any kind of assistance in this matter! 




Best answer by Thony 24 October 2022, 16:30

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Having the exact same issue as described above, also for the past approx 10 days. 

Did the same tests also, with no luck. Storytel works fine on my iPhone. I did however notice that Storytel books previously added to Sonos playlists still works. So it’s probably related to searching for books, not actually playing books.

Have either of you contacted Storytel?

Thanks for your replies. Sad for your issues but happy that I am not alone. 😀 

I have not contacted Storytel yet. Mainly since their app works 200% fine, so I figured I would start with Sonos as step #1. 

It’s extremely likely that the Server that feeds the Sonos stream is completely different than the one that feeds their own app. 

Same probleme here, anyone contacted storytel? 

Yes, I contacted Storytel’s support. If the account works (adding the account to Sonos), that’s how far they support - for other questions or problems they send me to Sonos.

Heb ook een bericht naar Storytel gestuurd.



De integratie met sonos werkt niet meer sinds een 10-tal dagen.   Het is niet mogelijk om te browsen. 

Het is toch niet aan de gebruiker om dit uit te zoeken met Sonos, kunnen jullie zelf geen test doen?


Hi again!

I was in contact with a swedish chat agent from Sonos just now. I asked them to reply here but he gave no promises on this. He would however follow-up internally.

He did verify that there “seems to be an issue”, but probably only related to S1-installations.

Let’s see where this goes from now.

Antwoord van support Storytel:

Bedankt voor je vraag.

We zijn ons bewust van het probleem en onze technische afdeling werkt aan het oplossen van het probleem.

Mijn excuses voor het ongemak.


Moderator notes: Translated from Google.

Response from support Storytel:
Thank you for your question.
We are aware of the issue and our technical department is working to resolve the issue.
I apologize for the inconvenience.

Would be great to stick to English in this thread. 

I have the same issue and it has been persistent the last aporox. 2 weeks. And it is Sonos S1. Everything else works fine apart from Storytel. The account is active and I can use the stabdalone Storytel app but not with Sonos. Help please! 

Same problem on S1 installation in Oslo for almost a week now. Kids would love to finish their audiobooks soon :D 

I got this response just now:

Using the information you have sent, I have now forwarded your information to our technical department so that they can look into this. Thank you for bringing this issue to our attention, we will do everything we can to get it sorted out as quickly as possible!
I wish you a great Wednesday!
Kind regards,


Let’s wait and see…

Would be good if someone offical from Sonos could respond here and also push this issue to Storytel for a solution.

Storytel is working for me now with sonos S1.


Storytel is working for me now with sonos S1.


Does browsing categories also work for you ? I can search but not browse the categories last i tried, not tried since friday evening though.