Answered

Stingray "unable to browse"

  • 21 October 2023
  • 5 replies
  • 76 views

Stingray services won’t play. It opens but has lost all my history, favourites, etc. It shows only Recommendations and My Music, and when I open one, it says “unable to browse music.”

I have deleted and re-added Stingray numerous times. I’ve reauthorized the Stingray. I’ve updated the Sonos desktop and other device apps. Both apps are on the same wifi network in my house. Nothing has changed except I’ve lost access to all the Stingray channels. Why????

icon

Best answer by Corry P 25 October 2023, 13:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Have you rebooted your router, followed by a reboot of your speakers? It sounds like there is something blocking the Sonos speakers from reaching out to Stingray’s music servers (but oddly, not their authorization servers). This could be a DNS change that hasn’t been propagated properly to your router, and hence the speakers, or it could be some other port blocking software, like a VPN or something similar. It’s also possible that Stingray’s server is down. Sonos’ status page is updated by a human, and not automatic, so there can be a delay between losing access and it showing up on sonos.status.com. There may be value in reaching out to Stingray’s service directly. 

Thanks for your thoughts, Airgetlam. I just tried the router fix. Weirdly, the router required several attempts at a reboot before it finally came on again. But still no dice. The other services like Heart Radio, CBC, Calm, etc., all work fine. It’s just Stingray. I’ve written to them as well. Frustrating.

That’s why I think it may be a server issue on their side (or a DNS issue, but that would have Ben resolved by a router reboot followed by a speaker reboot). The fact that all other streams are working normally points in that direction. Unfortunately, streams you get on your Sonos aren’t ever on Sonos owned servers.

Userlevel 7
Badge +18

Hi @RobSVic 

Welcome to the Sonos Community!

Weirdly, the router required several attempts at a reboot before it finally came on again.

To me, this is a bit of a red flag - if the router can’t be trusted to boot properly, what else can’t it do? Personally, I would try rebooting it again (turn it off for at least 30 seconds), and if you see similar behaviour, contact the manufacturer/supplier of your router.

In regards to the problem you are having browsing Stingray on your Sonos system, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports - the logs should give some indication as to where things are going wrong.

I hope this helps.

 

Thanks,  Corry. I’m currently in a dialogue with Stingray. Apparently, there are a few of their customers who access their accounts via Telus, who are having similar problems, so it might be at their end. I’ll report back when I get answers.