Sonos cannot connect to library after Ventura 13.4 update

After updating to Ventura 13.4, the Sonos controller cannot connect to the library.. have tried reinstalling the app and removing the lib but fails when connecting to the app stating the computer refused to let Sonos access the folder ...

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Userlevel 7
Badge +17

Did you give the Sonos app the right permissions in the OS’s settings?

Of course and everything worked before the update….

This is most likely a result of a change in the way the updated OS handles permissions and the Sonos app needs an update 

Try deleting the app from your Mac, download a fresh copy from Sonos, and reinstall. Unfortunately, I’m not at home to do any testing, but I suspect that the install of the new OS killed a background app that is needed to access the data. If I’m right, a reinstall should reinitialize that app. 

@Airgetlam   That was my thought as well and have worked in the past… But this time, this approach did not work. Still suspect that there’s something new in the lastest OS update preventing Sonos app to “do it’s thing” ...

It’s interesting. I don’t recall any significant issue on either my Intel Mac or my M1 Mac at the point they were upgraded to Ventura. I do tend to stay away from beta release versions, such as Sonoma, merely as I can’t expect Sonos to constantly be chasing the ongoing changes. 

What did Sonos Support say, when you called in to discuss it?

@Airgetlam As this was a proper MacOS release I didn’t expect any issues and I’m still waiting to hear back from Sonos Support …. 

What did they say in your initial contact with them?

Essentially making sure I had file share turned on, sharing with open access etc … Nothing I didn’t look at first.

The thing they seem to forget is that everything worked before the upgrade but not after …

Ergo the update itself changed something in the privileges or Sonos lib manager access to prevent it from working :-(

At least someone is looking at it. Again, it’s really odd to me, as I didn’t have any issues at all when I updated. 

I got an “can’t update now” error message as well.  I resolved it by going into System Settings: Privacy & Security:  Media and Apple Music. I deleted Sonos app from the list of apps allowed to access Apple Music etc and then added it back on.
That cleared up the access issue on my computer.

Interesting. That’s the first time I’ve heard of that as a resolution, thank you for letting all of us know!

Having the same issue.  

MacOS Ventura 13.5 and SONOS 15.7.

MacOS permissions for SONOS enabled under accessibility settings, but it’s still not connecting to my itunes library.