samba share

  • 26 December 2021
  • 4 replies

  • Contributor I
  • 0 replies

Hi, there are several posts on adding a samba share for old sonos systems, including on this forum that reference:

setting ntlm auth=yes

in smb.conf

I tried this and various other settings before eventually scoring with this solution:

server min protocol = NT1

as indicated here

It seems this is needed for newer samba systems to use the old SMB1 protocol which the old sonos systems use.

Hope this helps someone.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Use of the Sonos S1 operating system requires SMB v1 to access data on an NAS. 

Sonos S2 operating system was recently updated to allow up to SMV v3, to access data on an NAS. 

I have a pair of old Play:1’s  The hardware remains excellent, but I am reticent to update to the bloated S2, and recently made the mistake of updating to S1 from 8.4.2  This has caused all sorts of issues with my ASUS router running samba.  While the router can be forced to use SMB1 (only) and all my other network appliances connect to it fine, my Play:1’s will lose the ability to update the library from time-to-time, and when I try to re-add the connection, the “Updating Music Library… Please Wait” icon keeps spinning.

Two questions:

  • Is there a way to clear out the speakers to properly re-initialize and accept the Samba connection, without resetting all the services on the speakers?
  • While I have set read-write (R/W) privileges for the user logging into my Samba server, will Samba 1 on these speakers work with simply a Read setting?  At least then I can eliminate the possibility of the speakers corrupting the shared directories on my router’s samba server.


  1. Simply unplugging the speakers from power, then plugging them back in after a minute forces the OS and all associated connections to reconnect. Not sure I understand any connection between ‘services’ and SMB. SMB is only used by Sonos to contact your NAS and gather data and play music, it is not used by any other process. 
  2. It should, to my knowledge there is no writing of data to an NAS at all. The data garnered is stored in Sonos’ own memory, and never written out to any other device. 
Userlevel 5
Badge +9

Depending on what ASUS router you have try Merlin's firmware as there must be some differences in the implementation of SMB1 and it has worked for me.