Answered

How to remove home Wifi from Networks list in the App?

  • 18 March 2023
  • 15 replies
  • 336 views

Userlevel 4
Badge +3
  • Enthusiast II
  • 44 replies

I want to remove my home Wifi from the Neworks list in the app, and get all my Sonos products back to communicating on the usual Sonos wifi mesh.  I am on S1.

I found a forum post which says this is possible, but for the life of me I can’t find where/how to do this.

Is anyone able to help, please? I’d be very grateful!

 

Here’s some further information on my set up, in case this is relevant:

Most of my Sonos devices are cat5-wired to my router, and have wifi disabled on them all.  I have one wired box (a Beam) with wifi enabled, which then communicates over the usual Sonos mesh with three Sonos devices which are not connected with cat5.  So far so good.  

Recently I had to remove the cat5 cables from a pair of Sonos Ones (so that I would have a total of 5 Sonos devices connected over wifi via the wired Beam).  Getting the wifi enabled and working for these was very very difficult, they simply refused to connect.  After a couple of hours of rebooting and retrying in a myriad of ways, eventually I got them connected by choosing the ‘use my home wifi network’ option.  This at least proved that the wifi functionality of the Ones is working and they seem to be working now most of the time.  However, I do want to revert them to the usual Sonos mesh, so that they don’t break every time I change my wifi password and also because the experience here appears to be that the Sonos mesh will be a bit more reliable for me.  But there is no option to delete the home wifi network and re-add the two devices which are currently using it.

By looking at the Sonos Support Info network matrix, I can see that my existing wireless Sonos boxes are still communicating over the Sonos wireless.  Only the two Sonos Ones seem to be showing as not on the Sonos mesh (and therefore using the home Wifi).

One idea was to reset everything to default config and do a fresh set up of all my kit.  But having hunted around the app I am unsure if even this is possible?

icon

Best answer by 106rallye 19 March 2023, 10:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Userlevel 7
Badge +20

FYI - I never turn Wi-Fi off on any of my Sonos devices and use SonosNet to connect.  

If you open the Sonos App>Settings>Network>Manage Networks you should see your Home Wi-Fi listed, just select the minus sign and it will remove the credentials from your Sonos Set-Up. 

Please see: Disable or enable Wi-Fi on your Sonos products | Sonos

Userlevel 4
Badge +3

Thank you UKMedia!

However, I don’t have a minus button. There are no controls at all on the Networks list.  And neither pressing, swiping nor everything else I can think of reveal any controls.

Is anyone able to shed any light on this?

Userlevel 7
Badge +20

I was following the S2 app instructions as that's the version I have installed, sorry.

 

Do you have a Reset WiFi or something similar under Network?

Let’s backup a little. Why do you want to disable all SONOS radios?

As you’ve discovered, disabling radios can have awkward consequences. In some respects this could be similar to someone moving the ladder back into the storage shed while you are still on the roof.

Userlevel 4
Badge +3

I’m not seeking to disable Wi-Fi completely.  I want to remove the ‘use my own Wi-Fi’ thing.  And then I guess re-add the Sonos Ones via the default Sonos Wi-Fi mesh network.

No, there doesn’t seem to be any kind of ‘Reset Wi-Fi’ command under Network.  I’ll post some screenshots later today.

Userlevel 4
Badge +3

Here is what the network list looks like.

No controls at all!  What can I do?

 

Userlevel 7
Badge +17

Maybe you can’t remove a network that is in use? Could you push the speakers off your wifi by temporarily stopping the Pink Panther network? Or, since you mentioning changing the password frequently, changing the password again?

Userlevel 7
Badge +20

What happens if you select Pink Panther?

Isn’t that screen just showing what networks are available, not necessarily in use? I’m unsure as to why you’re trying to erase the ability of Sonos to identify available networks that it can join. 

Peck,

Within a couple minutes of wiring one or more SONOS units to the network, your SONOS units will automatically switch to SonosNet and ignore WiFi. Note that ROAM and MOVE always use WiFi. Unless you are using the appropriate USB dongle, the ERA units will also use WiFi.

My play 1 speakers won’t get recognized by my iPhone tried everything suggested by Sono’s but nothing. Help

 

Ron,

Your issue has nothing whatsoever to do with this thread, you’d be better off opening a new thread. 

That being said, wire one of your PLAY:1s to the router directly with an Ethernet cable, wait 5 minutes, then test. If that doesn’t work, open that new thread, you’ll get assistance there. 

Thanks so much.

 

Userlevel 4
Badge +3

Peck,

Within a couple minutes of wiring one or more SONOS units to the network, your SONOS units will automatically switch to SonosNet and ignore WiFi. Note that ROAM and MOVE always use WiFi. Unless you are using the appropriate USB dongle, the ERA units will also use WiFi.

Actually, this doesn’t seem quite right.  The Sonos One’s were connecting via the home’s Wifi, and remained connected on the home’s Wifi, even though there was a nearby SonosNet-enabled unit wired to the hub.

I deduced this principally from the Network Matrix.  No SonosNet connection was shown on this from my Sonos One’s.  And also my ‘PinkPanther’ wifi network was showing as ‘in use’.

Userlevel 4
Badge +3

Maybe you can’t remove a network that is in use? Could you push the speakers off your wifi by temporarily stopping the Pink Panther network? Or, since you mentioning changing the password frequently, changing the password again?

This has cracked it!  Thanks!

The System->Network->Networks page listed the Wifi network that was ‘In Use’ for me - and it was because it was in use, there was no option to remove it from the config, ie stopping my Sonos products using it.  

I managed to sort this, by turning off power to my Sonos Ones, then the ‘minus’ sign appeared next to PinkPanther, and I could delete it. I then ALSO needed to factory reset each of the Sonos Ones as I turned them on (holding down the connect button as it powered up), otherwise PinkPanther reappeared on the list and the Sonos Ones used it.

All that remained then was to ‘Add Product’ to re-add my Sonos Ones to my Sonos set up.  This took 3 or 4 attempts for some reason before it worked, but the system recognised them eventually.

The Network Matrix now shows the SonosNet connections from the Sonos Ones to the nearest wired SonosNet unit.  Been quite a mission, but pleased to sort it in the end.

Thanks all!