Does Sonos update cause Connect Skipping?

  • 22 February 2022
  • 5 replies
  • 92 views

Sonos Connect suddenly started skipping last week after the release of 14.0.4. It won’t play any music via Sonos Radio, Apple Music, or Line-in without skipping. I also have a Sonos Arc that plays fine and does not have this issue. Does anyone know if the Sonos Connect is suffering from software obsolescence and must be replaced by the Sonos Port?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Have you tried unplugging the Connect from power for a couple of minutes and rebooting your router?

It’s not uncommon for routers to hand out bad / duplicate IP addresses when the Sonos asks for a new one as part of the software update process. As @GuitarSuperstar suggests, unplugging all Sonos devices, then rebooting / refreshing the router, and finally plugging back in the Sonos will resolve this, at least until the next time. 

A more permanent solution is to assign reserved IP addresses for all Sonos devices in your router’s DHCP table, a process that is explained in your router’s manual, as it differs in different routers. 

Thank you for your inputs. I’ve restarted all devices (router, connect, phone) and nothing’s fixed this issue. I’ve also changed the channel on the Sonos. 

It’s key that the order is followed, if you don’t shut down all Sonos devices while the router is rebooted, they’ll hold on to the ‘bad’ IP addresses. 

However, if you did, it may be time to submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Thank you. I’ve done this and sent several system diagnostics to Sonos tech support. After an hour and a half on the phone the culprit appears to be the Sonos Connect. This is why I’ve inquired with other users to see if others are finding similar skipping issues with their device.