Cannot add or update Music Library on USB disk with MacOS Ventura

  • 19 November 2022
  • 8 replies

Just upgraded to Ventura and I cannot reindex as it gives a permissions problem.

I have given ALLSonos components FULL disk access but no avail. Tried on iPad and all other Macs same issue. 

So deleted pathway and tried to  add it, again no avail cannot add external drive.

Can run apples music app and plays fine.

Any ideas ?



Best answer by LastK 29 November 2022, 11:48

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Perhaps see if this link will help you to sort it:


All was working well until this latest update


All was working well until this latest update

Maybe some security/firewall setting in Ventura then? … I’m not a MAC user, but came across this in another thread albeit it relates to BigSur, but not sure if it may assist you. or not:


Thanks Ken,

No there's no firewall issues as there external disk can be read and written to by my Mac and the Music app can access the iTunes folder and play music.

The Sonos apps and services have full disk access.

What makes it worse I cannot add the music folder on the internal hard drive as I get the same warning dialogue box.

This is something that the new version of Ventura has introduced and dare I say it Sonos have been caught napping.

Looking at people that have similar issues this is pretty disappointing.

Thanks Ken for your suggestions, Sonos would you like to get involved?

I found this when searching online - maybe see if it sorts it for you:

Open System Preferences on your Mac. Click on Security > Privacy. Under the Privacy tab, click on Full Disk Access. Check the box next to Sonos Library Server.

Open the Sonos app. Update your music library by going to Manage > Update Music Library Now.

I have the same problem and have tried the above but still getting an error message “The Compute “XXXX” is not responding. Prior to the upgrade everything was working fine. Any one any further thoughts?

Userlevel 7
Badge +18

Hi @LastK & @pjcdyson 

Welcome to the Sonos Community!

I have occasionally come across instances of macOS upgrades changing the network name of the computer. Please ensure yours’ is what Sonos expects it to be, and that there are no punctuation characters in the computer’s network name (Macs typically have hyphens by default). The name should be no more than 16 characters long, should not contain only numbers and should be unique on the network.

Reboot the Mac after changing it’s network name, and remove any existing shares in Sonos. Add a new share from the Sonos desktop app.

It may also help to uninstall and reinstall the Sonos app on the computer to get the HTTP service (the SonosLibraryService process) working properly after each bootup.

If you still struggle, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Hi All,

Spent some time with Jeff from Sonos this morning and now resolved.

The issue was to delete all shares, remove the path to the external drive then create one at a time  the services ensuring correct permission as you go.

Big thanks to Jeff, excellent service.